1 2 Previous Next 21 Replies Latest reply: Feb 7, 2014 5:52 AM by T573
kellystiner Level 1 Level 1 (0 points)

The ethernet Port on the back of the IMac will not work. the wireless works great but no connection on the Ethernet and DSL modem


iMac, Mac OS X (10.6.6)
  • 1. Re: Ethernet port not working
    daniel Azuelos Level 2 Level 2 (335 points)

    kellystiner wrote:

     

    The ethernet Port on the back of the IMac will not work. the wireless works great but no connection on the Ethernet and DSL modem

    Is your problem still there?

    Could you type the following command in a Teminal window and post the

    output :

        netstat -I en0 

    (en0 is the short name of the Ethernet interface)

    Could you check if a restart of your MacOS X does fix your problem?

    -- 
    dan
  • 2. Re: Ethernet port not working
    mitchfromflagstaff Level 1 Level 1 (0 points)

    I have the same problem, wireless is working but says my ethernet is not plugged in and it is. I plugged it into my daughters Mac book and it shows it on hers??

  • 3. Re: Ethernet port not working
    kellystiner Level 1 Level 1 (0 points)

    Sorry it took so long to get bakc to you but here is what I have found out.

    a restart did not help

     

    netstat -I en0

    Name  Mtu   Network       Address            Ipkts Ierrs    Opkts Oerrs  Coll

    en0   1500  <Link#4>    **:2c:**:2b:e8:**        0     0        0     0     0

    localhost:

  • 4. Re: Ethernet port not working
    daniel Azuelos Level 2 Level 2 (335 points)

    kellystiner wrote:

    [...]

    netstat -I en0

    Name  Mtu   Network       Address            Ipkts Ierrs    Opkts Oerrs  Coll

    en0   1500  <Link#4>    **:2c:**:2b:e8:**        0     0        0     0     0

    localhost:

    Your Ethernet card doesn't exhibit any sign of an hardware fault.

    Hence I advise you to perform an SMC reset .

    -- 
    dan
  • 5. Re: Ethernet port not working
    kiran_mbbs Level 1 Level 1 (0 points)

    hi daniel even i have same complaint i tried netstat -I enO in terminal & this is the result "Name Mtu Network Address Ipkts Ierrs Opkts Oerrs Coll" what does this mean?

  • 6. Re: Ethernet port not working
    FrederikY Level 1 Level 1 (0 points)

    I have the same problems!

    Have you found a solution?

  • 7. Re: Ethernet port not working
    mitchfromflagstaff Level 1 Level 1 (0 points)

    My imac was 1 month old, they gave me a new one.

  • 8. Re: Ethernet port not working
    FrederikY Level 1 Level 1 (0 points)

    You went to an Apple Store?

    Or via UPS/etc?

  • 9. Re: Ethernet port not working
    Marc Van Olmen2 Level 1 Level 1 (70 points)

    I have the same problem. Brand new iMac Mini was working fine for 2 months and ethernet port died. The wifi worked fine. I went to my local Apple Store and they replaced the motherboard for me. (That was 2 months ago) Yesterday same problem happend, the ethernet port is again dead, and Wifi still works.

     

    Marc

  • 10. Re: Ethernet port not working
    FrederikY Level 1 Level 1 (0 points)

    Well I just brought my iMac to an Apple Reseller on Tuesday, and got it back Friday.

     

    AND IT WORKS NOW!

     

    They replaced the LogicBoard.

  • 11. Re: Ethernet port not working
    IllegalAlias Level 1 Level 1 (0 points)

    Did you ever resolve the issue? I had a similar problem, appeared to be a hardware failure but turned out to be a network configuration issue. Very simple but non-intuitive fix.

  • 12. Re: Ethernet port not working
    Marc Van Olmen2 Level 1 Level 1 (70 points)

    I brought the MacMini to the Apple Certified repair store:

    • They did some tests and they claimed that everything is working fine on their network.

    • They claim that my local internet provider is at cause. (this setup is in Belgium and they claim that a lot of Telenet customers having issues).

     

    Configuration I have is the following:

     

    • Cable Modem + Integrated router

    -> Long ethernet cable  -> that goes directly to the Macmini

    • This connection worked fine for 2 months and suddenly it stops working. (see previous posting)

     

    But when I try the following setup

     

    • Cable Modem + Integrated router

    -> Long ethernet cable  -> to another Wirless router (has 4 ports) next to the MacMini

    -> I connect the Macmini with this Wirless router  through another ethernet cable

    -> After 5 minutes or so the Macmini looses its internet connection and port becomes unusable.

     

    If I instead use the WIFI connection to connect to this new Wirless router I don't have any drops and everything works fine.

     

    Apple just release this week a new Firmware for the Macmini late 2011 and I applied that this didn't gave any difference.

     

    I still can't explain why an ethernet port would fail after 5 minutes, only explanation I can find is hardware failure.

     

    Could there be another explanation?

  • 13. Re: Ethernet port not working
    IllegalAlias Level 1 Level 1 (0 points)

    If I understand you correctly, you are able to connect via ethernet but it loses the connection after a few minutes. WiFi works fine.

     

    This sounds different than what my issue was as you seem to connect via Ethernet but only for a short time. My issue was that I could not connect directly via ethernet at all. My Mac System report said it was unable to find an ethernet card installed. In the Network preferences pane, the troubleshooting assistant said that there was no cable attached (there was, and I also tried a different cable). Hardware Test did not find any problem. The Apple repair tech thought the port was bad and was going to replace the logic board (second time).

     

    Another tech looked at my network settings and discovered what the problem was.  In Network Settings on the left panel it said Ethernet connected and the status was "Ethernet is currently active and connected to (xyz) Network". Also, on the left panel of the Network Preference Panel, below Ethernet, WiFi was said to be OFF. The technician noticed that the symbol to the right of the network status (Ethernet, WiFi, Firewire, Bluetooth, etc.) was incorrect for an Ethernet setup. Instead of showing the Ethernet symbol it showed the icon for WiFi. Even though it SAID Ethernet, it was really setup as a wireless connection. He created a new connection, and under Interface created a new setup called "Ethernet" and with Service Name of Ethernet. Apparently the first time in the shop the technician had actually created a WiFi connection but named it Ethernet by mistake.

  • 14. Re: Ethernet port not working
    gasflame Level 1 Level 1 (0 points)

    Hi,

    I have had this problem with my old iMac 24" and now my newer (20 month old) iMac 27".

    Have had both these machines to Apple and have been told that the ethernet port is faulty. The only solution is an expensive board replacement.

     

    This appears to be a serious weakness with the iMac, as I know of others with the same problem.

     

    My 4 year old PC (Windows OS) on the same network, does not have a ethernet problem, neither does my Macbook Pro.

     

    GS

1 2 Previous Next