Skip navigation

stop office opening previous file

64848 Views 34 Replies Latest reply: Apr 8, 2014 2:20 PM by maninblack9 RSS
1 2 3 Previous Next
cisconet1234 Calculating status...
Currently Being Moderated
Jul 22, 2011 8:23 PM

Hi,

 

I am using MS Office 2010 and I had just upgraded my OS from Snow Leopard to Lion. After the upgrade, I had observed that each time I open my MS Word/Excel, it keeps opening those previous file that I had opened before.

 

How can i stop this? I hope to revert to the old times where each time i open Word/Excel, it would be a new document and NOT it automatically open those previous files.

 

Pls advise.


Thank-You

 

Roy

Mac OS X (10.7)
  • RodneyW Level 4 Level 4 (3,030 points)
    Currently Being Moderated
    Jul 22, 2011 8:56 PM (in response to cisconet1234)

    With Lion's default settings, you have to explicitly close the document before you close the application. If you do this, the next time the application starts, it will go to a new document.

     

    To change this back to the old way, simply go to System Preferences -> General and untick "Restore windows when quitting and reopening apps"

  • kurtgonska Calculating status...
    Currently Being Moderated
    Aug 4, 2011 4:49 PM (in response to RodneyW)

    But is there a way to stop only Microsoft Word (or, for that matter, any other individual program) from reopneing the last document?

  • A. Timleck Level 2 Level 2 (275 points)
    Currently Being Moderated
    Aug 4, 2011 11:05 PM (in response to kurtgonska)

    Yes, like what kurt said... this is annoying. Firefox, for example, will save your last windowed views, if you want - it shouldn't be system wide. For example, working on a document and need to run out, just shut down the machine, then when I restart it opens ALL the previous windows, and sometimes they're on other servers in the house so that takes FOREVER because the server has to mount etc., then they all open, then I get to make a new document. Not cool, or useful.

  • A. Timleck Level 2 Level 2 (275 points)
    Currently Being Moderated
    Aug 4, 2011 11:08 PM (in response to cisconet1234)

    I just found this in the macrumors forums:

     

    Alternatively, for those who want some resume functionality and don't want to globally disable it, you can hold Shift when you launch an application to bypass resume and start that app fresh.

    'Like'

     

    credit to jman240 there.

  • RodneyW Level 4 Level 4 (3,030 points)
    Currently Being Moderated
    Aug 5, 2011 12:19 AM (in response to A. Timleck)

    If you want to permanently disable resume for one app, you can always try this:

     

    http://osxdaily.com/2011/08/01/turn-off-resume-per-app-in-mac-os-x-lion/

     

    Cheers,

     

    Rodney

  • MarkDouma® Level 6 Level 6 (9,845 points)
    Currently Being Moderated
    Aug 5, 2011 12:57 AM (in response to kurtgonska)

    Hold down the Option key when quitting the app in question (assuming you are quitting by choosing Quit from the application's menu rather than the Dock menu). By holding down Option, "Quit" should change to "Quit and Discard Windows".

  • MarkDouma® Level 6 Level 6 (9,845 points)
    Currently Being Moderated
    Aug 5, 2011 6:07 AM (in response to cisconet1234)

    I just finished writing a GUI app to allow editing per-application settings for the window restoration feature:

     

     

     

    Screen Shot 2011-08-05 at 9.05.49 AM.png

     

    http://www.markdouma.com/developer/WindowRestorationFinagler.zip

     

    Hope this helps....

    8-core 2.66GHz Mac Pro (Nehalem) 8 GB RAM, GTX 285 ME; 17" MacBook Pro 2 GB RAM;, Mac OS X (10.6.7), Dual 2.7GHz G5 4.5 GB RAM; -
  • fmonzon Calculating status...
    Currently Being Moderated
    Nov 3, 2011 3:52 PM (in response to MarkDouma®)

    Works well. Thanks!!!

    This was driving me crazy.

  • ojvave Calculating status...
    Currently Being Moderated
    Dec 4, 2011 11:31 AM (in response to MarkDouma®)

    Darg! This didn't work.

     

    I don't know what happened, but it's like something went wrong with my machnine a couple weeks ago and now EVERY application (Office Aps, Firefox, Preview, etc) continually opens old files no matter what I do. I've turned this functinality off at the system level. I've tried the program from above...nothing works.

     

    At about the same time, I suddenly needed to type in my password to do just about ANYTHING. I don't recall doing any major system upgrades, though I wouldn't be surprised if there was a system update or something.

  • ojvave Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2011 11:33 AM (in response to MarkDouma®)

    Hold down the Option key when quitting the app in question (assuming you are quitting by choosing Quit from the application's menu rather than the Dock menu). By holding down Option, "Quit" should change to "Quit and Discard Windows"

     

    You know I've read about this "Quit and Discard Windows" option...It doesn't exist. I get "Quit and Close all Windows" or, if I've turned off the auto-restore, "Quit and Keep All Windows."

  • Carl Perkins Level 2 Level 2 (225 points)
    Currently Being Moderated
    Dec 4, 2011 12:01 PM (in response to cisconet1234)

    I found the feature annoying at first, but now simply close documents before quitting an application. Takes getting used to, but there are benefits: restart the machine and everything is as you left it. Remarkably cool.

     

    Anyway, the excellent freeware TinkerTool allows you to modify this behavior on a per-app basis. It's in the Resume section. Lists each app, pick and choose.

     

    http://www.macupdate.com/app/mac/5721/tinkertool

  • ojvave Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2011 12:18 PM (in response to Carl Perkins)

    Yeah, that'd be great if it that solved the problem. If it did, I probably wouldn't be here looking for help.

     

    To your point, I typically close windows and then quit. My problem here is that no matter what I do, the files keep coming back. Some of them are "recovered" from a crash weeks ago. So, it doesn't matter whether or not I close the windows before I quit or not. They'll show up again.

     

    Thanks for the suggestion!

  • Gordon IV Calculating status...
    Currently Being Moderated
    Dec 6, 2011 12:15 PM (in response to ojvave)

    This seems to have solved the problem for me:

     

    System Preferences > General > un-check "Restore windows when quitting & re-opening apps"

     

    http://www.tech-recipes.com/rx/17168/os-x-lion-disable-apps-opening-with-last-us ed-file-or-web-page/

  • DJ Mandy B Calculating status...
    Currently Being Moderated
    Jan 7, 2012 1:01 PM (in response to ojvave)

    Preview is doing this to me

     

    - i unchecked 'Restore windows when quitting and re-opening apps'

     

    that didnt make the preview files all close.

     

    - when i hold down option and quit preview, it says 'Quit and Keep Windows'

     

     

     

    so i checked the Restore windows when quitting and re-opening apps box again, went to preview and I was then able to Quit and close all windows. Did so, but they are all still there - open.

     

    I even Quit and closed all windows, unchecked the 'Restore windows when quitting and re-opening apps box again before opening Preview - but yep, all those jpgs and pdfs were still there

     

     

    can anyone help me?

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.