Skip navigation

How to connect to embedded POSTGRESQL on Mac OSX Lion Server

37333 Views 41 Replies Latest reply: Apr 5, 2013 11:36 AM by matthewfromdanvers RSS
1 2 3 Previous Next
Yansolo Calculating status...
Currently Being Moderated
Jul 22, 2011 5:59 AM

Hi all,

 

I've upgraded my Mac OSX 10.6 server to 10.7 server 2 days ago.

 

My web sites databases are still under MySQL server cause it's still running after the upgrade.

 

I manage to migrate the databases to PostgreSQL, so i've enabled the wiki from the server.app to launch the PostgreSQL server.

 

I can see that it's now running through a ps -ef | grep sql and that it's listening on the unix domain socket 5432 with netstat -an | grep SQL in a terminal shell.

 

The problem is that I'am unable to connect to it.

 

I tried psql -U postgres, and installed the Navcat for postgreSQL Lite, but they failed to connec to the database server twith the same error :

psql: could not connect to server : Permission Denied

Is the server running locally and accepting connections on Unix domain socket "/var/pgsql_socket/.s.PGSQL.5432"?

 

It seems that there is a permission problem on the Unix Domain Socket /var/pgsql_socket/.s.PGSQL.5432.

It has a 0770 permission on it, but i don't know if it's relly the problem.

 

I've compared with MySQL server, which I am able to manage through Navcat for MySQL Lite without any problem, and the socket permission are 0777 on /var/mysql/mysql.sock.

 

Does somebody able to connect to the embedded PostgreSQL server ?

 

Or am I doing something wrong ?

 

Thanks.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.