Skip navigation

Here is a very slow page in Safari 5.1

4029 Views 24 Replies Latest reply: Sep 20, 2011 3:30 PM by Nathan Goldshlag RSS
1 2 Previous Next
Jonathan Pool Level 1 Level 1 (40 points)
Currently Being Moderated
Jul 22, 2011 10:50 PM

Safari before 5.1 has had no problem loading this page:

 

http://panlex.org/u

 

But in 5.1 requesting this page makes WebProcess start consuming 100%+ of CPU and it takes 105 seconds under Snow Leopard on a 2 x 2.8 GHz Quad-Core Xeon Mac Pro and 65 seconds under Lion on a 2.3 GHz Intel Core i7 MacBook Pro, before the page is ready to do anything (scroll or press a button) with.

 

To check whether there might be a font or character causing this problem, I have replicated the situation with various subsets of the table being displayed. Displaying 1000 rows speeds the loading, but it still takes about 15 seconds on the Snow Leopard machine, regardless of which 1000 rows are displayed. (These times are over a LAN, so no Internet latency.) Similar problem on a 2.4 GHz Intel Core 2 Duo MacBook.

 

The loading time is not appreciably decreased if the page is loaded again in succession.

Mac Pro, Mac OS X (10.5.7), iPhone 8GB, Airport Extreme
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.