5 Replies Latest reply: Sep 5, 2011 7:12 PM by Whatzup
Ratz227 Level 1 Level 1 (15 points)

    Upgraded to Aperture 3.1.3. Then upgraded to Lion. Tried to sync my iPhone and it got as far as photo's and got a -50 Sync error. Went to iTunes and turned off photo sync and the phone syn'd perfectly. Went back to iTunes turned photo sync back on, and got an error again. Went to iTunes turned off sync and checked the option to remove my photo's from the phone. Sync worked fine. Turned the photo sync back on, and it errored out when it was trying to reload the pictures. Turned off the Aperture photo sync and changed it to iPhoto. The next sync it reloaded my 1,500 photos without a hitch.

 

Bottom line: I explained all I have gone through so you can understand that it is not a corrupt photo library on the phone, and iPhoto sync'd fine, so it certainly appears that Aperture is once again the problem.

  • 1. Re: Aperture 3.1.3 and iPhoto sync problems
    Terence Devlin Level 10 Level 10 (123,840 points)

    Did you have a question?

  • 2. Re: Aperture 3.1.3 and iPhoto sync problems
    Ratz227 Level 1 Level 1 (15 points)

    Just looking to see if anyone else is having the same problem. I have a lot of photos in Aperture that are not in iPhoto, so would like to be able to sync Aperture with my phone.

  • 3. Re: Aperture 3.1.3 and iPhoto sync problems
    Louis Trapani Level 1 Level 1 (20 points)

    I am getting the same "Unknown error (-50)" when trying to sync photos from my Aperture 3 library now.

     

    I did not upgrade to Lion (waiting for a 3rd party driver I need to be updated first for it), but I did update iTunes to 10.4 (80) recently and that is when I noticed the issue.

     

    I haven't had this issue before. It syncs everything else but when iTunes goes from "Analyzing Photos" to "Optimizing Photos" in the sync process it reports that it is unable to sync because of an "unknown error (-50)"

     

    To resolve the problem, I tried the following:

     

    • I repaired my Aperture library database (using Option+Command when launching Aperture 3).
    • Deleted the "iPod Photo Cache" folder inside my Aperture library. It had to resync all my photos again, this time it worked, but the next sync it had the same error again.
    • Updated my iOS to the latest version.
    • Did a Repair Disk Permissions on my Mac.
    • I changed USB cables and ports (using only ports directly on my Mac Pro).
    • Tried syncing with only iTunes running.

     

    Doing all the above made no difference, I am still getting the error message and it won't sync new photos back to my iPhone 4 now.

  • 4. Re: Aperture 3.1.3 and iPhoto sync problems
    Whatzup Level 1 Level 1 (10 points)

    Any update on this issue? I ran in the same problem, tried exactly the same things, and, as you can imagine, still stuck with the same error.

  • 5. Re: Aperture 3.1.3 and iPhoto sync problems
    Whatzup Level 1 Level 1 (10 points)

    I have fixed my problem. I posted what I have done at the following thread. See if that helps for you.

    https://discussions.apple.com/message/16094366#16094366