Skip navigation

How to turn off IPV6 on Lion Server

24337 Views 16 Replies Latest reply: Apr 28, 2012 12:10 PM by James Reid1 RSS
1 2 Previous Next
udo.christ Calculating status...
Currently Being Moderated
Jul 23, 2011 12:25 AM

I did a clean install of Lion Server on my Mac Mini. I need to enable the firewall on that machine.

My Mini is only connected via WiFi to the network.

 

Due to firewall / Networksoftware issues i would like to disable IPV6 on the Lion Server completely.

The menu however only shows entries for "Automatic, Manual or Link-Local". On a Lion install (no Server) there is also the "Off".

 

Is there any reason i cannot switch off IPV6? If i cannot switch it off how do i configure my firewall so my software no longer

tries to connect using IPv6. I assume IPV6 is chosen in the first place due to a mDNS running with IPV6 enabled as i only configure ipv4 stuff and have eliminated all ipv6 completely from all other os's.

 

thanks & regards

udo

Mac mini, Mac OS X (10.7)
  • tolthoff Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jul 23, 2011 7:52 AM (in response to udo.christ)

    Setting it to LInk-local only is off I believe. That is the default when you are not configuring IPv6 in my Airport Extreme. Hope that helps.

  • tolthoff Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jul 23, 2011 11:05 AM (in response to tolthoff)

    I also found this link which allows you to turn IPv6 off from your computer side: http://support.apple.com/kb/HT4667

  • KoiDragons Calculating status...
    Currently Being Moderated
    Jul 28, 2011 7:08 AM (in response to udo.christ)

    Hello,

     

    Here is what worked for me in Lion.

     

    I edited /Library/Preferences/SystemConfiguration/preferences.plist

    and changed the IPv6 ConfigMethod's string to __INACTIVE__ manually for the appropriate adapter.   This is what I believe the GUI would change in SL10.6.  Looks like it still accepts the option, Just dosen't provied it.

     

    sudo vi /Library/Preferences/SystemConfiguration/preferences.plist

     

    The section under your unique adapter key will look like this when you're done.

     

    When completed reboot.  Your inet6 address should not show for that adapter in ifconfig anymore.

     

    Hope this helps.

     

    <key>IPv6</key>

        <dict>

            <key>ConfigMethod</key>

            string>__INACTIVE__</string>

        </dict>

     

    Screen Shot 2011-07-28 at 9.54.07 AM.png

  • Kurt Tappe Level 2 Level 2 (180 points)
    Currently Being Moderated
    Nov 9, 2011 12:35 PM (in response to udo.christ)

    I'm seeing the exact opposite. I'm setting up a new out-of-the-box Lion Server and its IPv6 has the option for "Off" instead of "Link-Local". Whereas my new iMac desktop running 10.7.2 client has only "Link-Local" and no "Off". I wonder why Apple is not consistent in the options it presents??

  • Carapace Inc. Calculating status...
    Currently Being Moderated
    Dec 16, 2011 8:44 AM (in response to udo.christ)

    I found a fix for this issue and applied it to several different MacBooks, iMac's, PowerMac's in the last couple of weeks. It works quite well and will now show or unlock the option of "Off" in the IPv6 section of GUI once these process is completed.

     

    1. Click some place on the desktop
    2. Click on the Go menu at the top of your screen
    3. Click on Utilities
    4. Inside the Utilities menu you will find the utility called Terminal
    5. Open up Terminal
    6. Depending if your account has admin privileges or the following will be different.
    7. In the terminal window type in the following:
      1. networksetup –listallnetworkservices  (precede this command with su or sudo if you are not logged in as an admin of the MAC)
      2. You will see a list of network services such as Wi-Fi, Ethernet, Bluetooth, Firewire etc etc.
      3. The next couple of commands will enable a new option in the GUI that will say Off under your Wi-Fi and Ethernet etc.
      4. networksetup -setv6off Ethernet
      5. networksetup –setv6off Wi-Fi
      6. networksetup –setv6off FireWire
      7. networksetup –setv6off 'Bluetooth PAN'  (if you have this)
      8. networksetup –setv6off 'VPN (PPTP)'   (if you have this)
    8. Close the terminal window and reboot your MAC
    9. You will be all set and all IPV6 stuff will be disabled for your networking and you will also have the new option in the GUI to change it if you so choose to in the future.

  • npjh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2012 8:59 PM (in response to Carapace Inc.)

    Worked

    The Terminal solution is virtually the same as altering the plist. The only difference is that the sudo commands in Terminal make it so that there is no reboot required.

    The reason why I looked into this is because my WiFi connection speed is a bit slower by default now that I upgraded to Lion on my mid 2007 MBP. Shutting off ipv6, as apposed to having it on automatic, supposedly helps with that issue.

    Still confused as to why "off" isn't there by default...

  • Carapace Inc. Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2012 6:42 AM (in response to udo.christ)

    Well my opinion as to why it is not there by default is possibly that the developers at Apple in their wisdom thought that everything in a lab environment was IPV6 so that is how it is in the real world. That fact of the matter is that most homes and businesses still use routers/firewalls as well as most website providers have not had the money or time to upgrade their equipment to IPv6 compatibility.  That is why some websites render quickly and others take forever and a day to load. The time it takes the MAC to figure that the website is not IPv6 compatible and then convert to IPv4 and retry is what makes the experience aweful. Not to mention that almost every website now has some type of advertisement on it that creates additional website connections and retry's to convert to IPv4.  Just an opinion though.

  • mrrapple Calculating status...
    Currently Being Moderated
    Mar 2, 2012 1:05 AM (in response to Carapace Inc.)

    I did use exactly your solution for my airplay problems. Source for that was: https://discussions.apple.com/message/16701952#16701952 with the answer from Mike).

     

    Now I try to turn off ipv6 on the Ethernet card on another mac using the terminial command

    networksetup -setv6off Ethernet

    but now it reacts with

    Ethernet is not a recognized network service.

    ** Error: The parameters were not valid.

     

    Possible cause:

    I have a dutch mac os x system and when I give the command:

    networksetup –listallnetworkservices

    it returns for the Ethernet card:

    Ingebouwd Ethernet

    (that is translated: "build in Ethernet")

     

    Also when I use

    networksetup -setv6off Ingebouwd Ethernet

    I get the same error.

     

    Has someone a solution for this?

    Thanks in advance!

    Marcel

  • ArnoutF Calculating status...
    Currently Being Moderated
    Mar 5, 2012 6:06 AM (in response to mrrapple)

    Mrrapple you have to put Ingebouwd Ethernet between quotation marks; resulting in:

     

    networksetup -setv6off "Ingebouwd Ethernet"

     

    (Bij mij heette het Ethernet 1, had hetzelfde probleem )

  • eldrik Level 1 Level 1 (65 points)
    Currently Being Moderated
    Mar 5, 2012 11:00 PM (in response to udo.christ)

    Hi,

     

    there is no need to disable IPv6 via terminal the off switch is build into the new server.app.

     

    Just open server.app switch to the "network" tab of your server that is listed under "hardware" and try to change the hostname (which one you choose is not necessary).

     

    After that you should see a menu where you can switch between different hostname types, which one you choose here doesn't matter either.

    .

    Klick for example "hostname for internet" --> Next

     

    On the next screen you will see something like "change network" press it.

     

    After that you see a screen that seems equal to the network screen that you can find under "system preferences" now choose IPv6 and on the next input screen choose between "automatic" "manual" or "off".

     

    There you go!

     

    Sorry if not all of my text examples match the text on your server.app screens while I translated it from my german lion server.app version.

     

    Regards

    Eldrik

  • mrrapple Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 6, 2012 5:58 AM (in response to ArnoutF)

    ArnoutF,

     

    thanks. Quatation marks did it!

     

    (Dank je Arnout ).

  • Mark23 Level 3 Level 3 (975 points)
  • eldrik Level 1 Level 1 (65 points)
    Currently Being Moderated
    Mar 12, 2012 7:19 AM (in response to Mark23)

    This only addresses the lion client version not the server version and has been already addressed within the first post of this discussion.

     

     

    On the server version one can disable IPv6 like described in my last post.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.