1 2 3 Previous Next 399 Replies Latest reply: Apr 28, 2014 6:40 AM by thebigticket
peregrines Level 1 Level 1 (0 points)

since i am using osx lion, my iMac is disconnected from my wireless network after sleep. (27 inch mid 2011, i5 with 2tb and ssd) (it states, that none of my preferred connections are available). sometimes it is connected ... but internet just won`t work.

besides that wifi is working just perfectly ... no drops no instability!

i am using airport extreme with 5ghz n-network, router is about 10 meters away (full signal).

 

under snow leopard i didnt experience any problems ... but since lion (which i am using since GM release) its really annoying because after every sleep i need to deactivate wifi and reactivate to connect.

i tried smc and pram reset ... changed my 5ghz settings to channel 36, deleted all other networks, did a reinstall (fresh!!) ... nothing helped

this is NOT an airport station issue ... my other macs and iPhone are connected just fine.

 

please, this is VERY annoying .... if you have any hints i would be very grateful!

 

with kind regards,

felix


iMac, Mac OS X (10.7)
  • 1. Re: iMac 2011 - no wifi connection after standby under Lion
    peregrines Level 1 Level 1 (0 points)

    here is what kosole says about it (in this situation the networkconnection was lost after standby ...)

     

    21.07.11 08:45:36,000 kernel: Wake reason: EHC2

    21.07.11 08:45:36,000 kernel: Previous Sleep Cause: 5

    21.07.11 08:45:36,000 kernel: The USB device HubDevice (Port 1 of Hub at 0xfa000000) may have caused a wake by issuing a remote wakeup (2)

    21.07.11 08:45:36,000 kernel: 1733.103862: ar9300WowWakeUp: Skip PCIE WA programming

    21.07.11 08:45:36,000 kernel: 1733.103901: setDISASSOC from disconnectVap

    21.07.11 08:45:36,000 kernel: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).

    21.07.11 08:45:36,000 kernel: 1733.118827: setDISASSOCIATE ****STA SYNC DISASSOC SUCCESS 

    21.07.11 08:45:36,000 kernel: The USB device BRCM2046 Hub (Port 1 of Hub at 0xfa100000) may have caused a wake by issuing a remote wakeup (3)

    21.07.11 08:45:36,000 kernel: The USB device Bluetooth USB Host Controller (Port 1 of Hub at 0xfa110000) may have caused a wake by issuing a remote wakeup (3)

    21.07.11 08:45:36,000 kernel: EIR is supported.

    21.07.11 08:45:36,000 kernel: SSP is supported.

    21.07.11 08:45:36,000 kernel: 1733.288064: performCountryCodeOperation: Disconnecting from AP

    21.07.11 08:45:36,000 kernel: 1733.292796: setDISASSOC from disconnectVap

    21.07.11 08:45:36,000 kernel: HID tickle 211 ms

    21.07.11 08:45:37,039 UserEventAgent: CaptiveNetworkSupport:CaptivePublishState:1211 en1 - PreProbe

    21.07.11 08:45:37,042 configd: network configuration changed.

    21.07.11 08:45:37,050 [0x0-0x6006].com.google.Chrome: [225:55299:1734135665836:ERROR:download_updates_command.cc(93)] PostClientToServerMessage() failed during GetUpdates

    21.07.11 08:45:37,000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3045 goto Exit

    21.07.11 08:45:37,000 kernel: IOThunderboltSwitch::i2cWriteDWord - status = 0x00000000

    21.07.11 08:45:37,000 kernel: IOThunderboltSwitch::i2cWriteDWord - status = 0x00000000

    21.07.11 08:45:37,000 kernel: IOThunderboltSwitch::i2cWriteDWord - status = 0xe00002ed

    21.07.11 08:45:37,000 kernel: IOThunderboltSwitch::i2cWriteDWord - status = 0xe00002ed

    21.07.11 08:45:38,000 kernel: en1: 802.11d country code set to 'AT '.

    21.07.11 08:45:38,000 kernel: en1: Supported channels 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140

    21.07.11 08:45:52,038 UserEventAgent: ServermgrdRegistration cannot load config data

    21.07.11 08:45:52,038 UserEventAgent: ServermgrdRegistration oldConfig is nil during net changed notification

    21.07.11 08:45:56,000 kernel: en1: BSSID changed to 90:84:0d:d9:92:dc

    21.07.11 08:45:56,000 kernel: AirPort: Link Up on en1

    21.07.11 08:45:56,000 kernel: en1: BSSID changed to 90:84:0d:d9:92:dc

    21.07.11 08:45:56,000 kernel: AirPort: RSN handshake complete on en1

    21.07.11 08:45:56,727 configd: network configuration changed.

    21.07.11 08:45:56,740 UserEventAgent: CaptiveNetworkSupport:CaptivePublishState:1211 en1 - Probe

    21.07.11 08:45:56,740 UserEventAgent: CaptiveNetworkSupport:CaptiveStartDetect:2343 Bypassing probe on airo (5 GHz) because it is protected and not on the exception list

    21.07.11 08:45:56,741 UserEventAgent: CaptiveNetworkSupport:CaptivePublishState:1211 en1 - Unknown

    21.07.11 08:45:56,742 configd: network configuration changed.

    21.07.11 08:45:56,948 airportd: _doAutoJoin: Already associated to “airo (5 GHz)”. Bailing on auto-join.

    21.07.11 08:45:58,111 ntpd: bind(25) AF_INET6 fe80::129a:ddff:fea0:622%5#123 flags 0x11 failed: Can't assign requested address

    21.07.11 08:45:58,111 ntpd: unable to create socket on en1 (7) for fe80::129a:ddff:fea0:622#123

    21.07.11 08:46:11,697 UserEventAgent: ServermgrdRegistration cannot load config data

    21.07.11 08:46:11,697 UserEventAgent: ServermgrdRegistration oldConfig is nil during net changed notification

    21.07.11 08:46:15,978 librariand: new client - cancelling idle timeout

    21.07.11 08:46:15,978 librariand: no ubiquity account configured, not creating collection

    21.07.11 08:46:15,978 librariand: error in handle_client_request: LibrarianErrorDomain/10/Unable to configure the collection.

    21.07.11 08:46:15,979 iTunes: unable to get sandbox extensions: The operation couldn’t be completed. (LibrarianErrorDomain error 10 - Unable to configure the collection.)

    21.07.11 08:46:15,979 librariand: no ubiquity account configured, not creating collection

    21.07.11 08:46:15,979 librariand: error in handle_client_request: LibrarianErrorDomain/10/Unable to configure the collection.

    21.07.11 08:46:15,979 librariand: client connection is invalid: Connection invalid

    21.07.11 08:46:15,979 librariand: no clients - starting idle timer

  • 2. Re: iMac 2011 - no wifi connection after sleep under Lion
    Washy21 Level 1 Level 1 (0 points)

    Having similar problems on my 2009 Mac Book Pro. If I close the lid and re open it drops the connection. I have to turn Wifi on and off to access the internet. Wish I hand't bothered now because it has really hindered productivity - not what Lion was supposed to do!!!!

  • 3. Re: iMac 2011 - no wifi connection after sleep under Lion
    Amarant9 Level 1 Level 1 (0 points)

    Having the exact same problem after installing Lion last night. 2010 iMac i5, 2.66GHz, 4GB DDR3. When I put the computer to sleep it refuses to reconnect to my wireless network. Apple, please address.

  • 4. Re: iMac 2011 - no wifi connection after sleep under Lion
    capetonian2 Level 1 Level 1 (0 points)

    Exact same problem on my end - updated to Lion last night and then from this morning, (7/21/11), my Macbook Pro couldn't (or, at best, very intermittently - with slow speed), connect via wi fi, especially after closing it or going to sleep. This is the first time my computer has ever had this problem. It takes about half an hour to eventually find my wi fi signal, (route from my Time Capsule). Brutally irritating: worse than dial up now.

  • 5. Re: iMac 2011 - no wifi connection after sleep under Lion
    Rogue_Butterfly Level 2 Level 2 (175 points)

    I started having the same problem after switching to the new iMac (27-inch, i7, 16 GB RAM) with Snow Leopard and the problem continues in lesser form with Lion. If the networking seems to be lagging, I can Stop Wifi and Restart it and all will be well again. It was definitely having a problem awaking from sleep before I tried everything including a reinstall and then moved the machine to a different location and also switched to a different channel. Now it only drops when awaking from sleep and not sporadically while working. My other Apple devices seem fine, all systems have full bars. I originally thought it was related to my Drobo software which is very flaky with the external drive sometimes being recognized when awaking from sleep and sometimes not. It's a known problem and listed in their FAQs.

  • 6. Re: iMac 2011 - no wifi connection after sleep under Lion
    AshleyTarver Level 1 Level 1 (0 points)

    Exact same problem here.

     

    I had the issue with Snow Leopard and it is now much worse after upgrading to Lion.

  • 7. Re: iMac 2011 - no wifi connection after sleep under Lion
    gunnngforglory Level 1 Level 1 (0 points)

    Same problem here - under Snow Leopard I had no problems but my 27" iMac running Lion has to be manually connected to my wifi network after sleep/startup.  

  • 8. Re: iMac 2011 - no wifi connection after sleep under Lion
    Speedy974 Level 1 Level 1 (0 points)

    Hello, I upgraded my new iMac 27 to Lion yesterday and I have the same problem: when iMac comes back from sleep, Wifi appears to be connected (icon in taskbar is black, full signal) but I have not internet connection. I need to deactivate/reactivate airport to be able to go online again.

     

    REALLY ANNOYING!!!!

     

    Note: I had 0 problem with Snow Leopard.

  • 9. Re: iMac 2011 - no wifi connection after sleep under Lion
    capetonian2 Level 1 Level 1 (0 points)

    I now find that I have to not allow my MB pro to go to sleep at all, so it's now permanently powered up, (which isn't great for the overall health of the machine), or else I lose my wi fi connection if it falls asleep. My process for getting it back on line after it wakes up is tedious to say the least and takes about 10 - 15 minutes every time:

     

    My process currently:

    1. Turn wi fi off

    2. Then I open Safari and run through its "network diagnostics" routine, which alone takes most of the time. This somehow forces the laptop eventually to find my wireless network, (a Time Capsule router - which has always worked flawlessly, and still does, with my other "non-Lion" devices), but, again, its temporary because I have to run through this whole process whenever my machine goes to sleep again. Many times during this process the system won't allow me to access the network, correct password and all.

    3. Even once it's discovered and "latched on" to the wi fi, it then takes another five minutes to download the first browser page and another few minutes after that to return to its normal, (Snow Leopard), speed: about 10 - 16 mbps.

     

    Overall, the process of rediscovering my wi fi network numerous times a day is a real, time-wasting pain in the rear. Also, I now find myself on "laptop sleep alert" all the time, to make sure the machine doesn't go to sleep.

     

    I called Apple support and they were seemingly surprised and oblivious to this issue, which I find hard to believe. They tried to diagnose the problem without success and have asked me to "keep in touch" via my case number. To their favor, the support staff were very friendly, well-intentioned and courteous, but it doesn't help when the issue isn't resolved.  I now truly do regret downloading Lion, especially after many folks warned me to wait a few months for the bugs to be ironed out. Oh well, being the trusting fool that I am, I got suckered into the hype and downloaded it on day 1.

     

    In the mean time, I'll have to keep "wi fi rediscovering" until there's a veritable fix from the company.

  • 10. Re: iMac 2011 - no wifi connection after sleep under Lion
    Washy21 Level 1 Level 1 (0 points)

    I have sorted my issue out:

     

    I flushed the DNS cache using terminal, although I can't remember how I did this because I got instruction from another support posting.

     

    I turned off the router; stripped out all wireless details in system preferences - network

     

    I had a CD-ROM in the drive and I felt as though this was somehow intefering. I took the disc out and it seemed to cure the issue.

     

    So I'm not sure which of the above was the fix but I hope this helps.

  • 11. Re: iMac 2011 - no wifi connection after sleep under Lion
    peregrines Level 1 Level 1 (0 points)

    Is there any news? None of the above mentioned suggestions solved my problem. Still have to deactivate and activate every single time iMac awakes from sleep VERY ANNOYING!

  • 12. Re: iMac 2011 - no wifi connection after sleep under Lion
    SuperCobraPilot Level 1 Level 1 (0 points)

    All-  I have a similar problem with my brand-new MacBook Pro.  I use a linksys dual-band 2.4/5 GHz router and initially had no issues with WiFi after Lion installation.  The other day I noticed when downloading the new iOS version that my download speed was slow.  Linksys recommended that I change the SSID for the 5GHz so the computer could recognize it separately from the 2.4 GHz.  Now every time I shut the lid, I have to go through the Kabuki-Dance to get the internet working. (takes a couple minutes; I just open Safari and go through the network diagnostics).  Usually by the time I click the continue button (after re-entering the WPA password) It tells me that my internet is working normally.  I am a new Mac convert so I am not as well-versed as I was with myriad Windows BS issues but I did note that I receive new email notifications on outlook for Mac 12 before my internet connection is back up.  Again, prior to forcing 5GHz access, I didn't drop my connection when I shut the lid.  Hope this helps narrow the problem down for Apple or the other helpful folks out there.

  • 13. Re: iMac 2011 - no wifi connection after sleep under Lion
    bartfrommidlothian Level 1 Level 1 (0 points)

    I am experiencing the same issue with my 27" iMac after upgrading to Lion.  With Snow Lepoard I did not have an wireless issue, but now whenever I wake the compter, I have to mess with the network settings for up to 5 minutes just to get it to reconnect.

  • 14. Re: iMac 2011 - no wifi connection after sleep under Lion
    Tristan Merritt Level 1 Level 1 (20 points)

    Since upgraded to Lion from Snow Leo, I have the same problem with my MacBook late 2009 model, WIFI does NOT automatically connect after wake up from sleep. I have to manually select the wireless - dont really want to delete wifi prefences unless last options due other wifi password access as cant remember whole list of passwords.

     

    Any fix out there?
    Cheers

    Tristan

1 2 3 Previous Next