Skip navigation

Can't access iPhoto library

2795 Views 5 Replies Latest reply: Jul 24, 2011 10:55 AM by davidboughton RSS
Rubbertoe Calculating status...
Currently Being Moderated
Jan 12, 2011 2:30 AM
When opening iPhoto no images appear. When I go the library in finder, it shows a size of 115GB, so I know they're there. At this point I've also gone to "Show Package Content" and can find all the images in the library....any ideas???
MacBookpro, Mac OS X (10.5.2)
  • Terence Devlin Level 10 Level 10 (121,745 points)
    Currently Being Moderated
    Jan 12, 2011 5:11 AM (in response to Rubbertoe)
    First off: make sure you're opening the correct Library - Hold down the option (or alt) key key and launch iPhoto. From the resulting menu select 'Choose Library'

    If that doesn't help: Try these in order - from best option on down...

    1. Do you have an up-to-date back up? If so, try copy the library6.iphoto file from the back up to the iPhoto Library (Right Click -> Show Package Contents) allowing it to overwrite the damaged file.

    2. Download iPhoto Library Manager and use its rebuild function. This will create a new library based on data in the albumdata.xml file. Not everything will be brought over - no slideshows, books or calendars, for instance - but it should get all your albums and keywords back.

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one.

    3. If neither of these work then you'll need to create and populate a new library.

    To create and populate a new *iPhoto 08* library:

    Note this will give you a working library with the same Events and pictures as before, however, you will lose your albums, keywords, modified versions, books, calendars etc.

    In the iPhoto Preferences -> Events Uncheck the box at 'Imported Items from the Finder'

    Move the iPhoto Library to the desktop

    Launch iPhoto. It will ask if you wish to create a new Library. Say Yes.

    Go into the iPhoto Library (Right Click -> Show Package Contents) on your desktop and find the Originals folder. From the Originals folder drag the individual Event Folders to the iPhoto Window and it will recreate them in the new library.

    When you're sure all is well you can delete the iPhoto Library on your desktop.

    In the future, in addition to your usual back up routine, you might like to make a copy of the library6.iPhoto file whenever you have made changes to the library as protection against database corruption.

    Regards

    TD
    MacBook Pro 15 2.4 i5 / iMac 20" 2.66 C2D, Mac OS X (10.6), 4 gig RAM/ 4 gig RAM
  • readingsully Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 15, 2011 2:35 PM (in response to Terence Devlin)
    I am such a rooky at this that I am not sure I understand your instructions, but let me tell you what happened to me. All of my photos disappeared from I-photo about a week after upgrading to the latest version. I have tried everything to retrieve them....I know the photos are there but I cannot repair the Iphoto program to access them. I tried the instructions given at Iphoto. So I wanted to remove it and then reload it too. My photos are on hardrive which is where they returned after I retrieved them from my CARBONITE site. CARBONITE could not even put them back into I-photo. It is definitely corrupted. Can you help me or are your instructions here the same for my problem.

    Thanks so much...Carole
    MacBookPro, Mac OS X (10.6.6)
  • Russell Silver Calculating status...
    Currently Being Moderated
    Jan 17, 2011 11:06 AM (in response to readingsully)
    I'm having the same problem with all my data restored by Carbonite. I tracked it down to Carbonite "flipping" the bundle bit on folders. This change done by Carbonite turns folders into package libraries. I found a utility called File Matey that you can use to undo the bundle bit but you have to do it one folder at a time. I have repeatedly tried to get Carbonite to acknowledge and fix the problem with no success. It seems Carbonite is just not actually Mac compatible.
    Macbook Pro 2.4Ghz, AirPort Extreme N, iPhone 4, Mac OS X (10.6.6)
  • davidboughton Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 24, 2011 10:55 AM (in response to Rubbertoe)

    My situation was that my wife had a library corrupted with several thousand spurious files introduced by trying to upload to a print service directly from the iPhoto library.  You need to export your pix from iphoto to an external folder and use that with third party print services.  Once corrupted, iPhoto would launch and let me view the library with the corrupting "images" via the F9 key, but would not let me in. I tried the steps in TD's post, but the library retained the corrupted files and did not resolve the problem.

    What finally worked for me was I chanced to try "Empty iPhoto Trash".  It let me into the library, I hit "Cancel", and then I was able to move all the garbage "images" to iPhoto trash and delete them.  Problem solved and what a relief!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.