Skip navigation

Preview crash after Lion install!

13470 Views 27 Replies Latest reply: Jan 4, 2013 11:16 AM by vinsand RSS
1 2 Previous Next
klas-erik Calculating status...
Currently Being Moderated
Jul 21, 2011 9:14 AM

Preview crashes at start(everytime) after I intalled Lion, any idears?

MacBook Pro, Mac OS X (10.7)
  • Silvertoe Calculating status...
    Currently Being Moderated
    Jul 21, 2011 10:15 PM (in response to klas-erik)

    The fix. . .

    The problem is a Permissions problem. All you have to do is:

     

    1. Right click on the root /Library Folder and selct 'Get Info'

    2. Unlock the pad lock in the lower right hand corner.

    3. Click on the + symbol to add a user.

    4. When prompt add the 'root user'.

    5. Give the root user Read/Write privaledges.

    6. Lock the pad lock and open Preview.

     

     

    This worked for me and I hope it works for you to!

  • VAHomebrew81 Calculating status...
    Currently Being Moderated
    Jul 22, 2011 5:38 PM (in response to Silvertoe)

    This didn't work for me.  Any other tips?

  • mberanek Calculating status...
    Currently Being Moderated
    Jul 24, 2011 2:03 PM (in response to VAHomebrew81)

    I had this same problem, and the solution was ultimately what Silvertoe was saying, but I on mine I needed to get a little more involved.  I needed to use the terminal app to access my list of folders and using the reference site ( http://ss64.com/osx/ls.html ) I used the "ls -lag" command to loog at my user's list of folders.  The folders were listed in the wheel group, (which is the group of the root user, and even though you are an admin user, you are not in this group) you need to use the "sudo" command to "chgrp" to change the group membership of the folders - after cleaning up these items I was able to correct the permissions, to get my users Library to show up, and get the text and preview apps to create the container file in the container folder in the Library folder so they would work - def took me a lot of messing around - good luck and be careful messing around in the terminal 

  • Terry Hutchinson Calculating status...
    Currently Being Moderated
    Jul 24, 2011 2:15 PM (in response to klas-erik)

    I had the same issue. I fixed it by deleting the preferences file for Preview. You find it in the Preferences folder in the system Library. However, under Lion you now must first make the Library visible. Many posts about how to do this; but I don't remember the instructions. Why they chose to hide the Library under Lion is another head scratcher for me. In any event, preference files can be safely deleted - a new one is created when you launch the app.

     

    Me - this was just one of many glitches on top of a new OS that didn't really do anything new. So I'm very happily back on SL.

  • pnealey Calculating status...
    Currently Being Moderated
    Jul 26, 2011 11:57 AM (in response to klas-erik)

    Here is somthing that worked for me.

    Crash reporter indicated Preview was trying to write to a folder called "Containers" in my ~/users/name/library/ folder. It did not exist so I created it. Now preview will open fine. Make sure permissions are correct on that folder. Hope this works for other folks.

  • Dreli Calculating status...
    Currently Being Moderated
    Jul 26, 2011 1:52 PM (in response to klas-erik)

    Read the tip of Silverjoe. it works again

  • Xoncention Calculating status...
    Currently Being Moderated
    Jul 27, 2011 8:58 AM (in response to Silvertoe)

    Silvertoe wrote:

     

    The fix. . .

    The problem is a Permissions problem. All you have to do is:

     

    1. Right click on the root /Library Folder and selct 'Get Info'

    2. Unlock the pad lock in the lower right hand corner.

    3. Click on the + symbol to add a user.

    4. When prompt add the 'root user'.

    5. Give the root user Read/Write privaledges.

    6. Lock the pad lock and open Preview.

     

     

    This worked for me and I hope it works for you to!

     

    I think you missed one step.  You need to also apply the privileges to the user you have modified - the gear to the left of the padlock has a drop down choice - "apply to enclosed items" is the final action.

  • Silvertoe Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 27, 2011 10:20 PM (in response to Xoncention)

    You are correct. I should of stated that in #5. I also forgot to list the folder is hidden. Thanks X!

  • Jordan Jacob Calculating status...
    Currently Being Moderated
    Aug 11, 2011 4:36 PM (in response to klas-erik)

    I tried all of these suggestions with no luck. I found that If you right click and get info on the Preview.app file and just select the "Open in 32-bit mode" checkbox, everything works perfectly.

  • holm188 Calculating status...
    Currently Being Moderated
    Aug 14, 2011 10:55 PM (in response to klas-erik)

    For Preview I had two permission setting for "everyone", one as "read only", one as "custom". As I could not delete one of the "everyones", I set them both to "read only". Now Preview works.

  • Gian G Calculating status...
    Currently Being Moderated
    Aug 30, 2011 2:02 PM (in response to holm188)

    i have the same thing. 2 "everyone" settings. I set them both to "read only" but still no luck.

    It will appear in the dock, bounce a couple of times, then totally disappear. Never opening..

  • lemsx1 Calculating status...
    Currently Being Moderated
    Sep 8, 2011 9:16 PM (in response to klas-erik)

    Solution was very simple:

     

    If you have a symbolic link somewhere in the path that Preview looks for, say ~/Downloads, this causes the app to crash! Removing the symbolic ink and creating a real directory fixes the problem.

     

    It might be a good idea for people to run Disk Utility "verify permissions" too. You might actually want for it to fix any permissions problems you might have.

     

    Hope that helps.

  • Nathan Lavertue Calculating status...
    Currently Being Moderated
    Sep 15, 2011 10:56 AM (in response to klas-erik)

    None of the solutions work for me, using Lion (10.7.1).

     

    Also, I think the permissions method has changed since the last version of OS X - as some of the items in the tip aren't accessible.

     

    Changing permissions didn't work.

    Deleting preferences didn't work.

    Opening in 32-bit mode didn't work.

     

    I wonder if it's actually Preview or if it might be the printer dialogue since it only crashes, for me, when I try to print.

  • beerhauler Calculating status...
    Currently Being Moderated
    Sep 16, 2011 4:38 PM (in response to Xoncention)

    Silvertoe's solution worked for me... again, make sure to "apply to enclosed items." I had tried to repair permissions, delete preferences... none of that worked. Added the user, changed permissions, and Preview opens, and what's more... I COULD PRINT FROM IT!!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.