Skip navigation

disable start up sound

146937 Views 161 Replies Latest reply: Mar 22, 2014 12:59 AM by luis from Arcos RSS Branched to a new discussion.
1 2 3 ... 11 Previous Next
maximilian Jehuda Izchak Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 24, 2011 8:49 PM

On Leopard I could simply put down the volume before a shut down, and I had no anoying start up sound.However this seems not to work anymore on Lion.Which possibilities do I have to start my system without the roaring bong?

iMac, Mac OS X (10.7), respond to maximilianewert@yahoo.fr
  • leroydouglas Level 6 Level 6 (13,310 points)
    Currently Being Moderated
    Jul 24, 2011 9:00 PM (in response to maximilian Jehuda Izchak)

    I have not tested this in Lion.

     

    You could report back with your finding:

     

    http://osxdaily.com/2010/01/28/how-to-stop-the-mac-startup-sound/

    MacBook Pro, Mac OS X (10.7), 2.4GHz IntelCore i5 320 HD 8GB RAM
  • billearl Level 2 Level 2 (175 points)
    Currently Being Moderated
    Jul 24, 2011 10:51 PM (in response to leroydouglas)

    StartupSound.prefPane is not compatible with Lion. TinkerTool System 2.8 is supposed to be capable of muting the Lion startup sound but it doesn't work on my system (the author is trying to find a fix). I have searched but not yet found a way to do this with Lion.

  • skeelo221 Level 1 Level 1 (65 points)
    Currently Being Moderated
    Jul 26, 2011 5:04 PM (in response to billearl)

    Bummed StartupSound.prefPane doesn't work in Lion!

  • rabrack Level 1 Level 1 (40 points)
    Currently Being Moderated
    Jul 26, 2011 5:35 PM (in response to maximilian Jehuda Izchak)

    StartupSound.prefPane version 1.1b3 works fine in Lion. I have it installed now.

  • skeelo221 Level 1 Level 1 (65 points)
    Currently Being Moderated
    Jul 26, 2011 5:37 PM (in response to rabrack)

    rabrack wrote:

     

    StartupSound.prefPane version 1.1b3 works fine in Lion. I have it installed now.

     

    This version didn't work for me.  Are you able to mute the starup sound?

  • rabrack Level 1 Level 1 (40 points)
    Currently Being Moderated
    Jul 26, 2011 5:43 PM (in response to skeelo221)

    I'll have to check the "Mute", have mine set on first notch. Will check.

  • Acid Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jul 28, 2011 1:01 AM (in response to maximilian Jehuda Izchak)

    I've found another solution how to disable the startup sound. It also works on Lion - at least for me.

    There is some terminal stuff to do, but it's worth it imo ;-)

     

    Ok here we go:

     

    1. Login as administrator and open a terminal window

     

    2. Create scriptfile for muting

    sudo nano /path/to/mute-on.sh

     

    3. Enter this as content, when done press control+O to save and control+X to exit:

    #!/bin/bash

    osascript -e 'set volume with output muted'

     

    4. Create scriptfile for unmuting

    sudo nano /path/to/mute-off.sh

     

    5. Enter this as content, when done press control+O to save and control+X to exit:

    #!/bin/bash

    osascript -e 'set volume without output muted'

     

    6. Make both files executable:

    sudo chmod u+x /path/to/mute-on.sh

    sudo chmod u+x /path/to/mute-off.sh

     

    7. Check if any hooks already exist (these will be overwritten, so make sure it is OK for you)

    sudo defaults read com.apple.loginwindow LoginHook

    sudo defaults read com.apple.loginwindow LogoutHook

     

    8. Add hooks for muting

    sudo defaults write com.apple.loginwindow LogoutHook /path/to/mute-on.sh

    sudo defaults write com.apple.loginwindow LoginHook /path/to/mute-off.sh

     

    Notes:

    - /path/to/ is the location of the scripts, I used /Library/Scripts/

    - you can skip the unmuting loginhook (i.e. each logout will silence your machine), but I like it this way because I always have sound available exactly at the volume level I set last time

    - root has to be the owner of the script files - running an editor from command line with sudo is the easiest way to achieve that (otherwise you need to chown)

    - to delete the hooks, use the following:

    sudo defaults delete com.apple.loginwindow LoginHook

    sudo defaults delete com.apple.loginwindow LogoutHook

  • billearl Level 2 Level 2 (175 points)
    Currently Being Moderated
    Jul 28, 2011 2:32 PM (in response to Acid)

    Thanks, Acid. This method works reliably on my system, and it gave me the clues to develop my own method.

     

    What I finally settled on is simple and visible. I simply added a line to my AppleScript which is run at each login to set the internal speakers volume to 50% so I can hear the startup sound at lower than full volume the next time I reboot. Not ideal (should actually be run at logout) but good enough for me. The added line is:

     

    do shell script "osascript -e 'set volume output volume 50'" password "password" with administrator privileges


    I think "with administrator privileges" is necessary so the internal speakers volume is set rather than the line out volume (my chosen output device), hence the use of a shell script. My knowledge of AppleScript is not great, so there may be a better way to do the same thing.

  • suslik Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2011 2:46 AM (in response to Acid)

    Thanks Acid, this worked for me.

    I reposted your at solution on my blog since I liked the way you did it. I hope you are ok with that!

     

    http://my.opera.com/mereh/blog/2011/07/30/apple-osx-mute-startup-sound-chime-in- osx-10-7-lion-and-others

  • Acid Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jul 30, 2011 2:53 AM (in response to suslik)

    Hey suslik,

     

    np, that's ok for me

  • Bad News52 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 31, 2011 11:02 PM (in response to maximilian Jehuda Izchak)

    Mine disabled somehow on it's own...

    I have lion and a 2011 27" imac.

    It used to be really loud now it's completely muted and I did nothing

    Anyone know how this could have happened??

  • billearl Level 2 Level 2 (175 points)
    Currently Being Moderated
    Aug 1, 2011 12:01 AM (in response to Bad News52)

    No idea. Check the Internal Speakers volume in the Sound pref pane. Do you have sound through your Line Out speakers?

  • mr_urf Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 1, 2011 2:25 AM (in response to Bad News52)

    I was getting this same problem ... until I unplugged my headphones. I did as Acid suggested above but was still getting the startup sound. However as soon as I unplugged my headphones the startup sound was muted. Going to have a play about and see if I can specify the channel that Acid's script mutes.

  • mr_urf Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 1, 2011 3:00 AM (in response to mr_urf)

    Hmm, my iMac doesn't seem to differentiate between the internal speakers and the headphone port. Is this something specific to the iMac? Or to Lion? New to both

     

     

    UPDATE:

     

    For reference:

     

    headphones in http://d.pr/tEP

    headphones out http://d.pr/8Poh

    USB headphones in instead http://d.pr/BJ8L

     

    The startup sound only plays now if I have anything plugged into the headphone port. My USB headphones work fine.

     

     

     

     

    System: iMac 27" early 2011, 3.4 GHz i7, 8GB RAM, 256 SSD, 2TB HDD, 6970M 2GB

    OS: 10.7

     

    Message was edited by: mr_urf

1 2 3 ... 11 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.