1 2 3 Previous Next 169 Replies Latest reply: Jul 4, 2014 9:20 PM by Gilles Branched to a new discussion.
maximilian Jehuda Izchak Level 1 Level 1 (0 points)

On Leopard I could simply put down the volume before a shut down, and I had no anoying start up sound.However this seems not to work anymore on Lion.Which possibilities do I have to start my system without the roaring bong?


iMac, Mac OS X (10.7), respond to maximilianewert@yahoo.fr
  • 1. Re: disable start up sound
    leroydouglas Level 6 Level 6 (13,840 points)

    I have not tested this in Lion.

     

    You could report back with your finding:

     

    http://osxdaily.com/2010/01/28/how-to-stop-the-mac-startup-sound/

  • 2. Re: disable start up sound
    billearl Level 2 Level 2 (175 points)

    StartupSound.prefPane is not compatible with Lion. TinkerTool System 2.8 is supposed to be capable of muting the Lion startup sound but it doesn't work on my system (the author is trying to find a fix). I have searched but not yet found a way to do this with Lion.

  • 3. Re: disable start up sound
    skeelo221 Level 1 Level 1 (65 points)

    Bummed StartupSound.prefPane doesn't work in Lion!

  • 4. Re: disable start up sound
    rabrack Level 1 Level 1 (40 points)

    StartupSound.prefPane version 1.1b3 works fine in Lion. I have it installed now.

  • 5. Re: disable start up sound
    skeelo221 Level 1 Level 1 (65 points)

    rabrack wrote:

     

    StartupSound.prefPane version 1.1b3 works fine in Lion. I have it installed now.

     

    This version didn't work for me.  Are you able to mute the starup sound?

  • 6. Re: disable start up sound
    rabrack Level 1 Level 1 (40 points)

    I'll have to check the "Mute", have mine set on first notch. Will check.

  • 7. Re: disable start up sound
    Acid Level 1 Level 1 (30 points)

    I've found another solution how to disable the startup sound. It also works on Lion - at least for me.

    There is some terminal stuff to do, but it's worth it imo ;-)

     

    Ok here we go:

     

    1. Login as administrator and open a terminal window

     

    2. Create scriptfile for muting

    sudo nano /path/to/mute-on.sh

     

    3. Enter this as content, when done press control+O to save and control+X to exit:

    #!/bin/bash

    osascript -e 'set volume with output muted'

     

    4. Create scriptfile for unmuting

    sudo nano /path/to/mute-off.sh

     

    5. Enter this as content, when done press control+O to save and control+X to exit:

    #!/bin/bash

    osascript -e 'set volume without output muted'

     

    6. Make both files executable:

    sudo chmod u+x /path/to/mute-on.sh

    sudo chmod u+x /path/to/mute-off.sh

     

    7. Check if any hooks already exist (these will be overwritten, so make sure it is OK for you)

    sudo defaults read com.apple.loginwindow LoginHook

    sudo defaults read com.apple.loginwindow LogoutHook

     

    8. Add hooks for muting

    sudo defaults write com.apple.loginwindow LogoutHook /path/to/mute-on.sh

    sudo defaults write com.apple.loginwindow LoginHook /path/to/mute-off.sh

     

    Notes:

    - /path/to/ is the location of the scripts, I used /Library/Scripts/

    - you can skip the unmuting loginhook (i.e. each logout will silence your machine), but I like it this way because I always have sound available exactly at the volume level I set last time

    - root has to be the owner of the script files - running an editor from command line with sudo is the easiest way to achieve that (otherwise you need to chown)

    - to delete the hooks, use the following:

    sudo defaults delete com.apple.loginwindow LoginHook

    sudo defaults delete com.apple.loginwindow LogoutHook

  • 8. Re: disable start up sound
    billearl Level 2 Level 2 (175 points)

    Thanks, Acid. This method works reliably on my system, and it gave me the clues to develop my own method.

     

    What I finally settled on is simple and visible. I simply added a line to my AppleScript which is run at each login to set the internal speakers volume to 50% so I can hear the startup sound at lower than full volume the next time I reboot. Not ideal (should actually be run at logout) but good enough for me. The added line is:

     

    do shell script "osascript -e 'set volume output volume 50'" password "password" with administrator privileges


    I think "with administrator privileges" is necessary so the internal speakers volume is set rather than the line out volume (my chosen output device), hence the use of a shell script. My knowledge of AppleScript is not great, so there may be a better way to do the same thing.

  • 9. Re: disable start up sound
    suslik Level 1 Level 1 (0 points)

    Thanks Acid, this worked for me.

    I reposted your at solution on my blog since I liked the way you did it. I hope you are ok with that!

     

    http://my.opera.com/mereh/blog/2011/07/30/apple-osx-mute-startup-sound-chime-in- osx-10-7-lion-and-others

  • 10. Re: disable start up sound
    Acid Level 1 Level 1 (30 points)

    Hey suslik,

     

    np, that's ok for me

  • 11. Re: disable start up sound
    Bad News52 Level 1 Level 1 (0 points)

    Mine disabled somehow on it's own...

    I have lion and a 2011 27" imac.

    It used to be really loud now it's completely muted and I did nothing

    Anyone know how this could have happened??

  • 12. Re: disable start up sound
    billearl Level 2 Level 2 (175 points)

    No idea. Check the Internal Speakers volume in the Sound pref pane. Do you have sound through your Line Out speakers?

  • 13. Re: disable start up sound
    mr_urf Level 1 Level 1 (0 points)

    I was getting this same problem ... until I unplugged my headphones. I did as Acid suggested above but was still getting the startup sound. However as soon as I unplugged my headphones the startup sound was muted. Going to have a play about and see if I can specify the channel that Acid's script mutes.

  • 14. Re: disable start up sound
    mr_urf Level 1 Level 1 (0 points)

    Hmm, my iMac doesn't seem to differentiate between the internal speakers and the headphone port. Is this something specific to the iMac? Or to Lion? New to both

     

     

    UPDATE:

     

    For reference:

     

    headphones in http://d.pr/tEP

    headphones out http://d.pr/8Poh

    USB headphones in instead http://d.pr/BJ8L

     

    The startup sound only plays now if I have anything plugged into the headphone port. My USB headphones work fine.

     

     

     

     

    System: iMac 27" early 2011, 3.4 GHz i7, 8GB RAM, 256 SSD, 2TB HDD, 6970M 2GB

    OS: 10.7

     

    Message was edited by: mr_urf

1 2 3 Previous Next