Skip navigation

Preview and TextEdit quit unexpectedly (fresh install)

6254 Views 30 Replies Latest reply: Oct 27, 2011 6:37 PM by John Hammer1 RSS
  • Alan W Myers Calculating status...

    I'm having the same problem as the origonal poster did but I don't understand how to change the symlink to downloads.

     

    The link just say what to do but didn't tell me how. Please explain.

  • nanoX Calculating status...
    Currently Being Moderated
    Jul 24, 2011 12:14 AM (in response to t3kila)

    just go in the terminal and:

     

    1. check where your symlink points by

    ls -l ~/Downloads

     

    2. remove symlink

    rm ~/Downloads

     

    3. start Preview and TextEdit

     

    4. remove created Folder again by

    rm -R ~/Downloads

     

    5. restore your symlink

    ln -s /<absoluteSymlinkPath>  ~/Downloads

  • SameKim Calculating status...
    Currently Being Moderated
    Jul 24, 2011 11:35 PM (in response to nanoX)

    what a smart guy. thx. it resolved.

  • sirslabknit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 25, 2011 6:57 AM (in response to nanoX)

    My Preview and Textedit also fail to launch. Have deleted Downloads directories and they still do not launch.

    This is on Mac Pro. Macbook Pro works properly.

  • nanoX Level 1 Level 1 (0 points)

    hi sirslabknit,

    try on another user on your Mac Pro...

    check if you have other symlinks in your home directory...

  • sirslabknit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 25, 2011 11:06 AM (in response to nanoX)

    Log in as "guest" both apps run OK !

    There don't appear to be any unusual files in my home directory but I am not sure how you identify a "symlink". To my knowledge I have never dabbled in Terminal on the Mac (though I was once reasonably expert with Unix).

  • nanoX Level 1 Level 1 (0 points)

    like in unix there are million different ways.

    The nicest for me is:

    find ~ -maxdepth 1 -type l -exec ls -l {} \;

     

    if you want you can also remove "-maxdepth 1" to see all links within your homedirectory...

     

    if you do the usual list:

    ls -l ~

     

    you see for example this for a link:

    lrwxr-xr-x   1 nanoX  staff        28 24 Jul 09:12 Downloads -> /Volumes/2TB RAID1/Downloads

     

    where the l indicates a link and the -> shows the destination

  • sirslabknit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2011 3:09 PM (in response to nanoX)

    Sorry this is beyond me. I am a simple soull.

     

    The failure to launch Textedit and Preview is still there.

     

    Is this a clue?

     

    Container object initialization failed: NSCocoaErrorDomain:513 You don’t have permission to save the file “Containers” in the folder “Library”.

  • BritainyK Calculating status...
    Currently Being Moderated
    Jul 27, 2011 3:33 PM (in response to nanoX)

    no go nanoX.  All I accomplished was deleting everything in my downloads folder.  No biggie, but it would have really been worth it if I could have a working Preview/TextEdit app but they are still crush!  ugh . . . I do not know how to navigate in Terminal and am afraid I will screw something up permantely (not that permanately becuase I can retrive it in Time Machine, but I don't want to hassle with that as well).  I give up

     

    thank you for you help, I'm sure if I was more skilled it would have worked.

  • bhite80 Calculating status...

    Nothing is working for me. As far as I know, I do not have any symlinks. What do I run in Terminal to find out if I do? I ran "ls -l ~" but it just gave me a list of all folders in Library. Also, my Library folder isn't hidden, like some posts have said. It's perfectly visible. And I don't have to undo my lock to make changes. For some reason, it's showing it being locked, and when I unlock it (and provide my password), it won't let me make changes, e.g. add users or change access permissions. But when I lock it, it DOES let me make changes.

     

    Lion has really screwed a lot of things up, it appears. And over a month it's been out, and Apple has yet to provide an official fix for this. It's really starting to make me regret updating.

  • sirslabknit Level 1 Level 1 (0 points)

    try the post

    Installing Lion stops Textedit and Preview launching

     

    I was missing a directory structure called "containers".

  • BritainyK Level 1 Level 1 (0 points)

    OMGOMGOMG!!  It worked sirslabknit!  I read the post you recommended and repaired my disk premissions in Disk Untility and that worked!!  Thank you so much for sharing!  Have a terrific day

  • Don Frankenfeld Level 1 Level 1 (35 points)

    I am impressed by the erudition of both questions and answers on this post, but I am intimidated by the language. I bought my Mac because I believed the stuff about it being a computer for the rest of us. So when I am told to go to "terminal" mode, or to purge something from my "home directory" or to do something with symlinks, I feel like I have been transported to Planet Gates. I am not criticizing the smart folks on this post who understand these words, which apparently are so familiar to them that they feel no definition is necessary. But for those of us who want a computer that "just works," who don't understand the jargon, and who really would prefer NOT to master the jargon but merely to use their computers, I would be grateful for a careful step by step tutorial, as told to a third grader. (I am 63, which in computer years is the same as age 7.) For starters, is there a way to fix this bug without entering terminal mode, since UNIX stuff terrifies me? Or, since we are dealing with one of Lion's many bugs, is it reasonable to think that Apple will remedy their defect in short order? If so, I can live without Preview and TextEdit for awhile.

     

    Many thanks!

  • bhite80 Level 1 Level 1 (5 points)

    I emailed Tim Cook about this issue and my email got passed on to Executive Relations, where a guy named Tajai made an attempt to call me at my house (was never home when he called) the past three days, and I called him back today.

     

    After talking with him briefly, then being passed on to Ed from Support, the fix that did the trick for me was the following:

     

    Shut the computer down.

    Start it while holding the Option key.

    Select the Recovery HD.

    Open Terminal from the Utilities menu in the top.

    Type in "resetpassword". Press enter.

    Select your account and change your password.

    Go to the bottom and select Reset where it says something about Permissions (forget what exactly it says).

    Make sure your account was still selected.

    After that, go to the top left and select Restart under the Apple menu.

    Let it restart as normal, and log in with the new password.

    You may have some issues with keychain asking for your password and your new one isn't working. If this happens (it did to me), click cancel and let your desktop load. Then go to your Library<Keychains folder and drag the login.keychain file onto your desktop (can later be deleted once keychain is working again).

    Restart the computer again.

    Log in.

    See if TextEdit and Preview works!

     

    I'm almost positive these were all the steps, so hopefully they make sense and work for you anyone who tries it.

  • Chojubo Calculating status...

    Thank you bhite80! This worked, your efforts are much appreciated! .

    I'm not hugely comfortable in terminal either, but I did give the other solutions a go. This was the only one that worked for me (and is the easiest for a non-terminal-savvy user too).

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.