1 2 Previous Next 25 Replies Latest reply: May 3, 2012 5:54 AM by indigo222
SlippySlope Level 1 Level 1 (45 points)

I did all of the latest Apple upgrades last night and now Safari 5.1 will not play video on YouTube (get message that a plug-in is missing - it doesn't specify which plug-in). Have the same problem with video on www.Telegraph.co.uk. So, is Apple picking a fight with some commom video format or is this just a bug (and we're the beta test site)?


MacBook Pro, Mac OS X (10.6.8), iPad2/iPhone 3GS
  • 1. Re: Safari 5.1 won't play video on YouTube
    Alan Burton Level 1 Level 1 (5 points)

    I have a problem with you tube videos on a Rotary site. They both work fine on Firefox and ran Ok on Safari until recently. Noticed the problem after I upgraded my iMac to Lion . Checked the MacBook and it was OK on Safari. I thought that it was Lion> Last night ran software updates including Safari 5.1 and problem now occurs on Macbook.

     

    The videos are Rotary ones (not private) and have been embeded. One appears outside the confines of the Safari page and will run the other does not work at all. Have tried switching off extensions but no joy.   Reorted problem to Apple. Any one else with same problem.

  • 2. Re: Safari 5.1 won't play video on YouTube
    TheSquirt Level 1 Level 1 (0 points)

    No flash items will work since I upgraded to 5.1 and everytime I switch windows, the page is blank and I have to wait for it to "redraw" before I can view it... very annoying. I am now using Chome until Apple gets with the program and fixes this fiasco. This update was definitely not ready to be posted.

  • 3. Re: Safari 5.1 won't play video on YouTube
    SlippySlope Level 1 Level 1 (45 points)

    I checked it with both Firefox and Chrome and both worked fine...so, I switched my default browser to Firefox. Let Apple fight it's demons and I'll wait until the next update and see if it's fixed.

  • 4. Re: Safari 5.1 won't play video on YouTube
    erdried Level 1 Level 1 (20 points)

    What version of Flash did you have installed (that would be the plug-in in question)?

  • 5. Re: Safari 5.1 won't play video on YouTube
    TheSquirt Level 1 Level 1 (0 points)

    Whatever flash plug-in update software update pushed through. I haven't had to update Flash for my mac since Safari began. It was always done by Apple

  • 6. Re: Safari 5.1 won't play video on YouTube
    Carolyn Samit Level 10 Level 10 (89,570 points)

    Uninstall the current copy of the Flash plugin then reintall new.

     

     

    Troubleshoot Flash Player | Mac OS

     

    Make sure and empty the Safari cache before you stream YouTube content after you reinstall the plugin.

     

    Safari / Empty Cache.

  • 7. Re: Safari 5.1 won't play video on YouTube
    erdried Level 1 Level 1 (20 points)

    TheSquirt, Apple stopped bundling Flash with updates. Thus, your version of Flash is likely out of date.

     

    http://daringfireball.net/2010/10/apple_no_longer_bundling_flash_with_mac_os_x

  • 8. Re: Safari 5.1 won't play video on YouTube
    TheSquirt Level 1 Level 1 (0 points)

    I wish Adobe and Apple would kiss and make up already. Maybe then the iPad would function as well as the other tablets and be worth purchasing.

  • 9. Re: Safari 5.1 won't play video on YouTube
    unclepete Level 1 Level 1 (0 points)

    I just had the same problem and fixed it almost immediately and more simply.  Unless someone has already posted this (sorry) here's what I did.

     

    1. Down load Applejack

    2. Follow instructions and restart holding command S (single user mode)  makes you feel kind of really knowledgeable when that code like screen comes up.  Scarey , but don't worry.

    3. Follow the applejack instructions towards the bottom of the screen and you should be good to go.

     

    Hope it works as well for you as it did me.

     

    Good luck.

  • 10. Re: Safari 5.1 won't play video on YouTube
    Niko521Bucs Level 1 Level 1 (0 points)

    YOUTUBE VIDEO PROBLEM SOLVED!!

     

    For some reason only a select number of people have this problem. Including me. SO I right clicked on the YouTUbe video, but found NO FLASH options. Instead, something different, including the problem.

     

    Go ahead and right click on your youtube videos that wont play. If you see a menu with the bottom one saying ABOUT HTML5, click on it, and go down to the bottom, and OPT OUT Of HTML5.

     

    Your you tube videos will now work., as did mine.

     

    Obviously, Apple is trying to get everyone out of flash and into html5, but guess what Apple? Try to make your html5 WORK FIRST before you do it. instead we all got spinning you tube players that never started.

     

    MAKE UP WITH ADOBE PLEASE! You can then squash all iphone and ipad competition. Maybe now that jobs is gone Apple wont be so hard headed.

  • 11. Re: Safari 5.1 won't play video on YouTube
    vjtk Level 1 Level 1 (0 points)

    @unclepete THANK YOU!! I tried uninstalling 5.1, back to 5.0.5 only to have the same issues. Then back to 5.1 and the issues got even worse, this is after making sure all Internet Plugin's were eliminated and newest flash plugs installed. I was at the end of my rope! Not only was I having problems with Safari not playing videos on YouTube (only would play audio) and other video sites, but some of my pro applications started getting weird on me, saying I had no VRAM (thats a whole other topic!). I made sure I had applejack for SL installed, then did the "Command-S" at startup, went through all 5 steps, and POW!! When I rebooted everything worked, including 5.1 complete with YT video and audio with no weird page refresh issues!!

     

    APPLEJACK IS THE ANSWER. Everyone needs to try that FIRST, before messing about with the plugs, installs, prefs, etc.

     

    Model Name:                    Mac Pro

    OS:                                    SL 10.6.8

    Model Identifier:               MacPro3,1

    Processor Name:               Quad-Core Intel Xeon

    Processor Speed:               2.8 GHz

    Number Of Processors:      2

    Total Number Of Cores:     8

    Memory:                            8 GB

  • 12. Re: Safari 5.1 won't play video on YouTube
    dominicfromquebec Level 1 Level 1 (0 points)

    Nico521Bucs! You're the best! Thanks!!!! ^^

  • 13. Re: Safari 5.1 won't play video on YouTube
    nmphotog Level 1 Level 1 (5 points)

    Same issue.  Tried everything.  This worked immideately.

     

     

    Open Preferences.  Click "Security".  Click "Remove all Website Data"

  • 14. Re: Safari 5.1 won't play video on YouTube
    zer01chi Level 1 Level 1 (0 points)

    Second this solution. Easy and quick fix. Worked for me as well.

1 2 Previous Next