Skip navigation

Cannot login after Lion Update

3898 Views 10 Replies Latest reply: May 25, 2012 7:17 AM by Rich in Berlin RSS
jrosenblum Calculating status...
Currently Being Moderated
Jul 21, 2011 2:30 AM

After completing the Lion update, I attempted to login into my primary account. After getting the spinny for a while in the password box, the screen turned grey with a "faded" login photo for my account, then went completely grey, then I was returned to the login screen.

 

Fortunately I have a separate account on my machine and have been able to log in with that account.

 

Both of these accounts are FileVaulted. The administrative aspects of this primary account still seem functional, since I'm able to do things like (once I'm logged into the secondary account) open Software Update. I can also ssh into my primary account. But If I try to User-Switch using the user-switching menu in the upper-right corner of the screen to my primary account, I see very similar behavior. I get a grey screen, followed by a flash of the standard spiral-galaxy background, followed by a grey screen and a return to the login screen.

 

It seems like trying to go through one of the initialization steps on my primary account is failing.

 

Obviously, I'm pretty disappointed with this outcome. Anyone else seeing anything like this? Any pointers on how to further diagnose?

MacBook, Mac OS X (10.7)
  • michaelfromeagle Calculating status...
    Currently Being Moderated
    Jul 22, 2011 6:23 AM (in response to jrosenblum)

    I'm getting the exact same thing, except I don't have a second username and therefore can't login at all. Good times.

  • michaelfromeagle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 12:00 PM (in response to jrosenblum)

    I was talking to Apple this morning but didn't have time to finish.  I will be calling them later.  I'll let you know how it goes.  Who knows? Maybe Steve will have pity on us and hook us up with new Mac Pros or something.

  • michaelfromeagle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 12:44 PM (in response to jrosenblum)

    From MacRumors Forums.  Sounds like a similar-enough issue to give this a try (http://forums.macrumors.com/showthread.php?t=1191239):

     

    I got the answer here

     

    Ok step 1

     

    Boot your mac with Option + R holding it will boot into recovery mode

    Step 2 go into disk util and take terminal

     

    write resetpassword

     

    Choose root and put a password to log on root

     

    Reboot the mac and log in as root and root password that you've done

     

    Go in System Preference then users and group

     

    Create a new account with the SAME NAME and SAME PASSWORD as your old account and put it as an administrator

     

     

    When you accept it will say that in MacHD you already have an account with the same name do you want to use THAT folder

     

    You say YES it will take 3 mnutes about.

     

    Then log off and your account will be there, select it and put the password

     

    It will log and all your files will be there.

     

    That is what i done and it worked, my desktop docs and itunes is all there

     

    And for the time i took

     

    They refunded my Lion purchase and will send me a 50$ itunes store card

     

    Gotta love it hehe

     

     

    Sorry for the bad english

     

    Message was edited by: michaelfromeagle

  • michaelfromeagle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 12:59 PM (in response to jrosenblum)

    Another link.  This one is about the Developer Previews and the only systems it affected were ones with an nVidia GPU.  I'm not sure which kind I have.

     

    http://www.displaylink.org/forum/archive/index.php/t-844.html

  • socalspartanrunner Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 25, 2011 2:18 PM (in response to jrosenblum)

    Had the exact same problem, the only way I fixed it was to autologin for the primary.  You could try a fresh install of Lion, via USB or DVD route of the installer.

  • Rich in Berlin Calculating status...
    Currently Being Moderated
    May 25, 2012 5:24 AM (in response to jrosenblum)

    This was exactly my problem too, after upgrading to Lion. I originally solved it by booting in recovery mode, renaming my library folder (not deleting so as to keep backup of all prefences and app data) and logging back in. Followed by 4-5 hours reconstructing my account, from the Library backup. Even then, only about 80% of original account config, but at least I was up and running. For about 1 month...

     

    This morning I restarted (not for the first time, since restoring my account) and guess what... yes AGAIN! To say I'm angry is an understatement.

     

    Same symptoms as noted by jrosenblum. I can ssh, but otherwise always grey for a couple of secs, before switching back to login screen. The suggested solution I'd already tried. That is for when lion has "lost" your account. In our case, the account is there, as proved by ssh. Hence you can't even do the above mentioned, osx won't let you because the "account name already exists". It's IMPOSSIBLE to enter SAME NAME / PASSWORD.

     

    In contrast to jrosenblum what I see in the console is a loginwindow crash. Every time. And always KERN_INVALID_ADDRESS at 0x000000000000001c

     

    Googling that confirms my suspicion it's a driver problem but hasn't helped much beyond that. Most perplexing is that I can't even log in in safe mode.

  • Rich in Berlin Level 2 Level 2 (290 points)
    Currently Being Moderated
    May 25, 2012 7:17 AM (in response to jrosenblum)

    Nailed it!!! (for me at least)

     

    A couple of work colleagues have had the same problem; it turned out to be a wonky keychain! Man, man, man!!!

     

    Solution was to rename the old Keychains folder, then I could login in. That was all! Then from KC Assitant open the old keychain, set it as default, and delete the new empty one created at log in. All my passwords and certs and keys restored.

     

    Maybe because I often run a developmennt script for building apps, which adds and removes a keychain. Something must have got screwed up. Would explain why 3 of us here at work have had the problem, which otherwise doesn't seem to be too common.

     

    Nevertheless... SL never had this difficulty. I don't like Lion.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.