Skip navigation

Lion:WiFi not autoconnecting after sleep mode

110365 Views 132 Replies Latest reply: Apr 17, 2014 9:49 PM by Wout Mertens RSS Branched to a new discussion.
1 2 3 ... 9 Previous Next
live4hills Calculating status...
Currently Being Moderated
Jul 21, 2011 9:33 AM

Upgraded to Lion yesterday, now when Mac is recovered from sleep mode the WiFi preferred network is not automatically connected.  Never was an issue with Snow Leopard.  I added my connection as a preferred connection in the Networks/Advanced page but it stil doesn't reliably work.  I must select the network from the list and connect.

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Jul 21, 2011 10:32 AM (in response to live4hills)

    Have you tried all the suggestions mentioned here:

    https://discussions.apple.com/thread/3190651?start=30&tstart=0

  • AshleyTarver Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 23, 2011 8:30 AM (in response to live4hills)

    Just so you don't feel alone - I had the issue with Snow Leopard and it is now much worse - 9 times out of 10 I get no wifi after recovering from sleep.

  • PatrickL Level 1 Level 1 (45 points)
    Currently Being Moderated
    Jul 23, 2011 9:07 AM (in response to live4hills)

    Yes, ALMOST the same issue here! I am running a WIRED connection from my desktop to the AE. I run 10.7 on a MacPro 1,1 (2.0GHz), although that shouldn't mean anything.

     

    The strange thing is that when I run the Network Assistant/Diagnostic, I get ALL green lights. However, my Airport Extreme (Dual-Band) does not display in my Airport Utility list -- something obviously is not computing, as that does not make any logical sense whatsoever. Those behaviors should be mutually exclusive.

     

    I hope I'm not threadjacking, but this is the only post I found that approximates my issue. I will start a new thread if this is too far off-base.

  • MattJohnson Calculating status...
    Currently Being Moderated
    Jul 26, 2011 6:44 AM (in response to live4hills)

    I'm having the same issue.  The only way I've been able to get mine to work is to Turn Off Wi-Fi and then back on and then it works.  I NEVER had the issue prior to upgrading to Lion.  I've also had issues with my track pad not working when scrolling up and down and also going back on web pages.  I'm not real happy with these issues.

  • TOGinaMOG Calculating status...
    Currently Being Moderated
    Jul 26, 2011 7:17 AM (in response to live4hills)

    For readers information I am having this WiFi problem with my iMac too; however, for better or for worse Lion will not load on my (Intel) MacBook! 

     

    Any bright ideas on this second challenge folks?

     

    Many thanks.

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Jul 27, 2011 1:43 AM (in response to TOGinaMOG)

    Have you guy's tried creating a new Location under System Preferences->Network and then switching to that location and using it ? It has worked for some folks in the other threads.

    Also stick to using WPA2-Personal only. If you have VMWare etc., try disabling it and see if it works.

  • MattJohnson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2011 5:18 AM (in response to wifiguru)

    Thanks for the reply.  I just tried it and it did not work.  I am using WPA2 - Personal and I do not have any type of VM on my Mac.  I sure hope Apple sees all of this and fixes it in the next software update. 

  • LordOphidian Calculating status...
    Currently Being Moderated
    Jul 28, 2011 11:13 PM (in response to live4hills)

    Having the same exact problem here. Every time the MacBook goes to sleep, when it wakes up, it will briefly show the searching icon in the bar, then all the signal strength bars will go grey. I have to go to that menu and click on my access point to get it to actually connect. Very strange.

     

    Never had this problem with SL.

  • Aismaiil Calculating status...
    Currently Being Moderated
    Jul 30, 2011 3:11 AM (in response to live4hills)

    i've been having this problem for over a week n it drove me crazy, but i found the solution! Click on the wifi signal sign, then on "open network preferences", once u're in the network preferences, click on the drop down list in "location", and then on "edit locations" .. and simply delete the old location u were using, it might be "automatic" and just create a new one .. that'll reset ur wifi preferences and it should work like new from there on

  • criscoABQ Calculating status...
    Currently Being Moderated
    Jul 30, 2011 10:29 AM (in response to live4hills)

    Late 2010 Macbook. Same problem since upgrading to Lion.  After reopening the lid, it will scan for a network and then claim no conections available.  This has been true at work, home, parents home, friends home-- all preferred networks where I frequently connect.  I changed the location as some had suggested, from automatic to creating a location profile.  The problem repeats itself to the point of irritation.  To no avail.  I intend to call Apple Care and will post my results here.  Yuck!  What a loss of productivity!

  • Avrahqedivra Calculating status...
    Currently Being Moderated
    Jul 30, 2011 2:47 PM (in response to live4hills)

    Macbook Pro Unibody. After upgrading to Lion, my problem concerning WIFI was that I had no more autoconnection to my home netwoork.

     

    To fix the problem was simply to delete the plist file corresponding to aiport i.e

     

    /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist

     

    1/ disable airport

    2/ delete the plist file

    3/ enable airport and select your favorite network again

     

    nb: I had several other problems with Lion they allhad been fixed deleting the related plist files...

  • criscoABQ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2011 7:06 PM (in response to Avrahqedivra)

    Wow!  Thanks.  That seems to be the fix to the problem.  I am going to run Onyx for Lion and see what else needs maintenance.  Cheers!

  • daniel8811 Calculating status...
    Currently Being Moderated
    Jul 31, 2011 1:13 AM (in response to live4hills)

    opened keychain and then deleted access passwords to all the wifi/time machine listesd.. reconnected... entered in the password again and viola.. done!

  • MBCocomo Calculating status...
    Currently Being Moderated
    Jul 31, 2011 9:58 AM (in response to Avrahqedivra)

    That solved the problem.

    Thank you!

1 2 3 ... 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.