Skip navigation

v10.7 Lion - Windows constantly change to an inactive/background window.

902 Views 12 Replies Latest reply: Feb 19, 2012 1:22 PM by Onan Isleand RSS
Horlbecm Calculating status...
Currently Being Moderated
Jul 20, 2011 8:16 PM

Every window: finder, safari, iCal, etc... automatically transitions to an inactive window after about 1-2" for no apparent reason. This prevents me from being able to type anything but a letter or two at a time before I need to click on the window again to make it the active window so my keyboard inputs will take effect.  Only object it does not seem to apply to is Quicksilver.  Ideas?  Already checked other input devices and turned them off, as well as reboots.

iMac, Mac OS X (10.7)
  • Falkmanwan Calculating status...

    I got the same problem and I really need a way to solve it. I think it might be an App, cause when I add a new User everythings fine.

  • TLom20 Calculating status...

    I'm also having the same problem, I will try to make a new user when I get home to see if that helps, but this is rendering my macbook absolutely useless at the moment

  • RobbieSnr Level 1 Level 1 (0 points)

    I have the same problem - unfortunately I don't have Hyperspaces I've experimented with all my apps but can't find the one that's causing the problem. I too find that Quicksilver doesn't disappear, and the only other one that doesn't is Finder. Mission Control did seem to work all right for a period this morning after I powered up but it's gone again and I can't think why - very frustrating.

     

    I did have a problem with Lion not shutting down - I had the grey screen with the spinning icon which wouldn't go away. I found an old service that was running back from the days I was transferring things over from my Palm. When I go rid of that this problem went away. I've had a look at the other services running in the background but so far have not located one that might be causing the MC problem. If anyone finds one that has can they please report this.

  • RobbieSnr Level 1 Level 1 (0 points)

    I've got a work around for this problem that works for me.

     

    I see that all the apps now have a Show All as well as Hide (App) and Hide Others. It seems that I lose the apps in a Desktop because they've been hidden and when this happens all that's in the Desktop is a Finder title bar. If I click on the Show All in that title bar all the apps in that Destop reappear, and in most cases they reappear in all the other Desktops too. Until this is sorted out I've gone into Keyboard Shortcuts in Keyboard Preferences and under Application Shortcuts added a new one for Show All for which I've used Shift-Ctrl-S. If the apps are not appearing in a Desktop I use this shortcut to make them reappear.

     

    It seems that this problem is to do with this new Show All - there was one before but I could never work out what it actually did. I find that in most cases either this option is greyed out or the two Hide ones are, and vice versa. However I've come across one case where all three are active! Perhaps someone has some idea of what is actually happening here.

  • jaystad Level 1 Level 1 (10 points)

    Same problem here. I don't have HyperSpaces or Quicksilver. Super frustrating.

  • ss1271 Calculating status...

    Same here.

     

    And even when I swipe to Dashboard, it will automatically and instantly push me back to where I was.

  • RobbieSnr Level 1 Level 1 (0 points)

    I wasn't suggesting that Quicksilver is causing the problem. There are a few issues with it and Lion but there's nothing to suggest it's at fault.

  • olivier205 Calculating status...

    I had the same problem. I tried to deprive quite all apps on starting, I restart and everything seems good to go. Then I start quicksilver and again the same problem. What is strange it is that with another user everything works fine…

  • RobbieSnr Level 1 Level 1 (0 points)

    If you look at Qicksilver/Preferences/Extras you'll see that there's an option to Hide other applications when switching. If this is checked then unchecking it should sort out the Quicksilver problem.

     

    I've now got Mission Control working as it should. I used to use an application iClip in SL and it wouldn't work in Lion, in fact I find it has been discontinued. There was no sign of it anywhere. However when I had a look at the list of Login Items for me in Preferences/Users & Groups it was shown there! I used the '-' below the list to remove it. I had also tried out Google Desktop but had stopped using it but there was an entry for this in that list too. There was also an entry in Preferences, under Other, and I uninstalled it there. I don't know which of these was causing the problem but it does seem to have sorted things out.

     

    I suggest that those who are still having problems with MC should have a look at these Login Items against their username in Preferences/User & Groups in case there's something shown there that might be causing their problem.

  • jaystad Level 1 Level 1 (10 points)

    I finally figured this one out on my machine. The culprit was the Salesforce Chatter desktop app. When I get a notificaltion of a new post, the window "layering" problem begins. The "notifications" come in the form of a pop-up window "above" all other apps. Once I quit the Chatter app. All returns back to normal. Again, this is just what I have found that works for me. Hope this helps.

  • Onan Isleand Calculating status...

    I have this same problem and I do not have any of the mentioned apps running. Anytime I leave a window for a short while it becomes inactive. If I have anything on the desktop that file then becomes active and I write to it when trying to search in the inactive window. I've changed titles on several docs this way and missed it... Anger.
    The inactive windows are useless and I then can only close them and open another with the same info. I have the similar problem with the applications window... takes forever to respond. This behavior is driving me insane. I just bought a new, faster mac to end these stupid delays and now I have them worse than ever. Two service updates and this frustrating bug is still there. My productivity is suffering. Would love to read where exactly it's coming from. I do not use any of the "new" iPad features. I am using a Mac pro for my work and find those features useless distraction. I'm hoping not to find out that one of them is the source of the problems.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.