1 2 3 Previous Next 36 Replies Latest reply: Dec 30, 2011 9:10 PM by lensportal
Nspyro Level 1 Level 1 (10 points)

The animations in lion (launchpad, mission control etc) are really choppy and glitchy for my computer.

I have a MacPro 2009 2x 2.26ghz, 8gb RAM, ati HD 5770

 

Which more then meets the requirements of lion, but the animations are terrible

Anyone else seeing this problem? nor does anyone know how I could fix this up?

 

I did a clean install of lion on a 115gb SSD

I tryed ressesting the PRAM but that did nothing

 

cheers


Mac Pro, Mac OS X (10.6.8), 2x2.26GHz, 8GB DDR3 RAM, ATI HD5770
  • 1. Re: Lion animation glitchy
    Alan Edinger Level 4 Level 4 (1,615 points)

    It does look like your machine is fully rated for Lion—as you said.

     

    What you describe is what I experience on a daily use Mac Mini with a very inadequate GMA 950 graphics subsystem. As soon as Snow Leopard was installed, that machine preformed slowly.

     

    And when Lion was installed the same choppiness persisted.

     

    However, after waiting a full 24hrs for the indexing to complete (many drives attached to that machine, Lion is noticeably faster than Leopard or Snow Leopard. Especially Safari.

     

    The animation choppy remains, but it is a smoother choppy than under Snow Leopard.

     

    So, did you wait a day or two for the background routines to finish their conversion processes? If not I would suggest that you do.

     

     

    -Alan

  • 2. Re: Lion animation glitchy
    Nspyro Level 1 Level 1 (10 points)

    "So, did you wait a day or two for the background routines to finish their conversion processes? If not I would suggest that you do."

     

    Not sure exactly what you mean sorry

    Ive had it installed since in was released

    So I guess its had some time to settle in

     

    Even switching between full screen apps is so laggy

     

    Anything you could suggest?

    I have got appleCare so I ring them up

     

    THANKS!

  • 3. Re: Lion animation glitchy
    Alan Edinger Level 4 Level 4 (1,615 points)

    In your original post it seemed as if you were reconfiguring your machine, instead of just using it. -Sorry for the mis-understanding.

     

    But I take your response to mean that you have been operating Lion normally. Two days is far more than enough time for it to run normally.

     

    Hopefully someone else with your exact machine will report here.

     

    In the meantime I'll keep digging, but so far I can't find anything.

     

     

    Things to do:

     

         • You may want to try bringing your system up in 'Safe Boot' mode and see how it operates then.

     

         • Also, start the Utilities / Activity Monitor and sort via CPU usage column and watch for any runaway processes.

     

         • And start the Utilities / Console program, Select "All Messages" from the left pane then see if the right pane is logging many continuous messages of the same type.

     

    -Alan

  • 4. Re: Lion animation glitchy
    Steve Stinger Level 1 Level 1 (5 points)

    I, too, am seeing very choppy system animations (3-ish fps) in Lion.  Like you, I have a Mac Pro, though mine has 2x Nvidia 7300 GTs, not the ATIs.  These 7300s have been plagued with performance and OpenGL-compaitibliy problems since the day they came out, so my first thought on the animation issue is that they were the culprit.  Since you have different cards, perhaps not.

     

    Here's my rig's specs:

    • MacPro (2008)
    • 2 GHz Dual-Core Intel Xeon
    • 16 GB RAM
    • 2x NVIDIA GeForce 7300 GT w/256 MB RAM each
  • 5. Re: Lion animation glitchy
    Nspyro Level 1 Level 1 (10 points)

    Alan,

     

    I did notice this isnt my console that came up a couple of times

     

    "AM Kernel: IOSurface: buffer allocation size is zero"

     

    Also in activity monitor:

    mds and mdworker are spiking anywhere from 1.0 to 94.5

     

    not sure if this means anything

     

    thanks for all your help!

  • 6. Re: Lion animation glitchy
    DrAma78 Level 1 Level 1 (0 points)

    Really really choppy, never thought to see that on iMac i7 2.8Ghz with 8Gb of ram and a ATI 4850 with 512MB. I've tried also the scrollbar hints, but can't see an increase in performance. This is really ******* me off. Hope in a future update.

  • 7. Re: Lion animation glitchy
    NathanL1192 Level 3 Level 3 (775 points)

    Hi there,

     

    This seems very strange, especially as your machine has plenty of RAM, which Lion needs.

     

    As another user said, it may take a few days of usage for the computer to settle down. When I first installed Lion it was frustratingly slow, but after a few days of usage, it is fine.

     

    Try opening Activity Monitor, and seeing if you have any unnecessary processes which are hogging RAM or CPU, and quit them if necessary.

     

    Hope this helps,

     

    Nathan

  • 8. Re: Lion animation glitchy
    DrAma78 Level 1 Level 1 (0 points)

    Hello Nathan,

    thank you for answering.

    Actually checking the use of  the system resources was the first thing I did, I can't see nothing unusual (unfortunately). I'm using Lion since the day after the launch. This is my home machine and I'm not using so much, I hope it will improve its performance in the future using it more, because for now I'm seriously thinking to downgrade it.

    By the way I think that is the price to pay at a first release, I thought about issues but not graphic issues on an old hardware.

     

    Ciao,

    Andrea

  • 9. Re: Lion animation glitchy
    Nspyro Level 1 Level 1 (10 points)

    I just hope this gets fixed in 10.7.1 as this is really disapointing considering my computer is well above the specs needed to run Lion, Heck, a Mac book air would run it better then my pro

     

    "Really really choppy, never thought to see that on iMac i7 2.8Ghz with 8Gb of ram and a ATI 4850 with 512MB. I've tried also the scrollbar hints, but can't see an increase in performance. This is really ******* me off. Hope in a future update." - DrAma78

     

    This is very strange, as my iMac at work (iMac [late 2009] i7 2.8GHz, 4GB Ram, ATi hd 4850 512MB) is running Lion smooth as butter.

     

    The only thing that might be effecting this is how I installed Lion on my Mac Pro (clean install from a bootable DVD) where as my iMac I just upgraded..

     

    hm.. this is very strange indeed

     

    Nathan.

  • 10. Re: Lion animation glitchy
    DrAma78 Level 1 Level 1 (0 points)

    Thank you Nspyro, that is exactly the same machine. Yesterday I've ran also geekbench 32-bit to test performance and the score is OK comparing to the same model.

    This machine was updated. If I have time this weekend I will try to make a clean install of Lion on another partition of the same machine and see if there is some conflict with other software, but from what I see in monitor seems to be not.

    I will also check on the internet for a GPU test to check if it could be a faulty hardware.

     

    Bye,

    Andrea

  • 11. Re: Lion animation glitchy
    nanofunk.net Level 1 Level 1 (5 points)

    see the blog post here: http://bit.ly/pNtLWS 

    it seems to be adobe flash player related - though, nothing official from apple or adobe yet...

  • 12. Re: Lion animation glitchy
    Steve Stinger Level 1 Level 1 (5 points)

    @nanofunk - I'm not sure what the system freezes mentioned in your post have to do with choppy animation.  These seem to be unrelated issues.

  • 13. Re: Lion animation glitchy
    DrAma78 Level 1 Level 1 (0 points)

    So yesterday I had enough time to create a new partition on the same machine and made a new CLEAN install of Lion.. no choppy animation anymore. Can't see any sort of differences(RAM, CPU cycles) in Activity Monitor between the upgraded and the clean installation.

    I'm seriously thinking to format the mac, made a clean install and restore users and application with migration assistant... hoping to fix that issue.

  • 14. Re: Lion animation glitchy
    Gandalf Da Black Level 1 Level 1 (0 points)

    Yes I'm seeing glitchy animations too that weren't there in Snow Leopard.  You can mainly notice a flicker (or redraw, rather) when switching between apps located on different Desktops.   I'd never experienced any slow redraw using Spaces on 10.6.    Granted, my video card is the stock one that comes with a macpro, but I still think there is something funky going on with the video paging as people with significantly higher video cards on here are also reporting it.    Is there a way to turn off certain animation features on Lion?

1 2 3 Previous Next