Skip navigation

Wifi won't turn on since upgrade to Lion

74683 Views 278 Replies Latest reply: Dec 2, 2012 11:44 PM by 2yb RSS Branched to a new discussion.
  • jacen2141 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2011 6:28 PM (in response to jacen2141)

    By the way, a friend uploaded his System Configuration folder to me so that I might replace my folder with his.  He is currently running a 2010 Macbook Pro and Lion and having no trouble at all.  When I replaced my System Configuration folder with his and rebooted, my WiFi comes back immediately and asks me to select a network and I can connect fine.  For now, this seems to be working with no ill effects.

     

    This also leads me to believe it's a problem with the driver/firmware of the wireless chips.

  • Jake Jung Calculating status...
    Currently Being Moderated
    Jul 26, 2011 6:42 PM (in response to jacen2141)

    jacen2141, I also agree that it is a firmware/driver problem with late 2008 MBPs and Lion.

     

    That's interesting that replacing the System Configuration folder with your friend's has at least temporarily fixed the issue. Presumably, even if you lose Wi-Fi again, you can get it back by replacing the folder once again. It would be a pretty dirty fix, but at least workable. Please keep us updated.

  • jacen2141 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2011 6:45 PM (in response to Jake Jung)

    Yeah it did work that way. I rebooted after adding his System Config folder and I had lost WiFi again.  After replacing the folder and rebooting, I was back up and running again with Airport asking me to choose my network again.

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Jul 26, 2011 9:17 PM (in response to jacen2141)

    You guys should also check if you VMWare/Parallel's runnning on your system and deny it access to the WIFi device or uninstall it for troubleshooting purposes. Will help eliminate some causes.

  • AMMOCAN Level 1 Level 1 (140 points)
    Currently Being Moderated
    Jul 26, 2011 9:22 PM (in response to jacen2141)

    I have a MBP 5,3, which reports the same hardware/firmware that you all have been reporting and I have had no issues. I also know many others who are using Lion on their machines and are not having problems with Wi-Fi or their network, so I seriously doubt it is a Lion or Hardware/Firmware issue. Instead, I believe it is more of a specific user error, as others with different model of machines have reported that they are having network problems.

     

    You do not need v10.6.8 to install Lion, but I would highly advise you to have it when upgrading to Lion, as just doin a clean install of Lion does leave out a lot of stuff, which may cause some problems.

     

    One thing that is for sure is that Lion offers many new different settings for it's items in System Preferences and it's defaults are not the same as SL. I would advise going into them and taking some time to figuring them out.

  • Jake Jung Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2011 9:33 PM (in response to AMMOCAN)

    AMMOCAN, well my late-2008 MPB reports itself as MacBookPro5,1. So, maybe that is part of the difference right there.

     

    I upgraded to Lion from a fully updated 10.6.8, and my wi-fi worked for 5 days just fine before turning off. When it did turn off, I was simply browsing my Time Capsule Disk, I had not changed any settings or installed any software within the last day.

     

    Why did it just turn off like that? I don't know for sure, but I don't think it's a mere coincidence that 90%+ of the people reporting this problem have a late-2008 MPB with the same airport hardware. If it is indeed flaky firmware, that would also explain why none of us have any problems on Snow Leopard (the firmware is a different version).

  • AMMOCAN Level 1 Level 1 (140 points)
    Currently Being Moderated
    Jul 26, 2011 10:02 PM (in response to Jake Jung)

    Regardless of your model we have the same exact Wi-Fi hardware/firmware. Actually if you were to do a search you would find that there are plenty of people with different machines reporting Network/Wi-Fi issues. However, there are plenty more people, who are not having any issues in regards to those issues. This is why I have said that it is more of an individual specific error than one specific to Lion. If it was specific to Lion or even to the type of machine you have then everyone who is using Lion or who is operating that specific model of machine would be reporting the issue. Taking into account the actual percentage of people who are reporting this issue compared to the amount of people using Lion and who are even using the same machine; the percentage of people who are having issues is small.

     

    Through my years of experience I have mysteriously come across an occasional phantom issue with my Wi-Fi/Network. None of which have or have had anything to do with my machine. It has always been something mysterious with my provider, modem, router, or something else I couldn't explain. However, I went through all the trouble shooting steps in regards to my Wi-Fi/Network and then everything worked it's self out.

     

    Now, I am not saying that installing Lion didn't have anything to do with messing it up, especially if you didn't do something right when upgrading to it. However, what I am saying is that simply having Lion on your machine isn't the reason why you are having issues and neither is the model of your machine, as otherwise thousands if not millions of people would be having the same issues. You simply need to figure out what in your network/wi-fi is not jelling with the new OS. It will take some work/investigation on your part, but with patience and perseverance I am positive you will be able to figure it out or at least resolve your issues.

  • pictobox Calculating status...
    Currently Being Moderated
    Jul 26, 2011 10:09 PM (in response to galmeida_)

    Resetting the SMC worked for me. 30 second fix and my wifi is back.

    http://support.apple.com/kb/HT3964

  • AMMOCAN Level 1 Level 1 (140 points)
    Currently Being Moderated
    Jul 26, 2011 10:18 PM (in response to pictobox)

    CAUTION: Before resetting the SMC make sure you have exhausted all other trouble shooting methods.

  • pictobox Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2011 10:33 PM (in response to AMMOCAN)

    Why?

  • AMMOCAN Level 1 Level 1 (140 points)
    Currently Being Moderated
    Jul 26, 2011 10:58 PM (in response to pictobox)

    Well, because it returns all the hardware on the machine back to it's default settings, which might create problems of it's own. I would highly suggest exhausting all other methods first and if you find yourself needing to try the SMC reset, then be sure to follow the directions correctly and be sure to backup your machine.

  • Paulplace Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2011 11:38 PM (in response to AMMOCAN)

    How do you knows millions of people aren't? They don't all use Discussion Boards. There are plenty of people here with the same model, card and firmware having the same problem (though there maybe be other characteristics we have in common). My local Apple store has had plenty of people reporting this problem, and my local Apple reseller also has. Replicate that around the world and you have a lot of people. What do they have in common, installing Lion. So the problem IS Lion, albeit whether it's the installation process or the software itself.

     

    And there are people having other wi-fi issues, this is very specific. Ie the Airport card is off, will not turn on and has NEVER done so since rebooting after Lion installation.

     

    I am sending a load of info to an Apple engineer who kindly contacted me having read this thread, and I am sure they will solve it.

  • AMMOCAN Level 1 Level 1 (140 points)
    Currently Being Moderated
    Jul 26, 2011 11:54 PM (in response to Paulplace)

    Well, I am here to try and help and I truly hope you all figure out what is the real issue. I am simply saying that many others including myself are not having the issue, so if it was directly related to Lion then everyone would be having the same issue. Since not everyone who is using Lion or who has the same machine/hardware/firmware is having the same issue, then that means that this issue isn't isolated to just one variable and anything you find in common (i.e. machine/hardware/firmware/OS) is just merely a coincidence.

  • Riccardo S. Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2011 1:07 AM (in response to AMMOCAN)

    Well if it wasn't related why are we all having issues AFTER instaling Lion? It's obvioulsy somehow related to the OS,.. since I've installed Lion my network's funny, everytime I start up my macbook Pro it tells me another device is using the same IP and I have to restart Time Capsule and go through a whole annoying procedure to have the Wi-Fi running again, but I haven't found a way to fix it permanently, it just does it again the next day..

  • Harry van der Loo Calculating status...
    Currently Being Moderated
    Jul 27, 2011 1:25 AM (in response to Riccardo S.)

    hi, having the same issues here on a late MBpro 2010.. but intrestingly enough, if i am at work where the wifi is used with a pasword, it works great, yet if i am in an open wifi network, at first it works, but after taking the MBpro out of sleep mode, it will not connect anymore.... although in the top right hand corner it shows wifi is connected...

     

    really frustrating....

1 ... 4 5 6 7 8 ... 19 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.