Skip navigation

New Mac Mini with LED 24" LED Display

48009 Views 176 Replies Latest reply: Jan 16, 2012 2:02 PM by Saul in PA RSS
1 2 3 ... 12 Previous Next
charles.m.h. Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 22, 2011 1:42 AM

Hello all,

 

I just got myself a new Mac Mini yesterday. I connected it to my existing 24" LED Display. Prior to this, my display was connected my MacBook (2009) and I have never had any problems. Since yesterday (connected to my Mac Mini), my LED goes black from time to time (0.1 s randomly). There are quite a few theories about why it does this. Since I have never had this problem before, it seems to me that it maybe something to do with the new Thunderbolt port (on MAC mini) which is used for the display as well.  In fact I have read an interesting article

 

http://www.macobserver.com/tmo/article/thunderbolt_macbook_pro_suffers_flickerin g_display_issues/

 

I suspect the same problem is happening with the new MAC mini.

 

I am keen to see if there will be a firmware fix from Apple, on either the MAC mini or the Display.

 

Charles

Mac mini, Mac OS X (10.7)
  • kram.rebrab Calculating status...
    Currently Being Moderated
    Jul 23, 2011 8:25 AM (in response to charles.m.h.)

    Charles:

     

    I'm getting the same issue - the screen will blank or flicker for a fraction of a second.  It happens about once a minute.  I have a 24 inch Cinema Display and a new 2011 i5 Mac Mini.

     

    I'm sure a fix will be along for this one.

     

    Cheers,

     

    Mark

  • pierregrenoble Calculating status...
    Currently Being Moderated
    Jul 23, 2011 9:24 AM (in response to charles.m.h.)

    Hi,

     

    I also have the same problem with my new Mac mini 2,5 GHz and my 24" Cinema LED display. It's ok during a moment (sometime several hours), and after that it begins to blink once every few minutes. At this time I also ear a fan noise during one or 2 seconds. I had this problem also with a MacBook Air, but it happend rather unfrequently (a few times a day). It seem that a lot of people have this problem and that Apple never did anything about it !

     

    https://discussions.apple.com/thread/2057156?start=0&tstart=0

     

    Pierre

  • DEUCE SLUICE Calculating status...
    Currently Being Moderated
    Jul 23, 2011 4:51 PM (in response to charles.m.h.)

    Same here. Disappointing.

  • DallasGabe Calculating status...
    Currently Being Moderated
    Jul 27, 2011 11:37 PM (in response to charles.m.h.)

    Same setup here, 2.5 i5 and LED 24". Exactly the same problem, took my mini to the apple store and they gave me a new one, but I still having the same flickering problem. I thought something was wrong with my display, it was driving me crazy!

     

    Thanks y'all for posting your problems, now I know I'm not crazy and I'm not alone in this.

    Apple please fix it now!!!!!

     

    Charles, that sounds doable but is not the best solution for hardware that is supposed to work out of the box, that was the reason why I bought a Mac in the first place.

  • tom andre Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 28, 2011 4:15 PM (in response to charles.m.h.)

    I have the same issue with my new mac mini. I have used the 24" led cinema with my macbook pro mid 2010 for almost a year without any problems, but hooked up with the mac mini i5 it goes flickering black. Sometimes very often, makes it useless...The strange thing is that it now happens when I hook up my macbook pro which worked fine prior to hooking up the mac mini...

    I was thinking about sending the display to service (2 months warranty left). But maby its better to wait for an software update? Please do something about this Apple!

  • DallasGabe Level 1 Level 1 (15 points)
    Currently Being Moderated
    Jul 28, 2011 4:33 PM (in response to charles.m.h.)

    My 2 cents:

     

    I was going nuts and decided to do a full restore and start all over again. Booted the mini holding command+R and reinstalled Lion from the Internet.

    Now it seems to be working better, almost not flickering at all. I don't know if it is a hardware issue or it is Lion. Anyone else want to give it a try?

  • DallasGabe Level 1 Level 1 (15 points)
    Currently Being Moderated
    Jul 28, 2011 5:02 PM (in response to charles.m.h.)

    Charles,

     

    I did a clean install.

  • tom andre Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2011 1:51 PM (in response to charles.m.h.)

    Clean install did not work for me...

    I am going nuts...

1 2 3 ... 12 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.