4 Replies Latest reply: Sep 25, 2012 2:50 PM by MilanRusek
danielfromcave creek Level 1 Level 1 (0 points)

I installed Lion Server on my Mac Pro.  Everything looked to be working until I checked Profile Manager and I get an error message "Error Reading Settings"  Not sure how to fix it.  Tried to download Server agian but can't.


Mac Pro, Mac OS X (10.7)
  • 2. Re: I installed Lion Server and when I click on the Profile Manager I get an error and nothing shows - I can't figure out how to re install Lion Server to fix this - any ideas
    Steve Porritt Level 2 Level 2 (260 points)

    Me, too. I found the following thread here in the ASC that had a solution. Alas, it didn't work for me, but it might for you.

     

    https://discussions.apple.com/message/15695605#15695605

  • 3. Re: I installed Lion Server and when I click on the Profile Manager I get an error and nothing shows - I can't figure out how to re install Lion Server to fix this - any ideas
    andrew2011 Level 1 Level 1 (0 points)

    I have also had the 'Error reading settings' problem in Profile Manager, despite trying everything in the discussions and clean reinstalls (which work for a little while only).

     

    It seems that various different fixes work for some people but not others; and the underlying cause of the problem has not been resolved.

     

    There are now numerous threads on this problem (there are yet others with similar problems):

     

    https://discussions.apple.com/thread/3189397

    https://discussions.apple.com/thread/3195100

    https://discussions.apple.com/thread/3212015

    https://discussions.apple.com/thread/3208533

    https://discussions.apple.com/thread/3249062

    https://discussions.apple.com/thread/3199734

    https://discussions.apple.com/thread/3212304

     

    I have posted this in each to try and pull things together a bit.

     

    Does anyone know if Apple has acknowledged the issue and offered an official response?

  • 4. Re: I installed Lion Server and when I click on the Profile Manager I get an error and nothing shows - I can't figure out how to re install Lion Server to fix this - any ideas
    MilanRusek Level 1 Level 1 (0 points)

    Look at /usr/lib/libpq library. I have had the same problem. There were following files:

     

    -rwxr-xr-x  1 root  wheel  163680 30 jul 21:17 /usr/lib/libpq.5.4.dylib

    lrwxr-xr-x  1 root  wheel      15 30 jul 21:20 /usr/lib/libpq.dylib -> libpq.5.4.dylib

     

    Result for command sudo /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/wipeDB .sh was:

    Password:

    devicemgr:state = "STOPPED"

    postgres:state = "RUNNING"

    (in /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend)

    Couldn't drop device_management : #<RuntimeError: Please install the postgresql adapter: `gem install activerecord-postgresql-adapter` (dlopen(/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backen d/vendor/gems/pg-0.9.0/lib/pg_ext.bundle, 9): Library not loaded: /usr/lib/libpq.5.dylib

      Referenced from: /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor /gems/pg-0.9.0/lib/pg_ext.bundle

      Reason: image not found - /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor /gems/pg-0.9.0/lib/pg_ext.bundle)>

    (in /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend)

    Please install the postgresql adapter: `gem install activerecord-postgresql-adapter` (dlopen(/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backen d/vendor/gems/pg-0.9.0/lib/pg_ext.bundle, 9): Library not loaded: /usr/lib/libpq.5.dylib

      Referenced from: /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor /gems/pg-0.9.0/lib/pg_ext.bundle

      Reason: image not found - /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor /gems/pg-0.9.0/lib/pg_ext.bundle)

    /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_spe cification.rb:76:in `establish_connection'

    /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/railties/lib/tasks/databases.rake:69:in `create_database'

    /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/railties/lib/tasks/databases.rake:31

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 636:in `call'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 636:in `execute'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 631:in `each'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 631:in `execute'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 597:in `invoke_with_call_chain'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/monitor. rb:242:in `synchronize'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 590:in `invoke_with_call_chain'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 583:in `invoke'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2051:in `invoke_task'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2029:in `top_level'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2029:in `each'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2029:in `top_level'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2068:in `standard_exception_handling'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2023:in `top_level'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2001:in `run'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2068:in `standard_exception_handling'

    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 1998:in `run'

    /usr/bin/rake:31

    Couldn't create database for {"adapter"=>"postgresql", "username"=>"_devicemgr", "encoding"=>"UTF8", "pool"=>5, "database"=>"device_management"}

    devicemgr:state = "STARTING"

     

    There was missing symlink to right version of libpq dynamic library!

    After I entered the following commands and now it works well for me:

     

    $ cd /usr/lib

    $ sudo ln -s libpq.5.4.dylib libpq.5.dylib

    $ sudo /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/wipeDB .sh

    devicemgr:state = "STOPPED"

    postgres:state = "RUNNING"

    (in /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend)

    (in /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend)

    devicemgr:state = "RUNNING"

     

    Milan