Skip navigation

Unable to disable SMB file sharing: Incorrect password error

23836 Views 61 Replies Latest reply: Mar 1, 2012 8:08 AM by fabiolr RSS
1 2 3 ... 5 Previous Next
lpotr4 Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 25, 2011 12:35 PM

I'm not sure if this problem was present prior to updating to Lion from the latest 10.6, but I can't seem to disable file sharing using SMB on my MBP. I've only known to have used my login password as the same login when I activated SMB share a while back, and now all I get when using the same password is "Incorrect Password". I've tried implementing most of the suggestions I've found in this forum and on the web and that included resetting the password in System Preferences > Users & Groups (Accounts). I logged in using another admin account and it would not also let me turn off SMB sharing and returning an error "Incorrect Password" whenever I typed in what I believe to be the correct password (which is the user/admin pw used to log into the account currently being used). I have also tried: looking through the System Preferences > Security & Privacy (in hopes that FileVault has a hand in this, and it is currently off), then tried repairing Keychain (newp), and lastly, changed the Master Password to no avail. The one suggested fix I didn't try is creating a new user account and migrating all my files to that account. I'd rather not since that is way too much hassle just to turn off SMB sharing.


If anyone has ideas on how to reset or turn off file sharing using SMB, or knows how to resolve this issue, please post some help as this is driving me batty.






PS. Also another unrealted question: Is AirDrop not supported on a 2008 MBP? For the life of me, I couldn't find AirDrop anywhere on my mac (looked at the sidebar and prefs to enable it and it's not there as an option). My card type is an AirPort Extreme (802.11 a/b/g/n -- with firmware Broadcom BCM43xx 1.0)

MacBook Pro 17" 2.6GHz, Mac OS X (10.6), 200GB/7200 RPM HDD, 4GB RAM, 2008 non-unibody
  • darkthunder Level 1 Level 1 (0 points)

    I am having the same issue... there are several posts on various forums about this but no answers yet. Apple I am a new Mac user! Please help!

  • Guy-CP Level 1 Level 1 (5 points)

    Same problem here after upgraded to Lion. I have asked thgis question on other site and got this answer which seems to be the only possible solution to try but unfortunately it is out of my skill


  • JaimeAstin Calculating status...



    I think it is all because of a restore of files from snow leopard....

  • JaimeAstin Level 1 Level 1 (5 points)

    Well, I had the same issue.  Called apple support and no fix.  They made and apple genius bar appointment.  I went.  The genius was good, I got a parking ticket for the time being in the apple store, but still no answer.  The genius deleted the user accounts hoping the rid the problem as a last atttempt.  Still did not fix it.  I told him rather than waste anymore time with this, I was going to reinstall the OS.  I did that and restored from time machine and the problem came back.  So I reinstalled it again without migrating data from time machine and so far I have no issues. 


    My advice to anyone with Lion and needing to share with SMB and use CFIS do not migrate data from a snow leopard backup...   Shoot, I would not migrate from it in any case now.  I notice all of these useless files all over my computer even though the original application was not apple to transfer to lion. 


    My Post on Mac Rumors


    My Video of the Problem...

  • darkthunder Level 1 Level 1 (0 points)

    I don't believe this issue is limited to those that upgraded from Snow Leopard. I have a new Mac Mini with Lion preinstalled and the same issue is happening on my system.

  • JaimeAstin Level 1 Level 1 (5 points)

    I am using a Mac mini (2011) as well...  I honestly can't confirm having the issue before the migrate, but I know I am fine now after the restore and not migrating. I did test with a restore and migrate and the same issue was present.... 


    I know it is an issue none the less.


    Now, on your Mac "darkthunder"' what issue are you having. All of the above, or just one or so.   Just asking as it seems we are troubleshooting each others problem

  • dan67 Calculating status...

    We must recreate a user account but not through the Sharing but by Users and groups. The account created is placed in the group (staff)
    The primary account must be recreated and overwritten.

  • Jackalton Level 1 Level 1 (5 points)

    I had exactly the same problem, and it turned out I had a Sharing account in Users & Groups that I presume was a hangover from my previous SL installation. Deleting this account deleted the account in SMB sharing too.

  • mibrodt Calculating status...

    I believe if you do not have the SMB Sharing box checked, then it shouldn't matter that your user account box is checked because SMB Sharing should be off to begin with. With the SMB Box un-checked, have you tried to connect to your user account over SMB?


    Also, have you tried checking the box for SMB sharing first, then try disabling the account? I don't know if that is a fix, but I now there was a similar issue when trying to add or remove users from Remote Management pane in 10.6. Also, is this just a local account or is it an Active Directory account? I know in 10.6 there seems to be an issue where you can't enable SMB sharing for Active Directory-based accounts (which makes no sense). I wonder if the same is true here.

1 2 3 ... 5 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.