Skip navigation

Lion running slow on Macbook Pro Mid 2010

34490 Views 34 Replies Latest reply: Aug 31, 2012 2:54 PM by MyFreeLunch RSS
1 2 3 Previous Next
brandonfromgowen Calculating status...
Currently Being Moderated
Jul 26, 2011 10:47 PM

Every since I downloaded Lion from the app store I've notice programs running way slower and finding myself having to force quit them.. Also when I put my courser over the top menu bar it takes forever to recognize it.. Especailly when I hover over the wifi icon or volume.. Also when I go under the apple menu to shut down, it doesn't work I have to hold the power button.. Anyone else experiencing problems or no solutions? I think I'm going to put Snow Leopard back on it..

 

 

Macbook Pro Mid 2010

Processor: 2.66GHz Intel Core 2 Duo

Memory: 4GB 1067 MHz DDR3

MacBook Pro, Mac OS X (10.7)
  • LatinoAG Calculating status...
    Currently Being Moderated
    Jul 28, 2011 1:39 PM (in response to brandonfromgowen)

    I am having the same problems. I have forced quit just about everything I have used today.

  • ciroanez Calculating status...
    Currently Being Moderated
    Jul 28, 2011 1:52 PM (in response to brandonfromgowen)

    Same thing is happening with me. The programs are runing too slow. I know a friend that is having the same problem with a MacBook Pro Mid 2010. Ther is any incompatibility?

  • combustion Calculating status...
    Currently Being Moderated
    Jul 28, 2011 1:57 PM (in response to brandonfromgowen)

    I'm running an identical MacBook Pro and have noticed a significant speed increase throughout.

    I have had some issues with the track pad freezing and had to restart but nothing for a day or so now.

  • MacManTW Calculating status...
    Currently Being Moderated
    Aug 2, 2011 3:42 PM (in response to brandonfromgowen)

    I'm having the same issue.. MacBook Pro is very sluggish with Lion installed.. Multiple issues with the programs locking and having to conduct a forced shutdown and reboot. Forcing the app to close does not produce any results.

     

    Do I go Back to Snow Leopard?

     

    I have the 2.53 Intel Core 2 Duo, 15" Pro

    4GB DDR3

  • keg55 Level 5 Level 5 (5,615 points)
    Currently Being Moderated
    Aug 2, 2011 5:02 PM (in response to brandonfromgowen)

    You can try a few things before ditching Lion.

     

    1. Open Applications/Utilities and run Disk Utility. Select your 'Macintosh HD' (or whatever you called it) and run the 'Repair Permissions'.
    2. Delete the ~Library/Caches folder. To get to your user Library that Apple hid, will need to open Finder; then click GO and press your OPTION key to display Library under your Home entry.
    3. Shutdown and clear your System Management Controller (SMC) by holding down the Option-Command-Shift and Power button for 10 seconds then release them. Power up.
    4. For lockups, if you have a version of Adobe Flash Player installed, uninstall it and try the Adobe Flash Player 11 beta (64bit). I'm currently using Adobe Flash Player version 10.3.181.34 which is 32bit and have not had any issues.
  • ciroanez Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 2, 2011 5:32 PM (in response to keg55)

    Thank you very much for the tip. I have just reinstalled the Lion. I did a clean install (formatting the HD and etc.)

    I took care with programs as Adobe Flash Player, Flip4Mac WMV and others that allow play videos. I'm using the Adobe Flash Player beta version and the MBP is running very fast.

    I'm glad for being using Lion.

  • Barney-15E Level 7 Level 7 (33,440 points)
    Currently Being Moderated
    Aug 2, 2011 5:38 PM (in response to brandonfromgowen)

    Kind of an unofficial survey.

     

    I saw a post where someone thought slow issues were caused by not updating to 10.6.8. They reverted back, updated SL to 10.6.8, and then installed Lion and had no problems afterwards. Obviously, there's a lot of changes happening there, so tying it to not going to 10.6.8 first is rather shaky.

     

    So, just interested what number of people having slowness issues went from 10.6.6 or 10.6.7?

  • Nathaniel Rackowe Calculating status...
    Currently Being Moderated
    Aug 4, 2011 10:02 AM (in response to Barney-15E)

    Hey Barney,

    I did the 10.6.8 before updated to Lion but still getting major slowness headache. To compound the problem, I'm running at 27" Cinema Display from my 2.53 Mhz 13" MBP. I'm guessing the extra animated eye candy of Lion is playing havoc with the integrated graphics on my machine. Anyone else having that problem?

     

    Now I need to decide:

     

    Clean install of Lion or revert to Snow Leopard...?

     

    Just don't know is the graphics capabilities of my machine is up to running Lion on a 27"

     

    Any thoughts appreciated.

  • John Kitchen Level 3 Level 3 (635 points)
    Currently Being Moderated
    Aug 4, 2011 10:20 AM (in response to brandonfromgowen)

    You have a 4GB Mac. 

     

    This may help you - https://discussions.apple.com/message/15844464#15844464

  • Barney-15E Level 7 Level 7 (33,440 points)
    Currently Being Moderated
    Aug 4, 2011 12:49 PM (in response to Nathaniel Rackowe)

    I was hoping that would be a relatively easy solution. I guess not. Maybe it was just the wipe and reinstall effects.

  • Nathaniel Rackowe Level 1 Level 1 (45 points)
    Currently Being Moderated
    Aug 4, 2011 3:20 PM (in response to John Kitchen)

    Excellent suggestion. Will order ram in the morning and see how it runs with 8Gb. I'll soon find out if the integrated graphics driving the big display are also to blame.

  • Jan Storgaard Calculating status...
    Currently Being Moderated
    Aug 21, 2011 1:40 PM (in response to brandonfromgowen)

    I have an old MacBook Pro (17” Core 2 Duo)

    Processor  2,33 Ghz Intel Core 2 Duo

    Hukommelse  3 GB 667 MHz DDR2 SDRAM

    Grafik  ATI Radeon X1600 256 MB

    Software  Mac OS X Lion 10.7.1 (11B26)

     

     

    I purchased lion from app store (with worries due to the fact that my mac is old) and it updated it successfully. The next week was a pain, safari and firefox went sloooow, fan running for no reason, whell of fortune spinning, opening folder took forever etc.

     

     

    Yippicayay!

    I decided to do a clean install, and now my old mac is like new again. Everything is snappy and looking good.

    ;o)

     

     

    Just to let you know.

     

     

    Regards

    Jan Storgaard

    Denmark

  • Anthony.Williams Calculating status...
    Currently Being Moderated
    Aug 30, 2011 10:44 PM (in response to Jan Storgaard)

    Hi,

    I have a late 2008 15" MacBook Pro with 4GB RAM.  Since upgrading to Lion I have very similar issues with apps running slow, response times extended and even total feeze ups.  I find the computer is running hot all the time and generaly not the reliable fast machine it was before lion install.

     

    I have done a clean install of Lion now 3 times, but still the problems persist.

     

    I have tried running TechTools but can never get the full analysis complete without the programme crashing.

     

    Could it be a hardware issue?

     

    atb

    Anthony

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.