1 2 3 4 5 Previous Next 60 Replies Latest reply: Mar 2, 2014 12:15 PM by Eric Shawn2 Go to original post
  • 30. Re: Why does Finder jump around (jump around)
    zit Level 1 Level 1 (30 points)
    Still not fixed in 10.6.6
  • 31. Re: Why does Finder jump around (jump around)
    Tj Lensing Level 1 Level 1 (5 points)
    it started for me when i tried to create a new service in automator to gather files into a new folder. it didn't work, but it caused the jumping issue. i deleted the service from username/library/services but no luck. deleting the com.apple.finder.plist from username/library/preferences/ and relaunching finder (opt+right-click on icon in dock) worked
  • 32. Re: Why does Finder jump around (jump around)
    Nancy Salay Level 1 Level 1 (0 points)
    I too have this incredibly annoying behaviour. Unchecking the "spring loaded folders" option does nothing to stop it and neither does removing that file from the Preferences/Lib. Which ordering choice is selected seems to have some effect, but it's still wonky. I changed from "Modified" to "Name" and it jumps differently now. Problem is, I really find ordering my documents by date modified useful. If anyone has any other suggestions, I've love to hear them.

    Cheers,
    N.
  • 33. Re: Why does Finder jump around (jump around)
    KSL LNW Level 1 Level 1 (0 points)

    I agree, the fixes some are reporting may work on some machines, but not on all. I am having this problem with ONLY one finder window, it's a Mac Mini that we all connect to. No one else in my office has this problem, and I have no problem with ANY other finder window. I've tried everything suggested here, uncheck spring-loaded folders, view by anything but name, calculate all sizes is off, etc. If I try to scroll away from whatever was last "selected", it will always jump back to have that folder visible either at the top of the window or at the bottom.

     

    My workarounds are to place the folders I am currently working on in the sidebar and access them from there OR just type the first few letters inthe search field and then you get a window with just that folder (or a few) and it won't scroll as all of the contents fit in the window (I guess?). Another trick is just to scroll to the general vicinity of the folder you want and select something. It will bounce back to that view and the folder you want should be in that window. VERY annoying. (The good thing is, NO ONE wants to work on my computer anymore because of it.)

  • 34. Re: Why does Finder jump around (jump around)
    Crl Williams Level 1 Level 1 (0 points)

    Thanks for this more thorough investigation, which fits with my experience - I thought for a short while that turning off "calculate all sizes" fixed it, but later discovered it doesn't, per your description.

     

    I sort of gave up then, assuming that Apple will eventually get around to fixing it.

  • 35. Re: Why does Finder jump around (jump around)
    ptw Level 1 Level 1 (0 points)

    This appears to be a bug in the Finder's display update algorithm.  If you have your list view sorted by _any_ property whose display might vary (e.g., if you enable View/Options/Calculate Sizes and your view is sorted by Size, or if you enable View/Options/Use Relative Dates and your view is sorted by Date), the Finder seems to (incorrectly) cache the selected entry, and when it updates the display because one of the variable attributes changes, it resets the selection.

     

    So one solution is to turn off those view options.

     

    But another work-around that has worked for me is:

     

      1) Sort the view by Name

       2) Select anything other than the currently selected entry

       3) Now sort the view by whatever you want

     

    This little dance seems to clear the finder's cached (incorrect) notion of what is selected.  You can now move the selection around without the jumping behavior.

  • 36. Re: Why does Finder jump around (jump around)
    snakecarver Level 1 Level 1 (0 points)

    I was having a similar problem with my downloads folder on an external drive. I'm running 10.6.8 on an 21.5in imac. The problem was: the window would always scroll back to the selected file. Very annoying so I came here looking for an answer. When I realised the problem happened only when I was in my download folder, I made a new folder and transfered all my downloads into it and deleted the orginal and renamed the new folder. That solved my problem. Hope that helps others.

  • 37. Re: Why does Finder jump around (jump around)
    TurboDieselNYC Level 1 Level 1 (40 points)

    THIS IS STILL AN ISSUE ON 10.7.2.

     

    This is such a fundamental function to the operation of a computer.. and the fact that it has been ignored through countless updates is an embarrassing reminder of Apple's occasional, yet torublingly debilitating inability to prioritize their efforts on simple things that are REALLY important.

     

    Fix it, NOW.

  • 38. Re: Why does Finder jump around (jump around)
    noondaywitch Level 6 Level 6 (8,130 points)

    Turbo; this forum is not staffed by Apple; we're all users here.

     

    If you want to make your feelings known to Apple use the feedback form.

  • 39. Re: Why does Finder jump around (jump around)
    Papoon Level 1 Level 1 (5 points)

    The explanation offered by ptw seems plausible, and the suggested fix worked for me.  I had the jumping view only in a folder I always had viewed as list and sorted by date modified.  After unchecking Use Relative Dates and toggling the sort column, I can scroll normally with the date sorting.  Thanks!

  • 40. Re: Why does Finder jump around (jump around)
    Tranceplant Level 1 Level 1 (0 points)

    So I think I got some indications on what it is.

     

    Not sure if I am 100% rightyet, but this technic seems to be working for me so far. You will simply need a software to see hidden files on mac. (I use houdini 3)  I can't believe macs  doesn't have a feature to turn hidden files on or off.

     

    1. toggle file visibility on (you should now see a bunch of transparent folders/files a little bit everywhere)

    2. locate the folder with jumping problem

    3. delete the .DS_STORE file you see. Also delete all of the .ds_store files you see in sub-folders as well

    4. close all windows

    if the problem persist rename the problematic folder  and delete the .ds_store again.

     

    With that you should be fine for a while.

     

    From what I understand.  The computer is corupting the .ds_store file which is creating a bunch of problems like moving all the files on your desktop to the right after a restart.

     

    imo that is why some people have this problem and some people don't.

     

    let me know if that hekped you

     

    cheers

  • 41. Re: Why does Finder jump around (jump around)
    BiggerMac Level 1 Level 1 (0 points)

    I have had the exact same annoyance for the year-and-a-half that I've had my MacBook Pro (OSX 10.6.8).  I don't see it as a bug, but it is an annoyance.  What you have to do is this: switch your view from "Cover Flow" to "List."  You see, when you're in Cover Flow view mode, the focus will always go back to the selected (highlighted) item because it's the item in focus in the cover flow frame above.  But when you use the List view-mode, there isn't anything extraneous telling Finder re-focus on, and so you don't get the jumping around effect.

  • 42. Re: Why does Finder jump around (jump around)
    viphoto22 Level 1 Level 1 (0 points)

    FWIW   Talked to local Genius Bar...No fix...no change in lion... Found an App that provides work around  Path Finder by Cocoatech...problem solved

  • 43. Re: Why does Finder jump around (jump around)
    Seung Han Level 1 Level 1 (5 points)

    This is incredibly annoying. It has caused me mistakes at work. I have lost time. This is just amateur hour. Hey Apple, can you fix these fundamental issues so people can use your products productively?

  • 44. Re: Why does Finder jump around (jump around)
    Seung Han Level 1 Level 1 (5 points)

    so has anyone figured this out?

     

    Thanks