0 Replies Latest reply: Aug 6, 2011 5:07 PM by S.T.Smith
S.T.Smith Level 1 Level 1 (0 points)

I'm upgrading to Lion on a dual boot/Boot Camp/rEFIt box and have run into the problems detailed here, here, and here: Lion says "This disk cannot be used to start up your computer," and resizing my OS X partition yields "Partition failed: Mediakit reports no such partition."

 

I've come up with half a solution that involves four ( 4! ) Live CDs, but gets most of the job done. I'm hoping that someone here can post the rest of the solution -- I must repeat this upgrade on other boxes and am hoping to avoid these same headaches.

 

Here's half the solution:

 

  1. Boot 'C' into the Snow Leopard Install DVD, run disk utility, and Verify/Repair the OS X partition, just in case it needs maintenance. Mine did. Bootable backup of everything using Carbon Copy Cloner.
  2. Choose your preferred non-OS X partitioning tool -- I made a live CD of gparted, and it worked. Download the .iso or .cdr and burn a CD of it using Disk Utility Boot the mac holding down the C key, boot into gparted, select the OS X partition, and shrink nondestructively by 129 MB. Reboot into Snow Leopard.
  3. Install Lion from Snow Leopard using the app or the Install DVD you created. It should just work now. Lion shoot boot and work.
  4. Here's where the problems begin. Before, my drive had 4 partitions:

/dev/sda1

/dev/sda2 (OS X)

/dev/sda3 (ext3 Linux boot)

/dev/sda4 (lvm2 Linux root/swap logical parition)

But now, there's the new Lion partition in /dev/sda3:

/dev/sda1

/dev/sda2 (OS X)

/dev/sda3 (Lion recovery)

/dev/sda4 (ext3 Linux boot)

/dev/sda5 (lvm2 Linux root/swap logical parition)

And the MBR for rEFIt and all the grub configuration doesn't know that /dev/sda3 --> /dev/sda4 and /dev/sda4 --> /dev/sda5. A reinstall of rEFIt will figure out the new MBR, but after that, I get a FAIL.

 

I tried a bunch of tricks: using a Linux boot CD, then mkdir /mnt/boot ; mount /dev/sda4 /mnt/boot ; vi /mnt/boot/grub/grub.conf ; grub-install /dev/sda4 ; to try and tell grub about the new partition, but Linux just wouldn't boot from rEFIt. At best, I'd get a grub prompt after trying to boot Linux from rEFIt. I finally gave up and decided that it would be easier to wipe the Linux partitions and start from scratch.

 

Does anyone know how to reconfigure a dual boot machine that has a new Lion recovery partition inserterd into /dev/sda3 and avoid the pain of wiping the existing partitions?


MacBook Pro, Mac OS X (10.7)