Skip navigation

Can't get NAT to work with VLANs in Lion Server

2756 Views 23 Replies Latest reply: Jul 16, 2012 3:25 PM by ctrlb RSS
1 2 Previous Next
Shawn Wilton Calculating status...
Currently Being Moderated
Jul 22, 2011 12:31 AM

I just installed Lion over Snow Leopard and after two days of debugging have discovered that the NAT process is now trying to relabel all of my VLANs.

 

I don't know what changed but in Snow Leopard I was able to have 3 VLANs (Internet, LAN, and Guest) and properly route my traffic.  Now NAT tries to assign different IP addresses to all of my VLANs, which is not going to work.

 

Has anyone managed to get NAT to work with VLANs in Lion?

  • DigiAngel Level 1 Level 1 (40 points)
    Currently Being Moderated
    Jul 23, 2011 8:39 AM (in response to Shawn Wilton)

    I didn't get NAT to work using en0 and ppp0....saw SYN packets out, but that was it.  Good luck...NAT seems hosed with 10.7 Server

  • xplab Calculating status...
    Currently Being Moderated
    Jul 30, 2011 11:33 AM (in response to Shawn Wilton)

    Have you enabled internet sharing in system preferences. If Not Try. Nat will be magically enabled.

  • DigiAngel Level 1 Level 1 (40 points)
    Currently Being Moderated
    Jul 30, 2011 1:40 PM (in response to xplab)

    Internet connection sharing is great if you just want to flip a switch and have everythign done for you, but for granular control of your netblock as well as a mryiad of other things, it's not a good solution.

  • DigiAngel Level 1 Level 1 (40 points)

    LOL....that's flipping awesome!    I have a Mac Mini dual booting Snow Leopard Server and Lion Server....EXACT same hardware setup...SLS works, Lion doesn't...now we know why.  That's pretty pathetic.  My buddy has been waiting for this to get fixed before going to Lion Server, but seeing as how Lion Server is SOO bad...I think he's gonna stay with SLS.  As for me, I'll just keep staring at my 20" iMac happily doing everything I need......running Ubuntu .  Get ready all....Apple's Server product is on it's way out....

  • DigiAngel Level 1 Level 1 (40 points)

    I've been working with Apple since Snow Leopard Server trying to make NAT more workable...to include being able to configure interfaces that are neither up nor have an IP assigned (I should be able to choose it as long as it exists yes?), and to be able to include virtual type interfaces (ppp0 anyone?) in the allowable list in NAT.....so far none of these changes have been made.....I still have to take down everything just in order to put the backup Mac Mini in place and configure NAT...and I still have to manually edit /etc/nat/natd.plist to get to use ppp0.  Eh....I don't think they're listening

  • rowanj Calculating status...
    Currently Being Moderated
    Aug 25, 2011 3:18 AM (in response to DigiAngel)

    Well, here's my +1 for the impact of this; trying to replace my gateway black-box PC with a Mac mini server.

     

    Also, 'server' in the product title and only one ethernet port? that's not even trying... at least the USB ethernet adaptor works - the 'en3' interface that creates btw *does* show up in the sharing settings.

  • john_owd Calculating status...
    Currently Being Moderated
    Oct 26, 2011 2:14 PM (in response to Shawn Wilton)

    > Support did say they are compiling impact data, so if you are affected by this issue, please respond in this thread and if possible contact apple support directly.

     

    I use Server to host Oracle based applications using VirtualBox. The firewall appears to protect the VMs too so using the NAT too provides a very elegant solution.

     

    Pity it is not working on Lion.

  • Tropicalunix Calculating status...
    Currently Being Moderated
    Nov 5, 2011 6:13 AM (in response to rowanj)

    Hi,

     

    how do you manage to have LAN clients ue the ppp0 on the MacMini?

     

    I tried everything but it looks like packets are not "diverted" to ppp0 but remains on en3-en0 gateway. With tcpdump I seeno activity.

     

    Of course it all works locally fromthe macmini, routes seem to be ok,

     

    Thanks for helping, as of now 10.7.2 is completely unusable....

  • DigiAngel Level 1 Level 1 (40 points)

    Check this link:

     

    https://discussions.apple.com/message/16428049#16428049

     

    A gent posted how to do it....I made the files, but haven't had the interest to test it out....I'm just not going to run the OS, so eh...not going to sink anymore time into Lion.  As a side note, natd.plist is no longer used in Lion.

     

    James

     

    P.S. Completely agree with the unusable statement

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.