Skip navigation

Safari 5.1 will not display Java applet window

27640 Views 30 Replies Latest reply: Apr 1, 2013 5:05 AM by Saint Dismas RSS
  • macsantos Calculating status...
    Currently Being Moderated
    Aug 1, 2011 10:17 AM (in response to R1Mike)

    I too am having lots of problems with the new Safari 5.1 update. My system is 10.6.8 (Snow Leopard) and I'm having the trouble mentioned above by many accessing streetsmart.com, the gold site, as well as many other sites that use Java applets.

     

    It seems that this problem is affecting a lot of home users and a lot of businesses. Purchasing managers for corporations are not going to like their teams to be down without a solution for days and days over this. It's clearly a bug that needs to be fixed, and such a glaring one that I'm suprised Safari 5.1 was released with it.

     

    I know, 5.1 is supposed to give us new and exciting security protection, but I find it a little too "new" and too "exciting." I wish I could go back to 5.05. Were there an easy way, I would do it in a heartbeat. Does anyone know the link to the Safari 5.05 installation package? (The above link by laurencefromwichita gives a 404 error.)

     

    Regarding security, I'm all for protection of my home, but a high-tech security system that constantly locks me out of my own house is a waste.

     

    Any of the moderators of this thread, or Apple officials have any idea how we can get our browsers fixed?

  • AF38 Calculating status...
    Currently Being Moderated
    Aug 2, 2011 10:34 AM (in response to macsantos)

    I tried the same Applets with 10.6.7 and with 10.6.8. With 10.6.8 :

         Safari does nothing (not even an error message).

         Firefox shows the applet in its display rectangle but not at the right dimension. Changing the Applet tag parameters width and height changes both the display rectangle and the applet size. Thus the Applet is never fully visible.

     

    A lot of people complain on http://support.mozilla.com/en-US/questions/853621

  • reportjeff Calculating status...
    Currently Being Moderated
    Aug 3, 2011 9:10 AM (in response to R1Mike)

    I found a solution to my applet display problem (as a developer). My applet tags were being generated with the option separate_jvm="true". When I removed this option my applets started to display again.

     

    Jeff Martin

    ReportMill Software

  • AF38 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2011 9:43 AM (in response to AF38)

    I reply to myself.

    I finally found a bug (a missing character) in the code derived from

    <http://download.oracle.com/javase/6/docs/technotes/guides/jweb/deployment_advice .html>

    The code was correctly interpreted by Safari versions older than 5.1 but resulted in no display at all in S5.1.

    With FireFox 3.6.19 I still have a display problem but with that version only.

  • em from key biscayne Calculating status...
    Currently Being Moderated
    Aug 3, 2011 6:27 PM (in response to AF38)

    How can we (non developers) fix that bug?

  • reportjeff Level 1 Level 1 (0 points)

    Assuming your particular problem is the same as mine was, it's possible you could save the HTML page to your desktop, open it in TextEdit (you might have to turn off HTML rendering in preferences) and delete the separate_jvm="true" tag. But there are a lot of ifs in that suggestion.

  • atomicluck1 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Aug 4, 2011 9:48 AM (in response to reportjeff)

    I know that Safari 5.1 was more or less intended for Lion, but why did the Apple software guys not correct known problems for those that do not have Lion?

  • Obasan Level 1 Level 1 (50 points)
    Currently Being Moderated
    Aug 7, 2011 2:09 PM (in response to R1Mike)

    I've been trying to work this out and think that the solution I found will work for most of you as well. Go to

    Applications -> Utilities -> Java Preferences. Under the "General" tab, make sure the "Enable applet plug-in and Web Start applications is checked. Close Java Preferences and restart your browsers.

     

    I don't know why this information is not more easily available.

     

    Hope this helps!

  • macsantos Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 7, 2011 3:54 PM (in response to Obasan)

    What OS X version are you using, Obasan?

     

    I'm using Snow Leopard 10.6.8 and there are no options in Java Preferences such as you mentioned. How would a Snow Leopard user fix this bug in Safari 5.1?

  • Obasan Level 1 Level 1 (50 points)
    Currently Being Moderated
    Aug 7, 2011 7:24 PM (in response to macsantos)

    I'm using Lion. In Snow Leopard, you still have the Java Preferences in the same place -- or you should have, anyway! - but you'll have the option under the "General" tab to Run applets "In their own process" or "Within the browser process." Select "within the browser process." You'll need to restart your browser for this to take effect. Of course, you'll want to make sure "Enable JavaScript" is checked in your Safari preferences! Also, you might consider emptying Safari's cache.

     

    Edit: one other thing. If you are using the AdBlock extension, some of the recent filter updates caused problems for me on a few sites that were showing up as Java errors in the error console. That wasn't the cause of all the problems I had, but it was the cause of a few.

  • Sjazbec Level 4 Level 4 (1,665 points)

    wait for Safari 5.1.1  -- wont be long

  • macsantos Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 8, 2011 6:07 PM (in response to Obasan)

    Hi Obasan,

     

    Thanks again for your reply and your input. I checked Java Preferences in the Utilities folder (Snow Leopard 10.6.8), and verified that applets are set to run "within the browser process" as you suggested. No change needed.

     

    My Safari 5.1 preferences, likewise, contain "Enable JavaScript." I don't run AdBlock or any other Safari extensions.

     

    However, clearing the cache seems to have fixed it, at least for StreetSmart.com and the gold site!

     

    (I'm sure I cleared the cache before, but this time it seems to have done the trick.)

     

    Thanks again for your help!

  • Nickiwi Calculating status...
    Currently Being Moderated
    Sep 14, 2011 11:22 AM (in response to R1Mike)

    I have just found out from the Scifinder site at

    http://libinfo.wordpress.com/2011/07/27/scifinder-web-java-plug-in-available-for -safari-5-1/

    that Apple fixed this with a download, dated 20 July 2011;

     

    Here is the link: http://support.apple.com/kb/DL1421

    After quitting all browsers and installing the dmg, Safari 5.1 still wouldn't work with it until I re-started my computer - perhaps this just flushed a cache and I could perhaps have had the same result just from flushing caches.

     

    If Apple would only look at these threads and inform us!

     

    But I suppose by now most of you have found this anyway.

  • Nickiwi Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 14, 2011 4:03 PM (in response to Nickiwi)

    As skeeterpod pointed out on

    https://discussions.apple.com/thread/3289351?start=15&tstart=0

    this is for Lion, not Snow Leopard.

  • acobxo3bot Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 19, 2013 8:35 AM (in response to R1Mike)

    I have the same problem with new Safary on Mountain Lion. It actually works for the originally posted website but it does not for many other.

     

    It is super anoying!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.