1 2 3 Previous Next 262 Replies Latest reply: Oct 29, 2013 7:15 AM by chirodoody
Ethanace Level 1 Level 1 (0 points)

Ever since I have upgraded my late 2009-iMac to Mac OS X Lion 10.7 I have been experiencing issues regarding my WiFi. I'm actually loosing connectivity, as in AirPort seems to keep "refreshing itself" for no apparent reason, and disconnecting my WiFi intermittently each time. It's almost like my WiFi card can't keep a stable connection to my router anymore. This problem is not occuring on my iPhone, which is also connected to the same home network on the N Router. It's constantly halting downloads halfway through, or near to the end, and they have to be restarted and this is infuriating when the download has taken ages!

 

Even reaching this page now took several refreshes, as Safari keeps coming up with blank pages every now and then telling me I am not connected to the internet.

 

Has anybody else had problems with Lion dropping WiFi connection constantly?


iMac, Mac OS X (10.7)
  • 1. Re: Mac OS X Lion WiFi issues
    Shawn Grinter 2 Level 3 Level 3 (940 points)

    See "More like this" on the right.

  • 2. Re: Mac OS X Lion WiFi issues
    JTF Level 1 Level 1 (20 points)

    Reposting this so people have an easier time finding it:

     

    If your wifi is dropping thanks to Lion, try this first:

     

    * Reboot your router to connect.

     

    * Immediately open Terminal.

     

    * Copy and paste the following line, exactly as is:

     

    ping `route get default | awk '(/gateway/){print $2}'`

     

    And then, don't close Terminal... just "Hide" with command-H.

     

    That's it. This will work for most users, until Apple provides a better fix.

     

    Bonus step, not essential to the fix: Add the DNS server 8.8.8.8 in the "Advanced" section of Network preferences, on the System Preferences panel.

  • 3. Re: Mac OS X Lion WiFi issues
    mannypanda Level 1 Level 1 (0 points)

    After troubleshooting with my Internet cable company, trying all sorts of things, I went into the System Preferences and found that it had "forgotten" my network, defaulted to Ethernet but couldn't find a cable, then I had to re-teach it that the wifi was the correct one, then it worked fine. This happens every couple of days, but it's a lot easier going that route than unplugging things and finding where all those cords go.

    Funny thing: I had clocked the "lock" on that netwrok preference to keep changes, to no effect.

    Looking forward to the fix from Apple.

  • 4. Re: Mac OS X Lion WiFi issues
    mrnickh Level 1 Level 1 (0 points)

    As a systems admin, I am very dubious about 'fix' from JTF.

     

    Setting the DNS to google's and leaving a terminal constantly pinging the default gateway doesn't seem very scientific.

  • 5. Re: Mac OS X Lion WiFi issues
    JTF Level 1 Level 1 (20 points)

    Hah... Well, maybe not easily explained... By me, at least... But from what I know of the scientific process, on which I'm slightly better versed than I am on computer networking, one draws conclusions post test rather than pre test... And for me, dubious as it might sound to an expert, it works. I had drops for hours, every couple minutes. Then I did this. I immediately stopped having drops. And so have many others, scanning back through this forum, though there are some who say it hasn't helped as well. I don't know if that's because the 'fix' is flawed or they're doing it wrong, but there you go. Maybe you could test it, dubious or no, and tell us what happens.

     

    Meanwhile, if this 'fix' helps others, one hopes Apple's engineers are coming across posts like these and taking them into consideration when speeding toward a fix.

  • 6. Re: Mac OS X Lion WiFi issues
    black campbell Level 1 Level 1 (0 points)

    I have the same problem. Sleep the computer and it looses the wifi connection about 70% of the time. It's not a home router issue, as this happens at several other places I work. It ALWAYS happens if I sleep the computer and move from one location to another, and often the fix that seems to work -- turn Airport off/on -- doesn't always work and requires a machine reboot.

     

    It's obviously a Lion issue -- there was none of this under Snow Leopard, and while so far the OS has worked well, this is a niggling issue that crops up way too often. Hopefully, Apple's aware of it and working on a fix.

  • 7. Re: Mac OS X Lion WiFi issues
    rjulao Level 1 Level 1 (0 points)

    I had the EXACT SAME ISSUE. I wanted to slam my iMac on the ground. I tried all the "fixes" posted but none worked. I was on my last resort of going back to SL then i got brave and decided to upgrade my router.

     

    I was using an old Lynksis wireless G router that i've had for many years. I had a $50 BB gift card laying around and figured what the heck. I purchased a NetGear N600 Dualband Wireless N router. Took it home and set it up.......2 weeks in......NO ISSUE. At all. My iMac stays connected and has not dropped (5.0mGhz band). Even after sleep, it finds and connects. I don't know if it was wireless G old router just banging me out but this surely "fixed" my issue.

     

    I'm just glad i had that gift card.

  • 8. Re: Mac OS X Lion WiFi issues
    zarchbraeden Level 1 Level 1 (0 points)

    JTF, I think that the reason mrnickh is dubious is becaue it is considered a network attack to constantly ping a site. Short pings for tesing is one thing, but to constantly ping your gateway? This is not a valid solution to this problem, even though I've seen it on many forums. It is a violation of your terms of service with your ISP in many cases as well.

  • 9. Re: Mac OS X Lion WiFi issues
    JTF Level 1 Level 1 (20 points)

    Thanks Zarch, for the warning... you had me worried, since I've been one of the ones recommending the ping 'fix.' And naturally, I'd agree with you that any solution other than an Apple fix is less than ideal.

     

    I was concerned enough by your post to do some digging, and came across enough network experts (again, which I'm not) who had this to say about 'pinging': constant pings are only a problem when (a) the packet size is large or (b) the pings are sent from several different machines to one location at exactly the same time.

     

    For instance, when pinging is large enough to become illegal, it's a packet size of 65,535 bytes. These pings from the Terminal that we're talking about here are only 64 bytes. And since it's a ping to one's own gateway, we're all going to be pinging a different location, yes?

     

    I ask that because I'm genuinely unsure.

     

    This would be different, right, from pinging yahoo.com or something constantly? That's what someone early on in this thread recommended. But I didn't do it because that, to me, sounded 'dubious.'

     

    If indeed the ping of the gateway is not right, is there a better and even more local ping command people can use? Seems like the original person who suggested this was saying it's only the need for some kind of constant activity that keeps the connection open.

  • 10. Re: Mac OS X Lion WiFi issues
    matfromchicago Level 1 Level 1 (0 points)

    Hi Guys,

     

    My issue more serious than dropping connections. I CANNOT CONNECT!! I keep getting connection timeout from our all office access points. But anywhere else , i can connect decently.

     

    I joined this company for 6 months now and had no problem whatso ever until 1 day after updating to lion. I HAVE NO IDEA , is it software or hardware!! In boot camp also my wireless is not connecting to routers...I cannot believe it is hardware issue because i can connec to all other networks.

     

    Changing the wireless router config is IMPOSSIBLE. it take me 10 days to get appointment to see the IT guys and they are not going to change anyting on router. I end up buying a wireless usb adapter. It is ******* me off. Any help?

     

    This is my wifi card spec:

     

      CoreWLAN:          2.0 (200.46)

      CoreWLANKit:          1.0 (100.43)

      Menu Extra:          7.0 (700.42)

      configd plug-in:          7.0 (700.57)

      System Profiler:          7.0 (700.3)

      IO80211 Family:          4.1 (410.1)

      WiFi Diagnostics:          1.0 (100.26)

      AirPort Utility:          5.5.3 (553.20)

      Interfaces:

    en1:

      Card Type:          AirPort Extreme  (0x14E4, 0xD6)

      Firmware Version:          Broadcom BCM43xx 1.0 (5.100.98.75.6)

      MAC Address:          e4:ce:8f:03:ae:20

      Locale:          APAC

      Country Code:          X1

      Supported PHY Modes:          802.11 a/b/g/n

      Supported Channels:          1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 149, 153, 157, 161, 165

      Wake On Wireless:          Supported

      AirDrop:          Supported

      Status:          Connected

  • 11. Re: Mac OS X Lion WiFi issues
    mauryr Level 1 Level 1 (0 points)

    I have the same issue as the original poster, late 2009 iMac i7 that has regular connectivity issues of the same kind.

     

    Of interest is the Atheros chipset in the iMac. I have two other Macs in use with Broadcom chipsets, which have no issues at all.

  • 12. Re: Mac OS X Lion WiFi issues
    BryceBridges Level 1 Level 1 (0 points)

    I began having this problem on my mac book shortly after upgrading to Lion. I have an activity monitor in my finder bar and I see that no outgoing communication. I have found that turning my wifi off and then back on fixes it in the short run, but it always happens again later, and then I turn off wifi and turn it back on again. I hope that Apple is working on this annoying bug

  • 13. Re: Mac OS X Lion WiFi issues
    mannypanda Level 1 Level 1 (0 points)

    Had an AppleCare conversation in which the guide had me add a new "Location" in the System Prefs->Network panel, then select it. My new "location" is "at home," nothing special. He said to give it a day or 2 and see if it holds. If not, I am to contact the router mfr. FYI.

  • 14. Re: Mac OS X Lion WiFi issues
    ThaOne Level 1 Level 1 (0 points)

    I got this from another user on a similar post: Go to Library/Preference and copy SystemConfiguration then delete the folder and restart your computer. This worked for me.

1 2 3 Previous Next