Skip navigation

iphoto 8.1.1 to 9.1.5 migration

312 Views 6 Replies Latest reply: Aug 10, 2011 5:25 PM by rjanuary RSS
rjanuary Calculating status...
Currently Being Moderated
Aug 9, 2011 11:20 PM

Hello, I recently purchased a new iMac to replace my aging 24" iMac (circa 2007)

 

In the time I've been using the previous iMac I've spent a signifiant amount of time organizing my pictures using iphoto.  My iTunes library I was able to copy it from my old machine to the correct location on my new machine.

 

I expected to do the same for iPhoto, but it appears as though I'm not quite so lucky.  After copying the entire library, and opening iphoto I get an error "The iPhoto Library is locked, on a locked disk, or you do not have permissions to make changes to it."

 

I am able to write to the drive and my current user is owner of the files.  in terminal I do oddly get a permissions error when trying to mkdir or touch a file.  I am able to do maintenance through sudo.

 

I've tried doing a copy across the network and also pulling off of a timemachine backup with the same issues.  Are the library formats between the two version disparite enough that it's causing these issues?  If so, what is the supported migration path in this situation?

iPhoto '11, Mac OS X (10.7)
  • LarryHN Level 9 Level 9 (54,915 points)
    Currently Being Moderated
    Aug 9, 2011 11:24 PM (in response to rjanuary)

    How did you move the iPhoto library?

     

    Migration assistance does not handle the iPhoto library well sometimes - the best way is to drag the bad iphoto library from the pictures folder on the new system to the desktop, connect the two systems together (network, firewire target mode, etc) and drag the iPhoto library intact as a single entity from the old system to the pictures folder of the new system and launch iPhoto on the new system - it will open and convert the iPhoto library as necessary and you will be fine - once you test the iPhoto library you can delete the one on the desktop

     

     

    LN

  • Old Toad Level 10 Level 10 (113,315 points)
    Currently Being Moderated
    Aug 10, 2011 11:00 AM (in response to rjanuary)

    My next effort this evening will be putting the old mac in target disk mode and trying to copy from there.

    The odd thing about it is I can browse the photos through finder without incident.  If there should be no issues with library formats between the two versions at it's core I think this has to be a file perms/flag issue, I just have to find out on what files and why.

     

    That method should work as expected.  When you open the transferred library with iPhoto 11 you will be notified that iPhoto will have to convert the library and you'll go from there.

     

    For permission issues with a library is do the following:

     

    1 - download and launch BatChmod

    2 - drag the iPhoto Library into the BatChmod window. 

    3 - set the ownership and privileges settings to that shown in this screenshot:

     


    Click to view full size

     

    4 - launch iPhoto.

     

    You can use any group you'd like.

     

    OT

  • Old Toad Level 10 Level 10 (113,315 points)
    Currently Being Moderated
    Aug 10, 2011 12:49 PM (in response to rjanuary)

    I don't know enough about the ACLs so I leave that box unchecked when I use BatChmod.  if you learn anything more definitive about it let us know.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.