Skip navigation

10.6.8 Server - workgroup manager not authenticated

2621 Views 7 Replies Latest reply: Oct 18, 2012 4:31 PM by BioRich RSS
JP256 Calculating status...
Currently Being Moderated
Jul 28, 2011 2:53 PM

I have 10.6.8 Server that has suddenly stopped accepting the dradmin password when using Workgroup Manager.  Workgroup Manager connects, but in not authenticated mode.  When I click the lock icon and am prompted for the ID & Password it is rejected.  I know with 100% certainty I am using the correct administrator ID and password.  I am running Workgroup Manager directly on the server computer.  I'm able to log on to the computer as the local administrator. Server Admin works fine with no authentication issues.

 

I have not applied the 10.6.8 Supplemental update, but wonder if that might be helpful.

 

It is very concerning to be locked out of my own server. Any suggestions why this is happening and how to reslove it? 

 

Thank you,

-Joe

Mac mini, Mac OS X (10.6.8), 10.6.8 Server
  • dmare Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jul 28, 2011 5:54 PM (in response to JP256)

    I have experienced the same problem before.  A restart of the server resolved it in my case.

  • parexcel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 5, 2011 1:38 PM (in response to JP256)

    I have seen in earlier posts going back to 10.4 I believe that this happens, and rebooting often cures it, but one person reported success by getting the right combination of choices for Open Directory > Policies > Binding under the heading Security.  He/she said they rebooted between changing the combination to use, so it could well have been the rebooting that solved it.

     

    Can you get more detailed info about the reason for the failure to authenticate from the Open Directory logs?

  • parexcel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 11, 2011 8:01 AM (in response to JP256)

    I can't think of anything in particular to try, except maybe to make sure diradmin had all its proper privs.

     

    The problem I am actually having, posted elsewhere, is that when I change the password for diradmin to comply with regulations requiring password changes every 90 days, Samba stops working.  Logs show that SMB users authenticate properly, but Samba fails to authenticate its diradmin attempt.

     

    Everything I've found on the web suggests that's just how it is.  I've tried disabling / enabling Samba and various types of authentication in hopes of triggering the GUI to rebuild Samba configs, but no luck.  I don't know Samba internals but my poking around suggested I wasn't going to be able to hack a password into it.

  • jpt11 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2011 2:57 PM (in response to JP256)

    I had success with the method that parexcel mentioned.  I had turned on a couple Security Preferences in Server Admin->Open Directory->Policies->Binding; in my case Disable clear text passwords and Encrypt all packets.

     

    Once I rebooted, I could no longer login to the server.  After I disabled these security options and rebooted, I was once again able to login. 

     

    I don't know if you are having the same problem, but it definitely sounds like it.

     

    Jeff

  • BioRich Level 1 Level 1 (65 points)
    Currently Being Moderated
    Oct 18, 2012 4:31 PM (in response to jpt11)

    Just to add to this old thread, I just did exactly that, and it worked:

     

    1.  Server Admin: Open Directory: Settings: Policy: Binding: engage Disable Cleartext... & Encrypt all packets...Save.

     

    2.  Disengage what I just clicked.  Save.

     

    3.  Restart box

     

    4.  Workgroup Manager: login as network admin, authenticate using diradmin

     

    I have faint memories of this problem before, and years later, it just crept up once again. 

     

    Cheers

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.