Skip navigation

Belkin Network USB Hub (F5L009) - problem solved!

63766 Views 101 Replies Latest reply: Mar 7, 2014 6:31 PM by Carneiro RSS
  • ixanderMbP Calculating status...
    Currently Being Moderated
    Jul 21, 2011 10:47 AM (in response to vinsup)

    After updating Little Snitch my Belkin USB hub started working again.. I'm not sure if I ever installed any drivers btw.

  • matthiasfromzürich Calculating status...
    Currently Being Moderated
    Jul 24, 2011 5:03 AM (in response to petero221)

    Thank you petero221

    The only problem is that it allways disconnect my printers (green light goes off after a while). Have you any idea?

     

    I'm using Snow 10.6.8 and the printers (Epson Stylus Photo R2880 and Epson Stylus Pro 7600) over my Belkin USB Hub.

     

    Thanks to all for any help, i'm slowly getting mad...

     

    Greets.

    Matthias

  • DoroS Calculating status...

    Thanks a lot petero221

    I'm using Lion and your provided solution was very helpful. My Belkin USB Network Hub started working again.

     

    Doro

  • frankfromdover Calculating status...
    Currently Being Moderated
    Jul 26, 2011 6:10 PM (in response to petero221)

    Thank you Petero221. Worked in seconds!

  • Rhiannon36i Calculating status...
    Currently Being Moderated
    Jul 27, 2011 9:44 AM (in response to Keith Parr)

    Hi,

     

    I've followed the link and have managed to install the drivers. The SX Virtual Link is working and I can see the two printers and USB drive attached to it. Unfortunately when I try to connect to any of the devices I get a "Connection failed" message.

     

    I am new to the Apple scene so any help would be appreciated. I'm running Lion on a MacBook Pro.

     

    Thanks

    Noel

  • vinsup Level 1 Level 1 (5 points)

    Sounds like what I was facing. Try installing using the .pkg file under the 10.6 folder, it worked without issues though it did ask me to restart.

     

    Hope this helps.

  • Rhiannon36i Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2011 3:36 PM (in response to vinsup)

    Hi,

     

    Many thanks that seems to be working, I can now connect and print.

     

    Noel

  • cjrobledo Calculating status...
    Currently Being Moderated
    Jul 31, 2011 4:13 PM (in response to petero221)

    My usb hub worked perfectly under Snow Leopard. When I updated to Lion it stopped working. I installed the package SX VirtualLink_10_6 and it works perfectly again in Lion.

     

    Thanks for your help.

  • James Staniford Calculating status...
    Currently Being Moderated
    Aug 5, 2011 11:10 AM (in response to petero221)

    I'm running lion and bought a belkin usb hub and downloaded the silex software it works fine hoever it can't connect to my usb devices I have tried a few different one and it always comes up with the banner connection to usb disk failed.

     

    Can anybody shed anylight on this?

  • diablanco Calculating status...
    Currently Being Moderated
    Aug 10, 2011 10:15 PM (in response to petero221)

    THANK YOU!!  This problem plagued me for months!

  • Ringo De Smet Level 1 Level 1 (85 points)

    James,

     

    I also encountered this after the initial install of the SXVirtualLink_10_6 installer package. However, this package is dated 17 Oct 2009, while there is a more recent kernel extension package available under:

     

    SXVirtualLink/contained_packages/Driver/10_6/Silex_kext    (29 March 2010)

     

    I ran this installer package after installing the SXVirtualLink_10_6, rebooted my machine, and now I got rid of the connection failed messages. So far I tested the hub with 2 printers and it seems to work fine.

     

    Ringo

  • pbracegirdle Calculating status...
    Currently Being Moderated
    Aug 13, 2011 12:29 PM (in response to petero221)

    Cheers, worked a treat for me, Best Regards, PeteB

  • Rob Kamstra Calculating status...
    Currently Being Moderated
    Aug 14, 2011 7:32 AM (in response to petero221)

    Hi,

     

    I also bought a Belkin network usb hub, i'm running Lion but when i install the SXvirtuallink_10_6 software with the 10.6 Silex kext it all connects well!, but after a minute or 2 it constantly disconnects my usb devices all the time?, i have no idea what could be the problem because when i read these latest posts in this thread there were some persons who had succes with installing the Belkin network usb hub with the Silex software and the 10.6 Silex kext under Lion OS.

     

    So please help me to find a solution!

     

    Thanks in advance!

     

    Rob

  • compuswa Calculating status...
    Currently Being Moderated
    Aug 15, 2011 12:21 PM (in response to petero221)

    I recently contacted Belkin to inform them that my home Base did not work under OS X Lion.

    Belkin replied that Belkin had discontinued my product and was not able to support the software of my 4 months old Belkin Home Base (reed their answer below)

    This answer really ***** !

    Today I found here in this tread this simple solution to make it all work again.

    So, why those clever boys of Belkin were not able to provide that answer?

    Only interested in selling new products I suppose?

    Or do they have to pay a fee for the new Silex kext 10.6 when they provide us this update?

     

    This was the answer I receaved from Belkin:

    Response (08/08/2011 09.59 AM)

    Good morning, thank you for your e-mail.

     

    I am very sorry to hear of your issue.

     

    I am sorry to say that the Belkin Home Base's software is not compatible with Mac OS Lion. I regret to say that the product was discontinued sometime ago and it will be unlikely that any further software will be developed for the product so please accept my sincere apologies for this. I can only suggest you speak to your reseller who you purchased the product from for a refund as the product is not compatible with your OS.

     

    Once again please accept my apologies for your issue.

1 2 3 4 5 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.