Skip navigation

10.6.5 and wifi issues

191311 Views 496 Replies Latest reply: Aug 5, 2012 9:12 AM by RCully RSS
  • volkswagner Calculating status...
    Currently Being Moderated
    Jul 12, 2011 4:03 AM (in response to dabellator)

    Well I have two MacBooks with the Atheros chip.  One is happy running 10.6.7 with firmware Atheros 5416: 2.1.14.5, while the second refuses to use the newer firmware.  I used the same procedure to install SL.  There must be different revisions of the card.  Both cards are identified by "Airport Extream (0x168C, 0x87).  I have not taken the unit apart to see if there are revision numbers on the card.

     

    Since It is not difficutl to install the older Kext, that is what I have done.  I'll keep a local copy of the instructions and file.  don't expect Apple to help.

     

    One thing I do notice when checking the profile.  The unit running the newer hardware shows other (Neighboring) wireless networks after the network it is connected to, while the unit with older firmware only listes the connected network in profiler.

  • BananaMacintosh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 12, 2011 4:07 AM (in response to volkswagner)

    Thanks for that information volkswagner, it looks like we finally identified why it probably passed by Apples testing stages for the driver.

  • lot77 Calculating status...
    Currently Being Moderated
    Jul 24, 2011 11:55 PM (in response to BananaMacintosh)

    The issue still exists with OS X Lion. The IO80211Family.kext shipped with Lion is version 4.0 and the firmware shows as 2.1.14.9 now. However, the wifi connection is still unusable. I downgraded to 3.1 of the kernel extension as discussed above and the wifi connection is working as expected now.

  • markfromkawana waters Calculating status...
    Currently Being Moderated
    Aug 7, 2011 4:06 PM (in response to lot77)

    Hey Lot77, Yeah i seem to be having the same issues with Lion, I am currently running 10.6.8 with 10.6.4 IO80211Family.kext but doesnt seem be working, System info confirms i am running the older version.

     

    As Beth Shoshan mentioned previously this issue was resolved in one of the Beta releases of Lion.

     

    Why would they have reverted back to the problematic kext with the Production release ?

     

    This issue is appauling, I have tried many many routers to try and isolate this problem.

    I can confirm that a Buffalo WHR-HP-G300N running DD-WRT is glitch free.

     

    I tried the IO80211Family.kext from 10.6.4 but it did not resolve my problem.

     

    First OSX Machine, While many plus's this is a major negative. This is just not acceptable. I am not a happy customer/developer

  • matfromchicago Calculating status...
    Currently Being Moderated
    Aug 8, 2011 11:47 PM (in response to matteocaldari)

    Hi guys,

     

    I am on Lion 10.7 and have this issue. Any work around for it?

     

    Mine, happen like nothing. I went out for lunch and came back and wireless was diconnected and could not connect to any of networks in our office. I was connecting to same network for last 6 months and out of blue this happened 1 day after update to lion.

     

    I wiped out and installed 10.6.7 but still not working. Then update to 10.7.8 NOT WORKING. i can connect to all wireless routers. My house, shopping malls BUT not those in the office. I am freaking out.  Apple did nothing for me since it was working on apple shop.

     

    Any help? Should i downgrade using what suggested method ? Lion has this problem also? Can anybody confirm?

     

    Thanks.

  • BananaMacintosh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 9, 2011 3:29 AM (in response to matfromchicago)

    matfromchicag,

    If you are having the same issue with what was described in this thread, your wireless (Atheros 5416 card) should work with OS X 10.6.4 (atheros firmware 2.0.19.10). This issue is that Apples firmware update breaks wireless with Atheros 5416 cards under OS X Snopw Leopard 10.6.5 (atheros firmware 2.1.14.5), 10.6.6, 10.6.7, 10.6.8 and the current Lion 10.7. Did you have issues with them versions aswell? If so, you could try the work-around described by tenortims to downgrade the kext file back to 2.0.19.10:

     

    Download the IO80211Family.kext file taken from the 10.6.4 update here:

    http://hotfile.com/dl/111337068/eee082f/IO80211FamilyKext_10_64.zip.html

     

    Then, you can follow tenortims instructions:

     

    1) As root, cd to /System/Library/Extensions, rename IO80211Family.kext to IO8021Family.1066 (or anything else to back it up), and copy in the replacement IO80211Family.kext that we extracted from 10.6.4.

    2) Download, install and run "Kext Utility" (Google it, it's at Insanely Mac). It should ask for your password, run, and fix up the kext permissions and caches.

    3) Reboot. You should now be on the new (old) driver/firmware. Verify by running "About this Mac" -> "More Info" -> "Network" -> "Airport". As stated, the newer firmware is 2.1.14.5, the working firmware is 2.0.19.10.

     

    To recap, the IO80211Family.kext file ver. 2.1.14.5 or above *does not* work with some Atheros 5416 cards. This means that if you have this card and are experiencing difficulties with the 10.6.5, 10.6.6, 10.6.7 10.6.8 update, you will need to replace the newer IO80211Family.kext file with the older ver.2.0.19.10 one.

     

    The downgrade of the IO80211Family.kext file to the 2.0.19.10 version (taken from the 10.6.4 update) worked for me under Snow Leopard 10.6.4, 10.6.5, 10.6.7 and 10.6.8 on my 2007 Macbook 13.3 core 2 duo with a Atheros 5416 card. I have yet to upgrade to Lion 10.7 and see if it works for that too.

    lot77 claims that the downgrade workaround does work for Lion 10.7, but markfromkawana waters claims that it does not work.

  • matfromchicago Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 9, 2011 3:36 AM (in response to matteocaldari)

    Thanks for reply but

     

    1. now i am in 10.7.

    2. My firmware version reads as  "Broadcom BCM43xx 1.0 (5.100.98.75.6)"

     

    Can i still use same workaround?

     

    My surprise is this machine was WORKING for 6 MONTH at same place with same wifi network... out of suddent it stops working. I even had it working on lion for two days but it stops. I wiped out the whole hard drive and installed SL and nothing changed.

     

    Any insights?

     

    This is my wifi settings: I have first generation of 2011 thunderbolt MBP with SSP and Quad Core i7.

     

     

      Software Versions:

      CoreWLAN:          2.0 (200.46)

      CoreWLANKit:          1.0 (100.43)

      Menu Extra:          7.0 (700.42)

      configd plug-in:          7.0 (700.57)

      System Profiler:          7.0 (700.3)

      IO80211 Family:          4.1 (410.1)

      WiFi Diagnostics:          1.0 (100.26)

      AirPort Utility:          5.5.3 (553.20)

      Interfaces:

    en1:

      Card Type:          AirPort Extreme  (0x14E4, 0xD6)

      Firmware Version:          Broadcom BCM43xx 1.0 (5.100.98.75.6)

      MAC Address:          e4:ce:8f:03:ae:20

      Locale:          APAC

      Country Code:          KR

      Supported PHY Modes:          802.11 a/b/g/n

      Supported Channels:          1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 34, 36, 38, 40, 42, 44, 46, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 149, 153, 157, 161

      Wake On Wireless:          Supported

      AirDrop:          Supported

      Status:          Not Associated

  • maayank Calculating status...
    Currently Being Moderated
    Aug 12, 2011 12:11 PM (in response to matfromchicago)

    I had the same problem with my new MacBook Air 13". It was driving me crazy. It seems like there really is a problem with Lion and the new MBA WiFi chipset.

    I finally solved it by replacing the 802.11 kext with the older version, as outlined above me. (Yippy!!! )

    matfromchicago, I also have a Broadcom chipset and it still helped.

    I posted a recap of the whole experience (and solution instructions) here: http://thoughts.maayank.com/2011/08/wireless-problems-with-macbook-air-and.html

    Hope you find it helpful!

  • EJW Tas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 12, 2011 8:08 PM (in response to matfromchicago)

    SOLUTION FOR WIFI CONNECTION ON LION

     

    This looks like the answer to poor wifi on Lion - I have just installed the 10.6.4 kernel extensions for airport as per these instructions and my wifi connection is SOLID. Back to 8011 n only and transmit rates at 300 (max) rather than 8011 n (b/g compatible and transmit rates of 120-130). Also network connect is solid after sleep and shut down, so matfromchicago and earlier posts/threads get the kudos for solving this massive Lion issue.

     

    Follow the instructions here or at  https://discussions.apple.com/thread/2644274, and here https://discussions.apple.com/thread/2644274?start=465&tstart=0 (look close to bottom of page) with another post from matfromchicago and more details on the problematic kernel extension.

     

    This MAY NOT solve your particular problem, but it seems to be working for everyone who replaces the Lion wifi kernel extension with the one from SL!!

  • _R_ Calculating status...
    Currently Being Moderated
    Aug 12, 2011 10:05 PM (in response to EJW Tas)

    I've tried doing the 10.6.4 kext on my 2011 iMac running Lion as I'm having issues with the wifi connecting to my N network... (had problems as well in 10.6.8)

     

    no dice.  it has an Atheros 9380 wifi card in it...  current firmware is 4.0.55.4-P2P

     

    If i do the 10.6.4 kext swap, it tells me no wifi hardware, I'm thinking it's because this is a new airport card (that triple antenna one) that wasn't released back in 10.6.4 days, so the kext from back then probably won't work with this new card...

     

    put the 10.7 kext back in and wifi kicks back in, but still N network issues...

     

    any ideas?

  • maayank Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 13, 2011 12:52 AM (in response to _R_)

    _R_, are you sure you installed the new Kext correctly? (extracted the proper file from the zip file to the correct place, fixed permissions, built kext cache)

     

    I received the same message when not installed correctly.

     

    edit: Also: people have reported that "The problem" didn't exist for them in Lion beta. You could try and get the kext file from Lion beta and see how's that works for you.

  • _R_ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 13, 2011 3:34 AM (in response to maayank)

    I used the instructions on your website...

    I'm assuming that by going back and installing the "backup 10.7 kext" and getting the wifi to work again, that I was indeed following the instructions correctly...

  • mdb983 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2011 11:15 AM (in response to matteocaldari)

    I have an IMac and a MacBook Pro, both set up the same way and both experiencing the connection dropping, consistently, after placing the system in sleep mode, once upgrade to Lion.

     

    I kept the MacBook unchanged and played with settings on the IMac by way of identifying the cause of problem.

     

    I finally have stability again on both systems after changing the Channel on the router (it was set to 1). I can see several other wifi networks and perhaps Lion is a little more sensitive. Just for reference, my  Authentication is and has always been set toWPA-PSK and encryption set to AES

  • mspacer Calculating status...
    Currently Being Moderated
    Aug 25, 2011 6:51 AM (in response to matteocaldari)

    Just to add that the kext fix worked for me.  10.6.8 on a MBP 15" 2.16.

     

    Did have an issue with terminal running in sudo mode.  It still wouldn't give me permission to change files.  I finally went to the folder itself. I dragged the kext file in question out and it made a copy.  I then dragged the 10.6.4 version into the folder and got spanked, but told it to authenticate anyway.  Replacement was made and I repaired permissions with Kext Utility.  Reooted and solid ever since.

     

    Wanted to post this for those who don't like or have problems using Terminal.

     

    Thanks to all for figuring this out and posting the link to the 10.6.4. kext file.

  • robertfromperth Calculating status...
    Currently Being Moderated
    Sep 19, 2011 8:34 AM (in response to EJW Tas)

    Have tried BananaMacintosh's suggestion on Lion (10.7.1) with the Atheros 5416 chipset. Tried the latest Kext Utility to work with Lion (2.5 - http://www.megaupload.com/?d=5KTQQINJ), to repair the Kexts after downgrading the kext file, but on re-boot I too had the 'No hardware installed' error. Reverted, rebooted and tried again just in case - but still no wifi joy for me either.

    Currently have huge bit of Cat5 running through the house instead.

    Have raised a bug report with Apple: bugreport.apple.com Make sure you do too, just to get this annoying issue rectified in 10.7.2

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.