Skip navigation

No Sound through HDMI - Mac Mini

306973 Views 62 Replies Latest reply: Mar 23, 2014 1:56 PM by KoyangieVA RSS
  • DM Smith Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 3, 2011 7:54 PM (in response to krusdublin)
    I had been struggling with this for weeks. Reading this put me onto a different solution.
    I was running EyeTV (a TV Tuner) which was configured to output over HDMI. When I'd watch a video in Safari, while pausing EyeTV, the sound would come out over Internal Speakers. No matter how much I tried System Settings >> Sound >> Output >> HDMI or going into MIDI setup, right clicking and choosing "Play Sounds over this device" (or whatever it actually says), it never took.

    When I went into EyeTV Preferences and told it to play over Internal Speakers rather than over HDMI, then I could do the other settings and sound went out over HDMI.

    Appears that only one program can send sounds over HDMI at a time, even if paused. Very unlike internal speakers where all sources can play at the same time.

    Hope this helps.
    MacMini Core Duo, Mac OS X (10.6), Late 2010
  • macfan979 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 12, 2011 11:41 AM (in response to krusdublin)
    I had the same problem, cannot get audio through TV speakers when connected via HDMI.

    I apologize if this has already been mentioned, but all i did was mute the Apple internal speaker option and even though the sound bar is grayed out for the TV that is connected, i at least get audio through the TV speakers.

    sorry if this doesn't address the entire problem, which I have found to be cannot control the TV speaker volume from the Mac mini.
    mac mini mid 2010, Mac OS X (10.6.6)
  • David Mcleod Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 6, 2011 3:51 AM (in response to macfan979)
    Guys, I came across this post when connecting my Mac Mini to the TV via HDMI recently.

    Make sure you aren't being impatient when selecting the TV as audio output via Preferences > Audio > Output.

    You need to make sure you close down any apps running that output audio and re-start them after fiddling with this setting.

    I thought my Mac Mini couldnt do audio out via the HDMI cable when I tried a video in Safari.
    I quit Safari and re-launched it, played the video again and audio was working fine.

    As someone mentions further back in this post it is a 'handshaking issue', so just make sure you close any apps that use audio first, select the TV as audio output, and then relaunch your chosen application(s) and try again.

    It is also worth pointing out that some TV's (via their internal menu on the TV itself), also have a setting whereby you sometimes need to tell it to also use audio over the HDMI cable. (this is for people who might use a fancy audio system for movie sound and the TV for video only).

    Hope that helps.

    Message was edited by: David Mcleod

    Message was edited by: David Mcleod
  • john969 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 23, 2011 2:16 AM (in response to krusdublin)

    If you are using Plex...

     

    Preferences>System>Audio>Audio Output Device> change to HDMI

  • bommai Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 11, 2011 6:50 PM (in response to krusdublin)

    Actually, instead of pausing a program in eyeTV, close that window (don't quit eyeTV though).  eyeTV holds on to the audio output device and that is why other programs cannot output audio through that device.  This is true for optical audio also.  I have an iMac with optical audio and if I pause eyeTV, other sounds don't come through.  But if I close the playback window, then it works.  I kinda like this because in older version eyeTV did not do this and many times, I had to manually tell eyeTV to use encoded digital audio to get dolby digital 5.1 otherwise it will send two channel.  Now it is automatic since eyeTV takes control as soon as a program is played and keeps it even if it is paused.

  • ToryVision Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2011 12:20 AM (in response to krusdublin)

    All,

     

    Check your HDMI default clock source. In this case it would be a hand-shake issue as I had set my clock to 96K (to support another pro audio recording application) instead of the 44.1K that HDMI on the TV was looking for.

     

    You can find the clock settings in the Audio Devices menu under Audio Midi setup (Utilities/Audio Midi Setup/Audio Devices). I also chose to keep the bit rate at 24bit integer. Your results may vary depending on your device topology.

     

    Cheers!

  • xiiibc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 2, 2011 9:02 PM (in response to krusdublin)

    yeah, i had the hdmi working, but it was awfull. had center ch being sent to lr. i looked it up and it was a knnow error. so i tried to fix, now i have no sound. lol. i am bi curious as i have a windows 7 asus laptop before this mac.

  • toffimeister Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 8, 2011 1:57 PM (in response to krusdublin)

    Hi,

     

    I had the same problem with my mac-min and Lion. As soon as I plug-in a cable in the headphone jack, you can't switch to HDMI output, even though it is available under sound settings. It looks like it is selected for a few ms after you click on it and it switches back to headphones port immidiately. But applications which offer to select audio output work fine selecting either (like Airfoil speakers), but of course a lot of applications always use system output.

     

    The workaround I use is "soundflower", a free open source project. There is even a version now available for Lion (see here: http://kineme.net/forum/General/soundflowerforlion). This basically installs a virtual audio device which lets you route your audio to any real audio device independently from Mac-OS settings. Now I can finally have the system output use HDMI (for local movie playback) and use the headphone jack for Airfoils Speakers to stream to my stereo unit

     

    Cheers,

     

    Toffimeister

  • robbbb1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 14, 2011 11:27 AM (in response to krusdublin)

    Toffmeister, your suggestion finally did the trick for me. Installed Soundflower. I have no clue how it works, I can't even seem to open the program. But it has installed the virtual audio device, which is now visible in the sound preferences pane, and in audio midi set-up. Whem I reboot I have to adjust the latter to make sure that HDMI format is one that my TV accepts, then I'm good to go.

     

    Mac Mini mid 2011, Toshiba LED TV. I had audio only from DVD player prior to this fix; now audio from all the rest (iTunes, Safari).

     

    Thanks!

  • Kara Kimmel Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 29, 2011 7:16 PM (in response to krusdublin)

    I bought the Rocketfish Mini Display Port to HDMI adaptor, plugged it in and immediately had video, but no audio.  I went to System Preferences - Display and changed the displays so that they were mirrored (small check box at the bottom left) such that whatever is displayed on my MacBook Pro is displayed on my Sony Bravia TV.

     

    I then went to the Sound preferences, clicked on Output, and highlighted "Sony TV" for output.  It will say "The selected device has no output controls", but sound will then play through your TV, you just need your TV remote to control the sound.  Sound will not play over both devices.  If you disconnect the HDMI adaptor, sound will return to the laptop, otherwise you'll need to select "Internal Speakers" again in order to play the sound over the laptop.

  • mattystrand Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 24, 2011 11:39 AM (in response to krusdublin)

    Hello All. This is your friend from Vancouver, Canada. The problem is Apple, not you. More specifically, this is a problem with the Lion OS. This is not a software issue nor a problem with your television. Go to an Apple Store and ask them to reinstall Snow Leopard on your Mac Mini. I just did that and voila, the problem is solved.

     

    Good luck.

  • lolfunkymonkey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 30, 2011 10:31 PM (in response to MAJM)

    I have the same problem. I own an ASUS VH238H 23" display, and when the HDMI is plugged in, I can control the sound through the display, but my sound control on the Apple bar is faint. I have noticed that apps such as iTunes or Chrome can control the sound, but its not the same as the system sound control.

  • mattystrand Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 30, 2011 11:47 PM (in response to mattystrand)

    Ok, disregard my first reply.....

     

    So, I went back to the Apple Store. They reinstalled Lion (after being told by the Genius staff that whomever recommended that Snow Leopard be installed so probably no longer work at Apple).

     

    One thing that might help is to only use one of the audio outputs on the Macmin. Apparently, one is analog and the other is digital. Unfortunately I can't remember which is which now....

     

    Anyways, I only use one audio output now and the system is working once again....

  • WesTea Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 18, 2011 10:27 PM (in response to Kara Kimmel)

    Kara (or anyone else who can answer this quesiton),

     

    I have the Rocketfish Mini Display Port to HDMI adapter and a Sony TV as well, but in the sound settings, only the Built-In Internal Speakers are available. I'm running a MacBook Pro with Mac OS X 1.6.8 ... got any ideas why mine isn't working the exact same way?

     

    Rocketfish's adapter packaging says it supports audio ...

  • zeron89 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 22, 2011 9:05 PM (in response to WesTea)

    Hi all I may have a fix (it worked for me at least) I did install soundflower but i don't think it installed so anyways, i went to the audio midi setup app in (applications/utilities/audio midi setup) and created a "aggregate device" hit the plus sign then clicked "hdmi and built in output" and changed the sample rate till i heard sound. Also make sure you right click on it and "use this device for sound input". Now i can control the sound with tv remote!! Hope this works for you guys (i just got my mini today..can't wait to make it my media center...previously using apple tv2 with xbmc)

     

    ss.jpg

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.