Skip navigation

Missing emails in Mail - Lion deleting them?

79736 Views 246 Replies Latest reply: Jul 25, 2013 10:10 PM by mattwong0502 RSS
1 2 3 ... 17 Previous Next
Adam McGechan Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 24, 2011 9:44 AM

I'm using Mail with two IMAP accounts (oneis gmail), and I'm experiencing a little weirdness.

 

I seem to be missing emails coming in, which I'm not deleting or filing away.

 

I got in late last night and checked my emails on my iPhone. I read one that needed to be replied to today, then closed Mail on my iPhone and went to bed.

 

This morning, I jumped on my Lion iMac and opened Mail - and the email I read on my iPhone doesn't appear in my inbox. I checked on my iPhone and iPad and it's not there either.

 

I didn't delete it or move it or do anything other than read it on my iPhone.

 

I asked on another forum, and one person said the following:

 

I am experiencing the same thing. I seem to be able to send email from the Lion's new Mail, but can't receive any.

 

I have several mail accounts in Mail and the problem seem to be the same with all of them regardless of whether on exchange server or not. The strange thing is that I can see and read some of the "invisible" incoming mail in my iPhone, but if I try to refresh my Mail accounts on mac, it may delete the new emails also from my iPhone! The disappearing emails are nowhere to be found and I have also checked the external exchange service mail boxes and junk mail and spam boxes.

 

Quite serious bug causing a lot of harm!

 

So it doesn't seem to be just me.

 

Anyone else?

 

Cheers.

MacBook Air, Mac OS X (10.7)
  • instantb Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 25, 2011 8:02 AM (in response to Adam McGechan)

    I'm having the exact same problem that you describe. In some cases incoming mail appears in the inbox for a few seconds, but then dissappears and I'm unable to find it anywhere.

  • BigDfromnew haven Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 25, 2011 3:17 PM (in response to Adam McGechan)

    And I have the same problem with mail disappearing. Sent mail has also disappeared. Checking my e-mail with a web interface, I see the missing e-mails on the server. Searching for them in Mail gives empty results. This after I had earlier read them in Mail.

  • scadmin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 25, 2011 4:33 PM (in response to Adam McGechan)

    I am experiencing this as well.  I have had several folders dissapear, then re-apear (sometimes), before just deleting the account and starting over by re-importing it.  This seems to work sometimes but only for a bit before it happens all over again.  Even the "new mail indicator number" on one of my inboxes is not displaying a number when there is several new mail waiting (of course this is happening for 1 account while the others still work).  One more little issue I have experienced is I will receive a new email which i can view the header clearly, however the message body is blank.  My iphone can see the entire message fine (I will admit this last bug I was experiencing in Snow Leopard as well).

     

    In short, there seems to be a bunch of little things messed up here, and I hope this gets resolved soon.  I am forced to use Outlook Web Access or my ipad/iphone to manage my email and it's killing me!

  • instantb Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2011 11:33 PM (in response to scadmin)

    Adam, do you use SpamSieve or other 3rd party spam filter? Have you checked you Spam folder for missing emails? I have and just found most missing emails, hoping an updated SpamSieve plugin fixes my problem. I'll let you know.

  • jennieltx Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2011 6:20 AM (in response to Adam McGechan)

    I am having the same issue.  Any ideas on how to fix this?

  • Ernie Stamper Level 8 Level 8 (37,455 points)
    Currently Being Moderated
    Jul 27, 2011 7:01 AM (in response to Adam McGechan)

    What type of account -- POP or IMAP?

     

    Ernie

  • jennieltx Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2011 11:49 AM (in response to Adam McGechan)

    For me, Google and Yahoo, as well as AOL (I believe). They all seem to be doing it, but I am 100 percent sure that Google and Yahoo are a problem.

  • mleedham Calculating status...
    Currently Being Moderated
    Aug 1, 2011 12:14 PM (in response to Adam McGechan)

    Same problem here. Have had to turn off mail on my mac and only use my iphone for e-mail. Otherwise I can hear e-mail arriving on my mac, (ding noise on a glass) both .me and pop3 accounts, but they tend to dissappear instantly, completely deleted, never to be found. Kind of horrified!!! Rang for support and was told to rebuild mail. This did nothing. Awaiting a call from apple support tuesday evening. Will update. You expect the odd glitch with a new OS but this is truly awful. I lost important emails today about stuff that matters. Embarrasing having to call people up and say did you e-mail me, can you send again, so I can turn off my computer and respond on my phone!!!

  • Lori B Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 3, 2011 6:33 AM (in response to Adam McGechan)

    Same problem here with IMAP, POP, .mac/me, and Google accounts. The problem comes and goes with no pattern that I have been able to track. Some emails can be viewed by opening them in a new window instead of viewing them in the preview pane.

     

    Message was edited by: Lori B. Added info about new window vs. preview pane.

  • perrygovier Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2011 8:16 AM (in response to Adam McGechan)

    Ditto,

     

    I have an Exchange, 5 IMAP, and a POP account.  I only have the exchange and an IMAP set up on my phone and iPad, so I only know that those are acting odd for sure.  Not really sure what the problem is.  The emails are showing up in searches.  I have a special "ding" for when my wife emails me and that sounds, but I can only see it if I search for it. The message, along with, most, others wont show up in my inbox...

     

    I'm a part of the developers beta for iCloud and have iOS 5 beta on my iPad but not my iPhone.  Not sure if that has anything to do with it, but I figured I should mention.

     

    I really have no idea where to start to fix this bug.  Maybe adding and removing the account, but if it's a problem spanning multiple accounts, that doesn't seem likely and with the number of email I have, it'd require quite a while to sync up again.

  • mleedham Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2011 10:13 AM (in response to Adam McGechan)

    Hi,

    The fix that worked for me. Close all apps. Create a new file on your desktop. Then finder, go Press & hold alt and library appears, then go down to mail. Move mail and find com.apple.mail.plist and move both to the empty folder. This empties your email accounts from mail into the file for safe keeping incase the fix does not work. Then reopen mail which will be a blank new mail and go to preferences and maunually re-enter each e-mail account by adding new accounts. Doing this has worked on both my mobile me & pop 3 e-mail addresses. All is working fine again. The file on your desktop containing your old settings can be kept until you are certain all is good again, before deleting. Think I will wait a few days!

  • Bradley Miller Calculating status...
    Currently Being Moderated
    Aug 10, 2011 9:23 AM (in response to Adam McGechan)

    In Lion, my emails are showing up in the column on the left side of the screen, but when I select them to see the preview… they appear blank.  Opening those same emails on my iPhone works just fine.

     

    I am going to try mleedham's fix to re-create my email accounts.  I'll let you all know how it works out for me.

  • Bradley Miller Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 10, 2011 10:11 PM (in response to Bradley Miller)

    I looks like that took care of it for me!

  • scadmin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 15, 2011 5:02 PM (in response to mleedham)

    Can you elaborate on where to find these files and how to move them?  I am having troubles following your intructions to rebuild themail database.  Thanks.

1 2 3 ... 17 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.