1 2 3 4 Previous Next 48 Replies Latest reply: Jul 1, 2014 3:34 AM by mayorova
alex_from_adelaide Level 1 Level 1 (0 points)

I've installed Mac OS X Lion on my MacBook (white, late 2007) and lost my wi-fi connection. It worked fine with Mac OS X 10.6.8 but after upgrading to the Lion I get "Wi-Fi: No hardware installed" sign in the upper right corner of the screen. I reset PRAM but no avail.

Any suggestions?


MacBook, Mac OS X (10.7)
  • 1. Re: wi-fi: no hardware installed
    alex_from_adelaide Level 1 Level 1 (0 points)

    Solved.

    Reset SMC by:

    1. Turn off the comp;

    2. Disconnect the Mag Safe;

    3. Remove the battery;

    4. Press and hold the power button for 5 sec;

    5. Recconect the battery and turn on the comp.

     

    http://support.apple.com/kb/ht3964

  • 2. Re: wi-fi: no hardware installed
    ZeekTX Level 1 Level 1 (0 points)

    This procedure doesn't fix the problem in my MacBook "WI-FI: no hardware installed" and to make matters worst, wi-fi connection is dropping frequently. I don't recall having this issue with Snow Leopard

  • 3. Re: wi-fi: no hardware installed
    voikya Level 1 Level 1 (0 points)

    I'm having this problem too (on a mid-2009 15" Macbook Pro). The wifi in my menubar used to work fine, but all of the sudden it stopped and now just reads "Wi-fi: No hardware installed". I tried the PRAM reset, the SMC reset, and various other suggestions I've seen, but nothing seems to work. I can't get wi-fi at all now.

  • 4. Re: wi-fi: no hardware installed
    iTommyy Level 1 Level 1 (0 points)

    Me too..I have used to developer versions of Lion since 1,2,3,4 and GM. But first in the gold master version, I got some problems. The same day as the Lion officially launched, I got problems with my Wifi. First I had problems with the connection to the Wifi on my Macbook Pro 13 Mid '10. First I did restarted my Mac twice. After that I got the "no hardware installed", like many others here. So I upgraded the Mac to the Lion Retail version. But it did not work. After a few days I decided to take a "clean install" of "Snow Leopard. But I did not get Wifi to work in either Lion or Snow Leopard with Clean Install. I have also done the PRAM and SMC, but no help. I also try to delete the "System Configuration" folder..

    Is there any point to hope that Apple comes out with a fix for this problem. Can I be the only one who has the problem even after a clean install of Snow Leopard? Do you think this a software or a hardware problem? I can't understand how a software update; 10.7.1 could fix my problem, when my mac doesn't either work in Snow Leopard longer..

  • 5. Re: wi-fi: no hardware installed
    James In Savannah Level 1 Level 1 (0 points)

    I have had this same issue on my MacBook 2GHz Intel Core 2 Duo 4 GB SDRAM, even after today's update to Mac OS X version 10.7.1.

    I followed the directions of removing the battery and holding the power button for 5 seconds and restarting only to still have the "Wi-Fi: No hardware installed"

     

    The fix that worked for me.  I went into System Preferences>Network and unchecked the "Show Wi-Fi Status Bar in Menu Bar", Shut down the MacBook, removed battery, held the power button for 5 seconds, replaced battery and rebooted.  Then I went back to System Preferences>Network and checked box "Show Wi-Fi Status Bar in Menu Bar" and now it works like before. 

     

    Still one bug found - After unchecking and rechecking - It stopped working and reverted back to "Wi-Fi: No hardware installed".  Ugh. 

  • 6. Re: wi-fi: no hardware installed
    Justin He Level 1 Level 1 (0 points)

    Hey, guys. I got this problem this morning. It works fine last night but when I turned up mac this morning the "no hardware installed" showed up without any reason. I think it's becoz Lion is not very well developed.  As I installed Ubuntun 11.04, I switched to it and try if the wireless works or not.  Turned out it's working in Ubuntu.   Bang! Here is how **** happens:  I switched back to Lion again.    Tada....  Wireless works fine again!!.... I don't know why. The card sleeps for a while??  The ubuntu slash this **** card and make it wake up?   Damit Apple. Lion seems got a little bit to develop in next version.   Anyway, maybe you can try boot another system and switch to Lion to see if it works.

  • 7. Re: wi-fi: no hardware installed
    ramgarge Level 1 Level 1 (0 points)

    I have similar probem. restarting 2-3 times brings back the Wi-Fi. Does it happening same at your side? I am looking for a solution.. if not I will have to downgrade to SL. Looks like upgrade to 10.7.1 caused the issue. Before upgrade everything was working file with SL and Lion.

  • 8. Re: wi-fi: no hardware installed
    JustinPuddle Level 1 Level 1 (0 points)

    I have been having the exact same issue. I just upgradded the RAM in my 2008 MBP 15" (2.2 Duo) and all of the sudden I got a Wi-Fi: No Hardward Installed in the menu bar. I installed OSX Lion weeks ago and have not had any issues. Trying replacing the old RAM and no change. Tried resetting PRAM as suggested, as well as battery and holding power button for 5 seconds. No changes.

  • 9. Re: wi-fi: no hardware installed
    jonnyfive01 Level 1 Level 1 (0 points)

    I have an iMac and I have the same issues! I have fixed this issue with a restart. I spent the extra money on a Mac because I was tired of having to do this kind of stuff with a PC. I wish I wouldn't have spent 30 bucks on this upgrade Snow Leapord was a lot better.

  • 10. Re: wi-fi: no hardware installed
    GLeidenfrost Level 1 Level 1 (0 points)

    Had the same issue. The following worked for me:  Go into System> Network.  Uncheck the Show Wi-fi in menu bar and then turn off the wi-fi.  Now check the show wi-fi in menu bar and finally turn on wifi.  Hope it works for you.  I did this after an SMC reset did not restore the wi-fi icon status for me.

  • 11. Re: wi-fi: no hardware installed
    Matteo P. Level 1 Level 1 (0 points)

    iMac..... Same problem, I was playing wow then after two connections losts, my Mac with lion installed asks me to restart,,,,, then this problem... I'm without Internet and I'm ****** off considering that I might bring this huge fkg monitor at the assistance... Lion is a very bad software.... Lion is no good. Hate u apple.

  • 12. Re: wi-fi: no hardware installed
    edsfsanches Level 1 Level 1 (0 points)

    hi

    i am relieved to see that i´m not the only having this problem... i did exactely the same, install SL, uninstall...i tryed out every solution saw in this comunity..nothing worked...some times the wifi icon apears, sometimes not. sometimes it apears with full range of signal but after few seconds desapairs. in the menu prefencences the wifi option doesn´t apear even when i am trying to create a new one...something like this:Captura de Tela 2011-11-18 às 08.17.59.png.

    i hope this can be fixed ASAP.

  • 13. Re: wi-fi: no hardware installed
    CB_22 Level 1 Level 1 (0 points)

    does not solve the problem on my 10.7.2 MBP  !

  • 14. Re: wi-fi: no hardware installed
    madhuv2222 Level 1 Level 1 (0 points)

    The same problem with my MacBook Pro 5,5.

     

    Is there a Fix for this..

1 2 3 4 Previous Next