6 Replies Latest reply: Aug 19, 2011 5:27 AM by Bupsy
twi252 Level 1 Level 1 (0 points)

Hi all,

 

Upgraded to Lion from a retail build of Snow-Leopard, upgrade went fine, but noticed i can connect SMB fine to my Win7 shares, but when doing a "mount" command on the MBP side, all mounted shares are read-only !

 

Permissions for this user are correct (it worked great in Snow-Leopard) with no changes to the Windows side.

 

Also i am giving credentials when i mount the share.

 

I realize Apple have written their own SMB stack since they cant distribute Samba anymore, but surely it can mount shares read-write, or is the implementation not ready for prime-time and mounts read-only for now until Apple correct the issue?

 

 

Thanks.


MacBook Pro, Mac OS X (10.7)
  • 1. Re: smb shares read only
    Steve Holton Level 4 Level 4 (1,025 points)

    It is definitely a problem.

    In my case a Win XP system.

    Lion -> Win XP no problem

    Win Xp -> Lion mount Read/Only

     

    Boot Lion machine with 10.6.8 - no Problem mounts R/W.

     

    Some have reportedproblems involving home directories, but in this case it a separate volume not the Lion or 10.6.8 volume.

     

    I have reported it to Apple.

     

    Steve

  • 2. Re: smb shares read only
    twi252 Level 1 Level 1 (0 points)

    Hi Steve,

     

    When you say Lion -> Win XP, do your shares mount read-only or read-write?

     

    I'm not trying to mount from Win 7 (or XP) -> Lion, more the other way around.

     

    I'm interested to know if others have it working in that direction (and mount as read/write)?

     

     

    Thanks.

  • 3. Re: smb shares read only
    Bupsy Level 1 Level 1 (0 points)

    I am experiencing somewhat of the same issue.

     

    When I try to open an excel document located on my lion server from a windows machine I get an error saying "File cannot be accessed. The file may be read-only, or you may ben trying to access a read-only location". I can however create folders and copy over documents no problem. This makes absolutely no sense to me.

  • 4. Re: smb shares read only
    Ampherion Level 1 Level 1 (0 points)

    You described my situation as well.

     

    I have a Windows XP computer -> Lion SMB share that mounts correctly but has "challenges"

    - Files and folders can be created but error messages are displayed on the Windows side. Refresh the window and they are there.

    - Files and folders can't be renamed or deleted

     

    A Snow Leopard Mac on the same network -> Lion SMB share works great

     

    Prior to upgrading to Lion the same shares on Snow Leopard worked flawlessly.

  • 5. Re: smb shares read only
    rickblackdog Level 1 Level 1 (5 points)

    I'm having the same issue with office documents on Lion 10.7 shares.  Files appear to be read only, folders appear to have read/write access.  Anyone got a solution?

  • 6. Re: smb shares read only
    Bupsy Level 1 Level 1 (0 points)

    I was experiencing the same issue when using office 2003. What worked for me was to upgrade to office 2010. Not much of a cheap solution, but it did solve the problem.