Skip navigation

Aperture crashes when expanding keyword menu tree item

707 Views 12 Replies Latest reply: Feb 3, 2012 1:19 PM by muppix RSS
ringhome Calculating status...
Currently Being Moderated
Aug 19, 2011 7:16 AM

I have a nested tree in the Keyword menu, call it "focus". When I expand it by clicking on the triangle to the left, Aperture 3 dies. However if I click "add sub-menu" with that same item selected (not clicking the triangle, just the text), it will expand the list and add a modifiable placeholder; the placeholder can be deleted, effectively expanding my list! It's a workaround, but it seems wrong to do it this way. I've repaired permissions and rebuilt the database, per another article in an Apple article.


Ideas, anyone?



If this helps, here's a snippet from the crash report:

Process:         Aperture [1218]

Path:            /Applications/Aperture/


Version:         3.1 (3.1)

Build Info:      Aperture-1290000~2

Code Type:       X86-64 (Native)

Parent Process:  launchd [178]


Date/Time:       2011-08-19 06:56:44.298 -0700

OS Version:      Mac OS X 10.7.1 (11B26)

Report Version:  9


Interval Since Last Report:          17995 sec

Crashes Since Last Report:           12

Per-App Interval Since Last Report:  3674 sec

Per-App Crashes Since Last Report:   12

Anonymous UUID:                      BAB87AEA-5161-4E78-818A-F7E8406B8378


Crashed Thread:  0  Dispatch queue:


Exception Codes: 0x000000000000000d, 0x0000000000000000

VM Regions Near 0:

    __TEXT               0000000100000000-0000000100ad9000 [ 10.8M] r-x/rwx SM=COW  /Applications/Aperture/


Application Specific Information:

objc_msgSend() selector name: unsignedIntegerValue

objc[1218]: garbage collection is OFF


Thread 0 Crashed:: Dispatch queue:

0   libobjc.A.dylib                         0x00007fff95291e90 objc_msgSend + 16

1                      0x0000000100583642 0x100000000 + 5781058

2                        0x00007fff9413e9e1 -[NSWrapperCellView drawRect:] + 557

3                        0x00007fff939fe768 -[NSView _drawRect:clip:] + 3758

4                        0x00007fff93a2c131 -[NSView _recursiveDisplayAllDirtyWithLockFocus:visRect:] + 1583

iMac 27, Mac OS X (10.6.6), 16GB RAM
  • Frank Caggiano Level 7 Level 7 (22,755 points)

    You're right you shouldn't have to work around this and nothing you do in the program should cause it to crash.


    Take a look at the Aperture 3: Troubleshooting Basics there are a few other things you can try besides what you've already done. Specifically I try moving the preferences's file out to see if that makes a difference.


    Also I'd try creating a new empty library, import a few images and try what crashes Aperture in that library. Finally you can try making a new user and running Aperture as that user to se if it makes a difference.


    Report your results, good luck

  • Kirby Krieger Level 6 Level 6 (11,550 points)

    This is in the Keywords HUD?


    Voodoo, fwiw:  Create a new Keyword, we'll call it "Focus Two".  Expand "Focus" by way of your work-around.  Select all the sub-items of "Focus".  Drag and drop them onto "Focus Two".  Delete "Focus".  Does the disclosure triange for "Focus Two" work?  If so, close Aperture, re-open, and try again.


    If not, you might drag Keywords one at time until you find the Keyword (or the number of Keywords) that trips the system.


    Agreeing with Frank, this is abnormal and improper.

  • Kirby Krieger Level 6 Level 6 (11,550 points)

    Glad you got it sorted -- and very helpful to know what actually worked.  Thanks for posting your results. 

  • Kirby Krieger Level 6 Level 6 (11,550 points)

    Thanks for the update.  Best wishes -- I hope you don't find the same problem in the new Library.


    I, too, have always resisted the brute-force approach -- as though my computer "feels" work in some way similar to me.  This projection is all too human, and of course silly.


    At the end of last week I relocated a very large Masters set (~500 GB, many of them small files) to a new drive.  I thought this would take my computer about 24 hr. to finish.  It took about 54.  No problems at all.  (Fwiw, I'm now convinced that it is faster to copy very large Masters sets via Finder and then use "Locate Referenced Files" than it is to "Relocate Masters".  Not a surprise.)

  • Frank Caggiano Level 7 Level 7 (22,755 points)

    Glad to see you finally fonud a solution for your problem.


    One question I have concerns  your statement

    I think my problem was related to either the defrag


    What defrag operation were you doig that  may have lead to your problem?


    Just curious, regards

    iMac Intel 3.06 GHz 8GB Mem; Macbook5.1 2.4ghz 4GB Mem, Mac OS X (10.6.8), Aperture 3.1.3
  • muppix Calculating status...

    I'm probbaly a little late to this thread, but let me add my experience anyway in case it helps somebody.


    Background: just downloaded and installed Aperture 3 trial on a fairly new & clean MacBook Air. I hope to evaluate Aperture as a replacement to ACDSee Pro 3, which I've used to organise and edit roughly 180k images spanning 15 years. Changing my main workflow tool with a library that size is a bit daunting to say the least ...


    The first thing I did was to import a folder of 2.5k images from Kenya into Aperture to mess around with. I noted that the list of standard keywords that Aperture trial ships with was now joined by 'Safari', which had over 400 images associated with it. I'd assigned this keyword liberally in ACDSee and embedded it in the JPG metadata along with many other keywords, but these weren't showing up in Aperture.


    On trying to expand the standard list of keywords Aperture crashed, leading me to this forum post and the workaround of adding a temporay keyword to get the lists to expand. In this way I was able to junk some the standard keywords. I renamed 'Safar' to 'Kenya Safari', and after that I was able to expand and contract the other lists too.


    My guess is that Aperture wasn't able to parse some character(s) it found in the JPG metadata when importing my images, resulting in only 'Safari' being registered in the keywords list. Whatever else was imported interfered with the expansion of the list, and renaming the keyword stripped out the offending character, causing the list to function again.


    I know this is a long shot but I can sort of see it working. If you're still having issues with your keywords, maybe try renaming those that were created through import and not natively in Aperture?


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.