Skip navigation

iPad wont get IP address from DHCP Server

41077 Views 27 Replies Latest reply: Apr 15, 2014 10:38 PM by Reid1801 RSS Branched to a new discussion.
  • dehartjw Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 7, 2011 5:09 AM (in response to Steven Rix)
    Had similar issue on IPAD 2 using latest 4.3.1 iOS

    We use profiles to push out our "authorized" WiFi Settings and the same issue was happening were we would connect, but then no IP was aquired (standard 169 address was issued instead)

    After much head banging found that even though SSID was predefined and accurate
    "fogetting" the connection was not an option because this was applied using a "profile" removing and readding the profile gave no solution. However, after clicking on OTHER and then re-define the setting (the same that was already defined by the profile) it started to work.

    After it worked we reset all network connections ( General/Reset/Reset Network Connections) after the IPAD restarted, our Profiles were still there and everything worked as it should.

    Hopefully this will be helpful to the next person. DON'T Go buy a new ROUTER because of this issue. If you know your router works then the IPAD should too (as long as you using standard stuff that is...)
    IPAD 2, iOS 4
  • marcor_technologies Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 31, 2011 12:41 PM (in response to dpjax)

    We ran into a similar issue with various iPad and iPhones as well.  It turns out there was a problem with the AP that we were connecting to at that time.  When we moved to another AP, it pulled a DHCP address on all of the devices that failed previously.

     

    We are still troubleshooting the AP to determine what the root cause is.  The strange thing is we could connect to the AP with several laptops, an Android phone, and even 2 of the iPads.  Not sure yet on whats different on the iPads.

  • gdekens Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 25, 2011 10:39 AM (in response to dpjax)

    My iPAD2 hung yesterday, I powered it down, did power it backup and everything seemed OK except that I discovered later that I could not access the Internet. I restored it to no avail, It seemed to connect to the WIFI but did not get an IP address (DHCP) I searched everywhere finally did find the ridiculous advice to change the brightness of the screen! In my desperation I was willing to give the most unlikely a try and… it actually worked! My iPAD2 got its IP address and the problem is solved,

  • Vossi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 19, 2011 1:11 AM (in response to dpjax)

    i have had the same issue ( Ipad 2 / Cisco Access Point 1130 / MS 2008 as Raduis / EAP Authentication with self created Certificate / Username / Password authentication MS-CHAP )

     

    I my case ( Authentication was successful reported on the IAS Server ) but did not receive the IP from the DHCP Server, the solutuion was to switch from TKIP to AES-CCMP on the Access Point. After that switch reboot the IPAD an voila we are in !!!

     

    Hope this helps somebody !

  • humorzo Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 19, 2011 8:42 PM (in response to Lee Chalmers)

    Did you all ever find a solution? An IP address starting with 169. means an invalid connection--that address will never connect to anything. I hope you reset your network, in the Settings App - and did a hard Restart.

  • mpsan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2011 10:51 AM (in response to gdekens)

    It sounds ridiculous, but that did it for me too. After fiddling with many options, the only way to get wifi seemed to be to disable DHCP and use static ip addressing. DHCP would always choose a 169 address (no Internet). But after changing the brightness, going back to the DHCP settings revealed a new ip address and Internet came back!

  • gswane Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 18, 2011 12:20 AM (in response to mpsan)

    I'm so glad I found this thread it's saved me hours of fiddling about.  I picked up my ipad2 this morning to find that overnight it too had assigned itself a 169 IP address, after 4 months of working flawlessly.  I've had the same problem with a Macbook that will only ever connect with a static ip address now, despite initially working properly, so there is obviously something in OSX that causes this to happen. 

     

    Thinking I was going to have to spend the morning fiddling around trying to find the correct solution for the ipad (and cursing Apple and all its works) I decided to try the easiest thing first and set wireless to off, switched screen brightness from auto to off, switched brightness back on and moved the brightness bar a fraction, switched wireless back on and........

     

    voila! 

     

    What a bizarre solution, but I hope it continues to work if it happens again!!

  • dustinfromvancouver Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 31, 2011 1:58 PM (in response to dpjax)

    I had this same problem. My wifi network would show up on my iPad but when I touched the blue dot next to the network I could see it wasn't detecting an IP address. The solution I finally found (which I've seen mentioned nowhere) was to go to my routers settings online and under MAC Address Control I added my iPads Wi-Fi address (found under General > About on your iPad).

     

    I was amazed that I could not find this solution anywhere. As soon as I did this the iPad immediately connected.

     

    Hope this helps!

  • Roufey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 13, 2012 10:18 PM (in response to dpjax)

    Hey Gyzzzz!!!
    It can be simple problem...
    I was also goin through this and searched a **** lot from 4 days for solution BUT

    got it all fine when i entered the correct password for the chosen wifi network..so... make sure that
    password you are entering is 100% correct..

     

    even wrong password would make it show connected but it takes the wrong ip address...

     

    Gud Luck

  • Rogwhale Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 17, 2012 12:52 AM (in response to dpjax)

    We are in the lucky position of having 2 iPads and 2 routers so this morning when my wife's iPad wouldn't connect I could test it on two routers neither of which would connect. No problem connecting my iPad though. Hers was shown as connected but whenever you tried to surf the net it said not connected. I then checked the ip settings on both iPads and found that hers had very different settings for both ip subnet router etc. I changed it to static ip using a number not available to dhcp (to avoid conflicts) and voila no problems. Hope this helps.

  • Greatreality Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 21, 2012 6:44 PM (in response to dehartjw)

    DEHARTJW: I know it's a year since your post, but I just had the same issue with one of my iphones and and a few other devices to connect properly to my router. AFTER READING 101 POST and finding absolutely no possible solution, I came to the conclusion that my router must be the problem. So I signed into my router and toured around for a few hours and found the the DHCP range that was allocated was 192.168.2.3 to 192.168.2.99.

    You would think this wouldn't affect a device from connecting, but I further switched the range from 192.168.1.3 to 192.168.1.99 and all my devices started connecting immediately with thw WPA2 security.I know this may or may not be helpful but to me, it was like finding the holy grail!!

     

    Good luck!!

  • Reid1801 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2013 7:00 PM (in response to dpjax)

    I'm glad to see I have got your attention on the 169 problem, Apple--but deleting my post is not the right answer.  You need to provide a solution to your customers which actually works (and which is written in terms which a person without a computer science degree can understand).  Until you do, I will continue to advise people not to buy an iPad.

  • Reid1801 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2014 10:38 PM (in response to dpjax)

    After making the post above, my iPad began to work again for no discernible reason until April 2014.  It failed again, and nothing seemed to cure the problem.  As a last resort, I upgraded my imac from Snow Leopard (10.6.8) to Mavericks (10.9.2).  This allowed me to upgrade to a WPA2 password on the iMac's wifi (Snow Leopard only used insecure WEP passwords).  My iPad then asked me for the new password, and the wifi began to work. 

     

    So in this case the 169 problem seemed to be caused by the wifi's old WEP security system (and yes, I was using the correct password).

     

    I'm glad my iPad is now working again.  I'm not glad that I had to waste three days of my time to get it working.

     

    For the record, you can set a WPA2 password on your iMac (if you have upgraded to Mavericks) by going to System Preferences > Sharing.  Untick 'internet sharing'; highlight wifi and click on wi-fi options.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.