7 Replies Latest reply: May 2, 2012 12:48 PM by Mathilde C.
ysfgary Level 1 Level 1 (0 points)

I'm using Lightroom 3 and my shortcut key to show/hide right panel is conflicting with Lion F8 which brings up Mission Control. I have search in the keyboard preferences and couldn't find the F8 assignment. Both F8 and F9 does the same thing, anyone know how to remove F8 from calling up Mission Control?


MacBook Pro, Mac OS X (10.7)
  • 1. Re: How do I remove F8 Mission control in Lion?
    Roger Barre Level 2 Level 2 (225 points)

    This appears to be a holdover from Snow Leopard, and there are two ways to fix it:

     

    1) Delete com.apple.symbolichotkeys.plist (in Library/Preferences), but this will also delete other custom hot keys you've created.

     

    2) Apparently, you can edit your com.apple.symbolichotkeys.plist with any basic text editor. First back it up ... then, search for "75".  Keys 75 and 76 are the ones for F8 activating Mission Control. Delete those two entries and they'll no longer activate Mission Control.  (Note: F9 will still work for Mission Control.)

     

    Hope this helps.

  • 2. Re: How do I remove F8 Mission control in Lion?
    ysfgary Level 1 Level 1 (0 points)

    HI Roger, thanks for your reply. I have searched through my mac and could not find com.apple.symbolichotkeys.plist in Library/Preferences

  • 3. Re: How do I remove F8 Mission control in Lion?
    Roger Barre Level 2 Level 2 (225 points)

    It's in your User Library.  It's a little tricky to get to in Lion, as they hide it, but here's how to access it:

     

    In the Finer, Select the Go menu, and then hit the Option key.  "Library" will appear as choice, and it's your User Library, not System Library.  Select it, and then drill down to Preferences to find the symbolichotkeys.plist.

     

    Hope this helps.

  • 4. Re: How do I remove F8 Mission control in Lion?
    ysfgary Level 1 Level 1 (0 points)

    Hi Roger, you have been a great help, I managed to solve this with your guide .. many many thanks!

     

    For those who encounters the same, here are the steps which I followed to solve this F8 mission control issue: -

     

    Step 1 : Finder, select Go and hit Option key. "Library" will appear. Select "Library" (while holding down Option key)

    Step 2: Look for symbolichotkeys.plist. Edit this with text editor.

    Step 3: Find for "75", delete it. Find for "76", delete it.

    Step 4: Restart Mac

    Step 5: Go to System Preferences-keyboard-keyboard shortcuts to reassign those shortcut keys which appears as a conflict.

    Step 6: Go to System Preferences-keyboard-keyboard shortcuts-mission control to re-activate those shortcuts for mission control.

    Step 7: Go to System Preferences-Mission Control and reassign the following:

    Mission Control = F9

    Application Windows = F10

    Show Desktop = F11

    Show Dashboard = F12

     

    Thanks again Roger for your help.

     

    with rgds, Gary.

  • 5. Re: How do I remove F8 Mission control in Lion?
    Diginin Level 1 Level 1 (0 points)

    I did

     

     

    ... edit your com.apple.symbolichotkeys.plist with any basic text editor. First back it up ... then, search for "75".  Keys 75 and 76 are the ones for F8 activating Mission Control. Delete those two entries and they'll no longer activate Mission Control.  (Note: F9 will still work for Mission Control.)

    ....

     

    Reset defaults for Mission Control in System Preferences-keyboard-keyboard shortcuts-mission control

     

    and logged out and in.

     

    Maybe the last two steps were enough, but the world may never know

  • 6. Re: How do I remove F8 Mission control in Lion?
    Conga Level 1 Level 1 (0 points)

    Hi, Thanks for solving this problem.

     

    I opened that preference file (com.apple.symbolichotkeys.plist) with PREF SETTER, a properties editor .

     

    Then I clicked in the main window on the triangle «AppleSymbolicHotKeys» to see all the key-numbers.

    Scrol to «75 and 76».

    Open both keys by triangle clicking, and click on the word «true» next to "BOOLEAN".

    SAVE, QUIT and RESTART

     

    Link to PREF SETTER, free download

    http://www.nightproductions.net/prefsetter.html

  • 7. Re: How do I remove F8 Mission control in Lion?
    Mathilde C. Level 1 Level 1 (0 points)

    Hey, I have a question,

     

    I've got the same problem, but only with the F3 key instead of the F8 key.

    I found the symbolichotkeys.plist, what do I have to do next?

    There are two files, one named com.apple.symbolichotkeys.plist and the other com.apple.symbolichotkeys.plist.lockfile

    I am not that good at computers, and I am not English, so I hope I will understand what to do

     

    Thanks anyway!

     

    Mathilde