Skip navigation

Keyboard stops working in Snow Leopard when using Spaces

113365 Views 292 Replies Latest reply: May 7, 2013 6:42 AM by kwxr2000 RSS
  • Bruce Kelly Calculating status...

    Howdy all.  I hesitate to make any suggestion here, because we all know what seems like a solution today may not be a solution tomorrow.  Nevertheless, I've been stuck with this bug for months now, on 2 different machines.  Searching again tonight to see if anyone had a new solution, and finding none, it occurred to me to toggle the switch at the bottom of Spaces preferences, the one that says, "When switching to an application, switch to a space with open windows for the application."  So I turned this off, and at least for the last 30 minutes, the problem has disappeared.  In fact, I just turned this box on again, and the problem still seems to no longer be present.

     

    If this solution has been suggested by others, sorry if I'm resurrecting a dead idea.  But, at least for the moment, I'm enjoying the b-e-a-utiful site of watching the Spaces indicator disappear.

     

    I hope this might help anyone else plagued by this ailment.

  • pags101 Calculating status...

    I am not sure if this is 'off-topic' but I have an instance of the keyboard stopping working in Snow Leopard while using spaces but also with screen sharing enabled. For the record I screen share a mac mini in space 2 and operate a MacBook Pro from space 1. Sometimes when I go from space 2 to space 1 the keyboard stops working completely except for the 'apple-left' or 'apple-right' spaces shortcuts. Drove me mad until I found a quick easy workaround without having to 'kill' or force quit anything. I simply went to the screen sharing space (space 2), click anywhere in it and type anything (even just the spacebar etc.). When I return to Space 1 the keyboard starts to work again. Pain in the neck but avoids rebooting either machine.

     

    I am not sure of what the bug is but it appears you have to return to the last place the keyboard was working and type something to restart the keyboards operation. I hope Apple can find a cure as it is one totally annoying bug!

  • Bruce Kelly Level 1 Level 1 (5 points)

    Guys, I started a new thread because of something insightful that I've found, but it seems these older threads get much more attention.  I'm certain, after searching into this problem, that this hanging up of the keyboard and Spaces is something to do with mouse software.  Could someone, ANYONE who knows more about OS X PLEASE look into the following link and see if my explaination provides any insight?!

     

    https://discussions.apple.com/message/16147325#16147325

  • swanksalot Level 2 Level 2 (150 points)

    I've had this problem for a while, for me, the fix is to keep Activity Monitor open, and whenever the keyboard stops working, I mouse into Activity Monitor, quit Dock, and then the keyboard works again.

  • Bruce Kelly Level 1 Level 1 (5 points)

    With colleagues admitting they have this problem but don’t use alternative mouse software, let alone an external mouse, and looking like this problem still exists in Lion, I’m confident this problem is centered in the OS.  I’m very frustrated that Apple has not done a thing about this problem.  Nevertheless I’ve been a Mac user since 6th grade, and I have little to complain about.

     

    So as all great Mac users do, I found ways to make things work. (Please note that I'm still using Snow Leopard, as I have a few PowerPC apps I'm not yet ready to abandon)

     

    Here’s my solution(s):

    • Solution #1: Quitting the dock is clearly the simplest way.  However, having to constantly bounce back and forth between the Activity Monitor and whatever I was working on is frustrating.  Looking for alternatives, I found a suggestion to make an AppleScript that would restart the dock for me.  This was my first AppleScript ever, but it worked, and here’s what I did:
      • I opened the AppleScript Script Editor (located at /Applications/Utilities/AppleScript/Script Editor) and I typed (or you can paste) the line below in the edit window:

    quit application "Dock"
    When I saved it, I went to “save as” and I saved it as an application, and saved it in my

    download folder.

    • With my download folder in my dock, I went there whenever Spaces froze my keyboard.  This was satisfactory for awhile, but then I found another option.  Having recently discovered the joy and beauty of BTT (Better Text Tool), I went into the preferences therein and compiled a command.  When I tap 4 fingers on my trackpad, it launches this AppleScript, the dock restarts, and I get full control of my keyboard back.  So with a simple tap, I have control again.

     

    • Solution #2: My second option was to follow other’s advice and download Hyperspaces (thecocoabots.com/hyperspaces/).  The great thing about this is it allows for the changing of spaces using alternative commands.  For example, rather than control + left arrow to move to my next space, I could instruct control + option + command + left arrow.  Burdensome?  Perhaps. But once I had fixed this, I went back into BTT and update this instruction.  As such, with a swipe of my choice, I can now change Spaces with my trackpad again, and freezing is a problem of the past.

     

    Of note, if I were to use control + left arrow at this moment, Spaces still changes, and most likely the icon will remain on the screen, freezing my keyboard.  So clearly what I’ve just suggested does not qualify as a solution, rather a work around.  Yet it’s a work around that right now I am happy with.  And for all the headaches I’ve had with the Spaces freeze (imagine having it freeze up in the middle of class!) were it not for this problem, I may not have discovered BTT or Hyperspaces.

     

    I hope this helps some of you, if not all.

  • RedHavoc Level 3 Level 3 (770 points)

    Some really good tips here by Bruce and others... but yes, all work-arounds.

     

    Shocked to here this issue is persistant in Lion!

     

    I feel for the more inexperienced users out there who don't know better and just reboot each time it happens!

  • andreionut Calculating status...

    Just FYI, you can modify the keyboard shortcut for spaces from the Keyboard preference pane (Go to Keyboard Shortcuts and from th elist in the left select Mission Control) and choose whatever you want. I choose ⌥← and ⌥→.

  • swanksalot Level 2 Level 2 (150 points)

    I know I resorted to rebooting the first couple times this happened to me - only after maybe the third time did I systematically keep track of what was running when the keyboard stopped working, and took a lot of work to figure out my quickie fix. And to confirm: still happens in Lion.

  • westmoquette Calculating status...

    Well, Hyperspaces has solved it for me! I'm running the free restricted version and, with the same keyboard shortcuts (cmd-number key) to change desktop, the keyboard hasn't frozen once in 3 weeks of heavy useage. It's not a solution, but it's a very good workaround. Phew!

  • cklunar Level 1 Level 1 (5 points)

    I have been experiencing this issue on an early 2011 MacBook Pro 17. Eventually, I found that the problem only occurs when the MBP is running on battery power, never on main power.

     

    My workaround is to use activity monitor to quit the Dock process to release the keyboard, then use Cmd F9 (remapped from F9) to show all spaces and then choose the Space with the mouse.

     

    Can anyone running Lion, latest update, confirm my experience that the issue only occuring when running on battery? If so it would be well worth reporting this to Apple at this URL http://www.apple.com/feedback/. In fact it should be reported repeatedly! until they fix it.

     

    OS X 10.6.8

  • briandealwis Calculating status...

    I too have been experiencing this same problem and tried the various solutions and workarounds, but to no avail.  I recently replaced my optical drive with an SSD and did a fresh install, and my problems have disappeared.

     

    Brian.

  • lowm Level 1 Level 1 (0 points)

    I have been having this problem for a few months now on my MBP and I had hoped there would be a solution here, unfortunatley not!

     

    I do have a quicker workaround than those being posted here, there is no need to shutdown, force spaces to stop etc. All you have to do is put the computer to sleep (ctrl+eject). When you wake the computer the keyboard is back.

  • Debrecini Calculating status...

    Just wanted to add my name to one of the MANY having this same problem.

     

    I'll have to read through every post on this thread but I can report having this same issue on both my machines (Mac Pro + Macbook Pro Laptop). I can confirm that no other conflicting software was cuasing this issue for me (Becuase it happens to me on fresh install of Snow Leopard). In other words IT IS A BUG with spaces and I am SHOCKED to hear it still persists in Lion.

     

    Apple pull a finger out this is a major flaw in your OS! Get it sorted, this is disgraceful.

     

    I will certainly be making an email to Apple Support about this, and its about time I did as I've been putting up with this bug for too long. I can never remember this happening in Leopard but always in Snow Leapard, I have yet to upgrade to Lion.

     

    So here's to hoping we get a bugfix.... And soon, fingers crossed

  • cklunar Level 1 Level 1 (5 points)

    I upgraded to Mac OS X 10.7.3 Lion two weeks ago.

    I have not experienced the issue since upgrading.

    In Lion Spaces are replaced by Mission Control.

     

    There are NO reports of this issue in Lion 10.7.3, which was released in February.

    If anyone is still experiencing the issue in Lion 10.7.3 please post here!

     

    It is highly unlikely that Apple will issue any further updates to Snow Leopard except for security updates.

     

    In Snow Leopard quiting the Dock using Activity Monitor was the fastest way to get the keyboard back.

  • MacMaster Mark Calculating status...

    I, too, have noticed that this problem has disappeared with Lion 10.7.3 on both my machines. Good luck, Debrecini—I'd advise an upgrade to Lion.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.