Skip navigation

Lion WiFi Connection Problem

666642 Views 2,660 Replies Latest reply: Apr 17, 2014 2:11 PM by ElJefeGrande RSS
  • lucciluccilucci Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2011 7:18 AM (in response to lrogersinlv)

    I have been on the phone with APPLE CARE this morning and they were very helpful and enabled me to fix my wifi issues.

     

    Before speaking with APPLE CARE I tried so many of the unusual little tricks on this board (and others) which seemed to be working uniquely for certain people. It turns out the problem in my case isn't LION as such, or my WiFi rather it's to do with the SECURITY on my ROUTER.

     

    I had an old MacBook at home which was very useful as I was easily able to make the adjusments on my Router through this to then later allow my new iMac (LION) to log on etc.

     

    I'm using a NETGEAR router, but the procedure will be much the same for other routers etc.

     

    What I did was sign in to my router (on my older MacBook in my case):

    http://192.168.0.1

     

    Put it my USERNAME and PASSWORD (which, by the way, is usually:

    USERNAME: admin

    PASSWORD: password

     

    Then selected WIRELESS SETTINGS.

     

    Within WIRELESS SETTINGS there is a subheading entitled WIRELESS SECURITY.

     

    Within WIRELESS SECURITY there are four options:

    1) Disable

    2) WEP (Wired Equivalent Privacy)

    3) WPA-PSK (Wi-Fi Protected Access Pre-Shared Key)

    4) WPA-802.1x

     

    I had

    2) WEP (Wired Equivalent Privacy)

     

    !! THIS WAS THE PROBLEM !!

     

    According to APPLE:

    WEP is being used less frequently as it appears to be not as SECURE as it's contemporaries (namely WPA etc). As a result LION struggles to communicate with the router using this security. BUT the good news is it CAN be easily changed!

     

    For a home setup Option 3:

    3) WPA-PSK (Wi-Fi Protected Access Pre-Shared Key)

    Seems to be the best option. Option 4 is a for a bigger setup (I wasn't listening too much, but apparently it's more suited to businesses using their own servers/networks etc?!).

     

    Next things we did was:

    SELECT OPTION 3:

    3) WPA-PSK (Wi-Fi Protected Access Pre-Shared Key)

     

    After selecting it asked me to enter a new password, so I did.

     

    Then I selected APPLY (or SAVE depending on your router). It took a minute to load...

     

    Then I went on to my new iMac (LION) clicked on

    SYSTEM PREF > NETWORK > ADVANCED and REMOVED (pressing the negative / '-' symbol) the network I've been struggling to get on for the last two days.

     

    Then ADDED (pressing the positive / '+' symbol) a 'new' network giving it the same title obviously as the one I had just deleted. It'll ask what SECURITY you want of the options, but just leave it as 'None' (as your WiFi will work it out itself). After this press ADD, then OK in the next window. Lastly press 'APPLY'.

     

    After this -  go up to your WiFi putton on your top bar, click it, then select the new network you've just created (which will of course have the same name as your old one) then when asked for a password put in your NEW ONE as you created on your ROUTER...

     

    ...Alas IT SHOULD WORK!

     

    It did for me, and the chap on the phone was so very useful and said this will be in the info they'll be putting on the discussion boards ASAP. I'm sorry if ym explanation has been a ittle convoluted as I'm not a techy person, but wanted to share this after sharing the struggle with so many.

     

    Good luck!

  • simon57 Calculating status...
    Currently Being Moderated
    Aug 22, 2011 7:48 AM (in response to lucciluccilucci)

    Now this looks like it could be the fix we have all been waiting for.  Like lucciluccilucci I have a Netgear router set to WEP security.  Altering it would presumably also mean altering the access from all other dependent computers on the network, but that's easy enough.

     

    I only have two remaining concerns:

     

    1 - It would be useful to know from lucciluccilucci that this fix is stable for both his main and any other computers on his network (may take a few days to know); and,

     

    2 - If it is this simple, why on Earth was this not foreseen by Apple?  Surely they must have known that a lot of people would still be using WEP and that Lion wouldn't like that?  The worry is that Apple must have known and would surely have covered that base, so is it really as simple as this?

     

    I'm still not ready to trust this fix.  I'll wait until either lucciluccilucci tells us all is fine after several days use or other people pile in saying it's been a success for them.  Sorry, but I no longer believe the It Just Works hype.

  • SaraSM Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2011 8:18 AM (in response to lucciluccilucci)

    I'm glad it worked for you. But, it's not that simple. I have two Apple Airport Extreme Base stations and I've been on WPA 2 for a long time.  I'm still having problems.

  • lucciluccilucci Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2011 10:07 AM (in response to lrogersinlv)

    Cool, well I keep you posted, so far so good.

     

    The chap from APPLE CARE on the phone said this has been the main problem  he's personally been having to advise the last few weeks, and that it tends to be down to the wireless security.

     

    However he did say there were several other problems with LION and WIFI (as we all know too well now unfortunately). E.g. SaraSM. Good luck people and I'll let you know if mine stays stable.

  • Nogueira Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2011 3:18 PM (in response to lrogersinlv)

    The solution is not to configure the router or any other apparatus that Apple claims will correct the problem. Supose you are in spot with a public networks, so everybody will ask the owner of the router to configure his network. That's insane. Listen folks !!! Listen Apple !!! The problem is with that piece of software named OS X Lion, that Apple claims to be the "The New King of the Desktop". King of what? The King of Erros !!! Listen folks !!! Apple must find a solution for its software and not we. Let's growl at the ears of Apple : We bought a software and we want it working, or at least that Apple is caring to find a solution.

  • bjgbjg Calculating status...
    Currently Being Moderated
    Aug 22, 2011 5:53 PM (in response to lrogersinlv)

    Just spoke to Apple and they solved my problem. I have a new MBA with Lion. I had no problem until I installed 10.7.1, then after waking from sleep, it would take a number of attempts to connect to the wireless network. I had tried resetting the PRAM and SMC before I finally called Apple.

     

    Apple's Wifi expert had me delete three preference files:

     

    com.apple.airport.preferences.plist

    NetworkInterfaces.plist

    preferences.plist

     

    from Macintosh HD/Library/Preferences/SystemConfiguration

     

    My problem seems to have gone away (at least for now)!

     

    Tech person explained that sometimes those pref files get corrupted, so after deleting they get re-created.

  • btwinguitarists Calculating status...
    Currently Being Moderated
    Aug 22, 2011 7:58 PM (in response to bjgbjg)

    I'll add to this mess.  My few weeks with this have been horrible.  Went back and forth between ATT and Apple, both claiming themselves as the problem.  Who knows.  I can connect fine to a friend's wifi, but mine suddenly drops connection like crazy.

     

    I've tried all steps listed in this forum.  Beginning with deleting pref files...and here recently changing more router settings.  The most recent attempt (changing router to wpk-psk) has MADE a difference...BUT has not completely fixed the issue.  My dsl/internet still drops, but for some reason it picks back up really fast.  So instead of me waiting for it to come back on, it's pretty much a 10 or so second gap, then it's back up.  Still Annoying.

     

    Apple walked me through every step in the book and concluded with LION has somehow caused my hardware to be messed up.  Obviously they used technical terms.  But their conclusion was that it was not software. I've even re-installed Lion, same issue.  After I asked if that was possible (because it sound software related to me...), they were pretty convinced it's my hardware even after I told them I connect fine to other wifi networks. 

     

    Conclusion:  I have to take it to apple repair center for troubleshooting and hardware replacement.  Probably the worst issue I've ever had with apple.  I'm not sure there is a fix for this yet.  I'm going to take it in, these guys know what they are doing.  They will troubleshoot and call me asap with the low down.  If there is absolutely the tiniest thing wrong with the comp hardware it will be fixed for free under apple prot.  I believe if it's software related, nada.  I'll post my findings soon.

  • nbooradley23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 25, 2011 9:11 PM (in response to btwinguitarists)

    What I would like to know is exactly what apple did to update their wifi connection issue in the latest 10.7.1 update.

     

    Apple being apple they just give you one line that they did something but not actually what they did..

     

    will have to rely on my insider sources to find that out... (sorry apple but yes you do have leakers)

     

    I still think this is a chipset compatibility issue but will now seek to find out exactly if anything what they did to address the wifi issue.

     

    < Edited By Host >

  • killhippie Level 3 Level 3 (580 points)
    Currently Being Moderated
    Aug 23, 2011 3:36 AM (in response to simon57)

    Its worth changing to WPA2 AES if you can, its much more secure than WEP, but I think at some point we will see an update that adresses this again. My imac takes a few seconds longer than usual to log into the network after sleep but its instant if you reboot...its not dropping the network during use though. Netgear router DGND3300 operating over 5Ghz.

  • marko152 Calculating status...
    Currently Being Moderated
    Aug 23, 2011 11:44 AM (in response to killhippie)

    I've been experiencing wifi dropouts typically more than once per hour (including the error message "Connection timeout occurred" when trying to reconnect) and sometimes exteremely slow connections. I have new MacBook Air and my router is Netgear WNR1000 (I use WPA2). My other laptop works without any problems. Update 10.7.1 actually made this problem worse in my case. This is quite an irritating problem, wish that a new fix will be available soon!

  • guyfromanytown Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2011 6:19 PM (in response to lrogersinlv)

    10.7.1 didn't fix my wifi issue either. Wake from sleep mode and it just says "Looking for Networks..." over and over again. Although it sees my network it doesn't automatically connect. I have to turn wifi off and then back on again and it connects instantly. I've reset SMC and PRAM/NVRAM. I'm running a WPA2 network and it's broadcasting my SSID. I've switched the router channel from Auto to Channel 10 and nothing has helped. I've gone into Preferences and deleted all the old networks, etc. and the problem persists.

  • whyamac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 24, 2011 3:22 AM (in response to guyfromanytown)

    What you describe is what Lion 10.7 was doing to my WiFi. !0.7.1 has fixed it but if I remember I pretty much started from scratch in setting up my network all over again with 10.7.1

     

    Try re-creating your network with password etc and see if that helps. I now have no issues with WiFi other than a short delay coming out of sleep. Don't forget if you choose a new password you're going to have to also change it in your router.

  • ecotop Calculating status...
    Currently Being Moderated
    Aug 24, 2011 5:40 AM (in response to whyamac)

    Well,

     

    I have "resolved" my issue. Not sure resolved is the correct word, but at least i am running with no issues for a day now. After messing around with the Time capsule settings, airport settings etc. It occurred to me that perhaps i simply should start with the basics.

    So, i disabled 5GHZ SSID which i was connected to and started testing with 2.4GHZ. That is all it took. I suddenly was no longer experiencing any hangs, any issues, no disconnects.

     

    Admittedly i have a better signal to noise ratio on 5GHZ, and much better speed, so now i get a fairly low transfer  rate ( 20Mbps sustained, vs 80-100 on 5GHz) but at least i am running and there are no issues.

     

    The 5GHZ SSID is working superb on snow leopard, so my only guess here is that the "wi-fi issues" in Lion may be related to real-time adjustments in terms of transmit rate, broadcast, SNR etc. in the 802.11A/N 5GHZ protocol.

     

    I am not able to comment any further on this, but i know this works for me now, and nothing else worked (i did read most of the 42 pages of this thread.

     

    PS i had recreated all my SSID's a after 10.7.1 was installed, and it hadnt changed anything either.

  • sk1982 Calculating status...
    Currently Being Moderated
    Aug 24, 2011 1:31 PM (in response to lrogersinlv)

    Fixed it on my MacBook Pro by uninstalling flash player. It had only recently started dropping the past few days for me, and co-incidently I've been doing a lot of flash speed tests the past few days as I was having speed issues with my ISP. Noticed the net drop out as described in this thread frequently when running the speed test, so uninstalled flash player and it's fine now. Very strange.

  • Cicignon Calculating status...
    Currently Being Moderated
    Aug 24, 2011 2:17 PM (in response to sk1982)

    (I originally posted this as a new thread, but this probably belongs more here)

     

    Like so many others after having installed Lion, I have been plagued by Safari freezes and slow-to-open internet pages, as well as what seemed like very frequent drop-outs in internet connectivity, especially after coming back from sleep mode.

     

    The machine (2011 MacBook Pro with 2,2 GHz i7 and 8 GB RAM) now seems to behave itself.  Here´s what I´ve done:

     

    Installed the latest patch to Lion (v. 10.7.1).

    Installed the latest version of Java (Java SE 6 Update 26).

    Installed the latest version of Flash player (v. 10.3.185.3).

    Disabled hardware accelleration in the Flash settings.

    Installed the ClickToFlash Safari-extension (v. 2.4.1).

    Made sure that the Time Capsule router had the latest firmware version (7.5.2).

    In network settings, for the Wifi-connection: added the following DNS-servers:

       208.67.220.220

       208.67.220.222

       8.8.8.8

    Also, in the network settings, enabled the automatic search for proxy and also disabled the passive proxy mode.

     

    None of this is new, as I have picked all this up from this forum and around the net.

     

    The machine has seemed stable so far today, with full internet speed / no drop-outs / no freezes so far (10-12 user hours so far with zero hiccups, vs. constant drop-outs or freezes before).

     

    I´m keeping my fingers crossed that it will last.

1 ... 40 41 42 43 44 ... 178 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (80)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.