Skip navigation

Windows 7 under bootcamp for MacOS X 10.6.6

8962 Views 9 Replies Latest reply: Jul 18, 2012 7:54 AM by JonT2 RSS
arb70sok Calculating status...
Currently Being Moderated
Feb 18, 2011 1:17 PM
Running under windows 7 I can not get a hash key. Have read various posts that say Ctrl-Alt-3 should do it and have even downloaded Windows Layout Creator 1.4 and loaded the Apple UK keyboard layout that says Ctrl-Alt-3 should work but it does not. I am using a MacBook Pro and neither the internal keyboard nor the full external USB mac keyboard (Apple UK) that I use give in a hash in Windows 7 under bootcamp. Under Mac OS option-3 works fine.

If anyone has figured out how to get the hash key working under Windows 7 (bootcamp) with an Apple-UK keyboard, please let me know.

MacBook Pro (15" 2.8G Intel Core 2 Duo), Mac OS X (10.5.8)
  • pessable Calculating status...
    Currently Being Moderated
    Aug 23, 2011 6:47 AM (in response to arb70sok)

    I've recently installed Windows 7 onto my 2011 MacBook Air.  The only thing that was a problem was the keyboard mapping for my UK keyboard.  A number of the punctuation keys were in the wrong place (e.g. the @ and the " were swapped).  I found this older post which I followed and that seems to have put all my keys in the correct places.


    Of course, I can't now find the # key because there isn't a hash key on the keyboard.  I guess I can use charmap in Windows 7 but that's clunky, but are there any other ways? 


    There's probably a way to amend the file from the post above so when I've got a few minutes spare I'll take a closer look at that too.

  • The hatter Level 9 Level 9 (58,560 points)
    Currently Being Moderated
    Aug 23, 2011 7:05 AM (in response to pessable)

    Keyboard mapping in Windows with Apple kb


  • pessable Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 24, 2011 2:34 AM (in response to The hatter)

    Unfortunately, the link refers to a MacBook Pro which does have a hash key, unlike my MacBook Air UK keyboard which doesn't.

  • bl_ndp_lot Calculating status...
    Currently Being Moderated
    Sep 5, 2011 3:58 AM (in response to arb70sok)

    i have struggled with this for ages - normally i work with an external full keyboard and alt+3+5 works


    on the laptop keyboard this does not work. i have read alt + 3 does it for mac, but in boot camp - no joy.


    I have just tried ALT + 3 using the RIGHT HAND ALT KEY!!! AND IT WORKS!!!!!!!!!!




    hope this helps someone else

  • frank hayes Calculating status...
    Currently Being Moderated
    Apr 10, 2012 8:51 AM (in response to arb70sok)

    Having just pulled my hair out taking advice from many pundits about how to get the hash key under bootcamp with an English Mac Keyboard selection I found that the advice from bl_ndp_lot worked perfectly; namely Ctrl+Alt+3 BUT USING Alt ON RIGHT SIDE OF THE KEYBOARD ONLY. Why the two Alt buttons appear to have different functions only Apple can explain. I was also surprised given the large number of internet queries concerning the missing hash that the Apple helpline (normally excellent) were not able to help, instead of passing it off as a 'Windows Problem' when clearly it is an issue with the Mac Bootcamp Keyboard Driver. I also think after many years of the 'Hash Problem' it is time for Apple to put a hash key on the keyboard (and whilst at it a DEL key would also be useful)

  • frank hayes Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 10, 2012 10:51 AM (in response to arb70sok)

    Apologies to my posting above. The correct sequence is simply Alt+3 using the right hand side Alt key.

  • Philbo80 Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 3, 2012 3:34 AM (in response to arb70sok)

    Thank you to those who have said right Alt key + 3, it works a treat!

  • JonT2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 18, 2012 7:54 AM (in response to Philbo80)

    This works because the Right alt key is actually functioning as a Ctrl-Alt combination key...

    which is NOT what I want.  Anyone know how to stop that?  I don't think it always was this way for me under BootCamp.  I installed a trial of Parallels recently, but I don't think the two are related.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.