Skip navigation

/Browse/ versus /BrowsePrivately/

1465 Views 15 Replies Latest reply: Sep 9, 2011 1:30 PM by XRayLarry RSS
1 2 Previous Next
XRayLarry Calculating status...
Currently Being Moderated
Jul 21, 2011 3:34 PM

[Formerly discussion https://discussions.apple.com/message/15646754 ]

 

We are one of the old iTunes U stores where Apple hosts our content. We had private content that was under credential access, and publically-accessible content. We moved our public content into the Public Site Manager, and soon after that the direct links to the private content stopped working. I've asked for help here in "Using iTunes U", without a solution. I've recently found a failure mode that I feel deserves a new discussion.

 

Here is a direct link to some of our private content:

 

https://deimos.apple.com/WebObjects/Core.woa/BrowsePrivately/deanza.edu.20336305 98

 

When used in a browser, deimos.apple.com sends back HTML with a body tag like this:

 

<body onload="return open('itmss://deimos.apple.com/WebObjects/Core.woa/Browse/deanza.edu.2033630598 ?ignore.mscache=5947157');">

 

... and then iTunes opens, but instead of calling my browser to show our login page, iTunes shows our public iTunes U storefront.

 

Putting this URI into the browser's address area gives the same behavior:

 

itmss://deimos.apple.com/WebObjects/Core.woa/Browse/deanza.edu.2033630598

 

but using this URI results in the correct behavior - the browser opens iTunes, which in turn correctly opens a browser window to our login page:

 

itmss://deimos.apple.com/WebObjects/Core.woa/BrowsePrivately/deanza.edu.20336305 98

 

Why is deimos.apple.com sending me an incorrect itmss URI with /Browse/ instead of /BrowsePrivately/ ?

  • richwolf Level 3 Level 3 (725 points)
    Currently Being Moderated
    Jul 26, 2011 4:23 PM (in response to XRayLarry)

    Larry,

     

    I think Duncan's got this about right.  I suspect the problem is that you may have granted the "All" and "Authenticated/Unauthenticated" credentials no access (i.e. "NONE") -and- there are no other permissions set for the iTunes U course/album involved.  I haven't tested it (but I will), but I'm almost positive what happens in such cases is that iTunes U redirects to the root page of your site as apposed to putting up a 403-style error. You are not redirected to your portal server because no purpose would be served by doing so -- there would be no credential(s) it could assign that would grant you access to the iTunes U resource.

     

    Can you do me/us a favor and post a picture of the permissions settings for the problem course if at all possible?

  • richwolf Level 3 Level 3 (725 points)
    Currently Being Moderated
    Jul 26, 2011 5:24 PM (in response to XRayLarry)

    The link you posted behaves the same way as the others for me (i.e., it redirects to your root page). It may be that you had an iTunes U session active already and it worked for you just now for that very reason. To test things "beyond a shadow of a doubt" you should log out of iTunes U first, then try the link. In fact, if I am right (and that the reason it worked was because you had an iTunes U session active when you clicked the link), then that's very very strong evidence that you have a permissions problem for the course/ablum involved. If this is the case, the most helpful diagnostic tool would be to see what permissions you've assigned for the course.

  • richwolf Level 3 Level 3 (725 points)
    Currently Being Moderated
    Jul 26, 2011 11:58 PM (in response to XRayLarry)

    Larry,

     

    Hmm…that looks okay to me. I confes I didn't look at it really closely tonight, but it looks okay just glancing over it. I'd like to explore it more deeply if you don't mind, but I can't tomorrow. Can this hold until Thursday?

  • AcadTech Calculating status...
    Currently Being Moderated
    Aug 22, 2011 11:28 AM (in response to XRayLarry)

    We're seeing the same issue. Using current iTunes software. The previous version still allows to "copy link" from a tab. It sure would be good to have a resolution.

  • Duncan Bernhardt Level 3 Level 3 (870 points)
    Currently Being Moderated
    Aug 22, 2011 11:31 AM (in response to XRayLarry)

    Larry-

     

    When linking to private courses/collections you should indeed use the "BrowsePrivately" url

     

    BUT - now whenI am logged into the private site as an admin, I can't do "Copy link". The option is grayed out.

     

    The work-around is drag copying the URL from the iTunes client

    DrapCopy.png

    -Thanks

  • Duncan Bernhardt Level 3 Level 3 (870 points)
    Currently Being Moderated
    Sep 9, 2011 12:37 PM (in response to XRayLarry)

    A click/drag of the title from the breadcrumb should allow you to grab the URL regardless of if you are logged in by Apple ID or not. Let us know if this is not the case for you and grab a screen shot if possible.

     

    -Thanks

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.