1 2 3 4 5 Previous Next 113 Replies Latest reply: Mar 17, 2014 8:16 PM by csunsweet Go to original post
  • 30. Re: My Mac don't go sleeping since Lion Update
    khenjin Level 1 Level 1 (0 points)

    I have a similar problem since updating to Lion:

     

    internet sharing is off, so is wake on lan and sleep mode for HDD is on.

     

    every time I put my mac pro to sleep it will do so for the first time. but when waking it up and then later on putting it back to sleep mode it will power down and then immediately start again.

     

    I have closed all programs and still it will do so.

     

    after having had a look into console it says there:

     

    02.08.11 08:24:58,000 kernel: hibernate_write_image done(e00002eb)

    02.08.11 08:24:58,000 kernel: sleep

    02.08.11 08:24:58,000 kernel: Wake reason: EHC1

    02.08.11 08:24:58,000 kernel: /drv/ MacModule.cpp:261   powerStateWillChangeTo: flags=82 stateNumber=3

    02.08.11 08:24:58,000 kernel: /drv/ MacModule.cpp:262   powerStateWillChangeTo: found flag=kIOPMPowerOn (2)

    02.08.11 08:24:58,000 kernel: /drv/ MacModule.cpp:267   powerStateWillChangeTo: found flag=kIOPMRestartCapability (80)

    02.08.11 08:24:58,000 kernel: /drv/ MacModule.cpp:261   powerStateDidChangeTo: flags=82 stateNumber=3

    02.08.11 08:24:58,000 kernel: /drv/ MacModule.cpp:262   powerStateDidChangeTo: found flag=kIOPMPowerOn (2)

    02.08.11 08:24:58,000 kernel: /drv/ MacModule.cpp:267   powerStateDidChangeTo: found flag=kIOPMRestartCapability (80)

    02.08.11 08:24:58,000 kernel: Previous Sleep Cause: 5

    02.08.11 08:24:58,000 kernel: The USB device Keyboard Hub (Port 3 of Hub at 0xfd000000) may have caused a wake by issuing a remote wakeup (2)

    02.08.11 08:24:58,000 kernel: The USB device Apple Keyboard (Port 2 of Hub at 0xfd300000) may have caused a wake by issuing a remote wakeup (3)

    02.08.11 08:24:58,000 kernel: HID tickle 160 ms

     

    so my first guess was I touched the keyboard or something but I definately did not. same with the mouse.

    does anyone have an idea?

  • 31. Re: My Mac don't go sleeping since Lion Update
    William Kucharski Level 6 Level 6 (14,705 points)

    khenjin wrote:

     

    so my first guess was I touched the keyboard or something but I definately did not. same with the mouse.

    does anyone have an idea?

     

    Is your keyboard plugged directly into your Mac?

  • 32. Re: My Mac don't go sleeping since Lion Update
    khenjin Level 1 Level 1 (0 points)

    yes, it is. no USB hub or similar inbetween.

  • 33. Re: My Mac don't go sleeping since Lion Update
    sander81 Level 1 Level 1 (0 points)

    Is there a way to enable sleep mode with internet sharing enabed?

    I googled very much, but i did not find a trick

  • 34. Re: My Mac don't go sleeping since Lion Update
    CndrllC Level 1 Level 1 (0 points)

    Same issue here.

     

    No printer, Internet, or sharing of any kind enabled.

     

    HDD to sleep when possible *IS* on.

     

    There is absolutly a trend / bug here.

  • 35. Re: My Mac don't go sleeping since Lion Update
    pencilman Level 1 Level 1 (0 points)

     

    This worked for me: In System Preferences click on Bluetooth, click on Advanced, uncheck "Allow Bluetooth devices to wake this computer.

     

    I have a Magic Trackpad and Targus Bluetooth mouse. I use my wired keyboard to wake my computer. I had the same sleep problems in Snow Leopard as well until I did this.

  • 36. Re: My Mac don't go sleeping since Lion Update
    CndrllC Level 1 Level 1 (0 points)

    Still not working...

  • 37. Re: My Mac don't go sleeping since Lion Update
    Thomas Moy1 Level 1 Level 1 (5 points)

    Add me to the list. 15" MacBook Pro, unibody circa 2009.  Internet sharing is off.  Bluetooth is off. Hard disk set to sleep when possible.  Even with power disconnected, computer does not sleep at 15 min as set.

     

    I guess I'll try resetting various PRAM, SMC etc.

  • 38. Re: My Mac don't go sleeping since Lion Update
    Steven Moore Level 2 Level 2 (160 points)

    Turning of file sharing after doing most of the above eventually sorted it. The only thing I didn't do was set the hard drive to sleep when possible.

  • 39. Re: My Mac don't go sleeping since Lion Update
    Axilla313 Level 1 Level 1 (0 points)

    I have the same problem, with the same messages in console. I have been trying everything for 4+ months.

     

    I took the computer (Macbook Pro purchased in March 2011) to Apple and they replaced the ribbon from the harddrive because they state some of the USB hubs including IR, work off that ribbon. The computer worked fine for about 24 hours and now it keeps waking form sleep AGAIN. I am really fed up.

     

    Are any of you with this problem using a Momentus XT DH and or Parallels?

  • 40. Re: My Mac don't go sleeping since Lion Update
    JPDy Level 1 Level 1 (0 points)

    Turning off internet sharing worked for me.

     

  • 41. Re: My Mac don't go sleeping since Lion Update
    khenjin Level 1 Level 1 (0 points)

    for me it worked unplugging the usb extension cable for the keyboard and plugging it back in.

  • 42. Re: My Mac don't go sleeping since Lion Update
    willObst Level 1 Level 1 (5 points)

    Same problem here with iMac i5 27'' :

     

    I had this "no sleep after idle time" Problem with SL and now with Lion.

     

    Screen and Printer Sharing WAS active --> no Automatic sleep :(

    Turned of all sharing: Same issue, still not going to sleep

     

    I called Applecare - they don't have any idea :-/

  • 43. Re: My Mac don't go sleeping since Lion Update
    willObst Level 1 Level 1 (5 points)

    Yesterday I did a clean install:

     

    Allthough it Should sleep After 1 min, it Takes 3 - 6 Minutes.

     

    At Night iMac did Not go to Sleep - don't Know Why.

     

    Mac is absolutely "clean installed" - nö other software.

     

    Any ideas? Maybe a hardware defect?

  • 44. Re: My Mac don't go sleeping since Lion Update
    Axilla313 Level 1 Level 1 (0 points)

    My computer is finally working correctly. It has been a week and a half without the wake problem.

     

    What did I do?

     

    System preferences->Security-> Disable the infared sensor.

     

    Also I had the screen cemera covered. I removed the tape that was covering the camera.

1 2 3 4 5 Previous Next