Skip navigation

Mac OS X Lion WiFi issues

114389 Views 262 Replies Latest reply: Oct 29, 2013 7:15 AM by chirodoody RSS
  • dtmwong Calculating status...
    Currently Being Moderated
    Aug 11, 2011 7:24 AM (in response to Ethanace)

    Hi guys, I've gotten the same problem on wifi connection after upgrading to Lion. I've complained and been waiting for the fix for almost 2 weeks... So frustrated!

  • GolfLeo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 13, 2011 12:48 AM (in response to ThaOne)

    I have managed to recreate the error (I have been error free for nearly a week) and then go back to normal operations again.

     

    What I did was:

    Error mode: set Channel to AUTO

    Working mode: set Channel fixed to 5.

     

     

    pls try it and verify yourself, but make sure you have a cable to connect your Mac to your APE, because when you can't get a wifi connection you can't change the channel either.

  • anthonyfromNJ Calculating status...
    Currently Being Moderated
    Aug 13, 2011 11:22 AM (in response to GolfLeo)

    I called into apple care and the rep offered a solution the problem which worked perfectly. 

    He mentioned that 7.1 would fix the issue for new users going forward.

     

    Steps to Fix

    1. Open Network Preferences

    2. Click Advanced

    3. Remove ALL of the Preferred Networks (should be completely empty when completed)

    4. Ensure that Remember Networks is checked

    5. Click OK

    6. Select your network in the Network Name dropdown menu

    7. Ensure that Ask to join networks is checked

    8. click Apply

    9. Restart your computer

    at this point you should be good to go!

  • dieswaytoofast Calculating status...
    Currently Being Moderated
    Aug 17, 2011 4:27 AM (in response to anthonyfromNJ)

    Yeah, that works, but its not really much of an option for those of us who have a whole bunch-a saved Networks, y'know?

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Aug 17, 2011 10:16 AM (in response to dieswaytoofast)

    dieswaytoofast,

    All you have to do when you go to a place that you had previously connected to, is pick it from the WiFI menu Extra and join. Your password etc. still stays saved in Keychain, so it's just the added extra step of manually joining the network. Your credentials etc. stay saved and you won't lose them.

  • Bango1808 Calculating status...
    Currently Being Moderated
    Aug 18, 2011 2:38 AM (in response to Ethanace)

    Hi guys,

    just share my experience with you.

    new iMac i5 with Lion received on last Thursday. After 5 minutes the troubles started, impossible to run properly the software update because of dropping wi-fi connection between the iMac and a time capsule!. On tuesday, I get Apple Support on the phone who recommends me a reinstall of Lion with the Recovery Utility. No improvement. Yesterday came 10.7.1 out. Even more frequent deconnection.

    Result: The iMac is on its way back to Apple for a complete replacement, This is the good news.

  • R_2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 18, 2011 9:09 AM (in response to Ethanace)

    update your lion to 10.7.1 and do these:

    1)reset smc

    2)reset pram

    it works well for me.i never face those wifi problem since.including the after sleep issues.

  • JPM-PL Level 1 Level 1 (40 points)
  • twitchy53 Calculating status...
    Currently Being Moderated
    Aug 20, 2011 3:47 PM (in response to R_2)

    I've also tried this suggestions with no effect.  Wifi doesn't drop on me, but it closes down and doesn't wake during sleep.  It shouldn't stop at all, for any reason unless it's been shut down.

  • lucciluccilucci Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2011 7:19 AM (in response to Ethanace)

    I have been on the phone with APPLE CARE this morning and they were very helpful and enabled me to fix my wifi issues.

     

    Before speaking with APPLE CARE I tried so many of the unusual little tricks on this board (and others) which seemed to be working uniquely for certain people. It turns out the problem in my case isn't LION as such, or my WiFi rather it's to do with the SECURITY on my ROUTER.

     

    I had an old MacBook at home which was very useful as I was easily able to make the adjusments on my Router through this to then later allow my new iMac (LION) to log on etc.

     

    I'm using a NETGEAR router, but the procedure will be much the same for other routers etc.

     

    What I did was sign in to my router (on my older MacBook in my case):

    http://192.168.0.1

     

    Put it my USERNAME and PASSWORD (which, by the way, is usually:

    USERNAME: admin

    PASSWORD: password

     

    Then selected WIRELESS SETTINGS.

     

    Within WIRELESS SETTINGS there is a subheading entitled WIRELESS SECURITY.

     

    Within WIRELESS SECURITY there are four options:

    1) Disable

    2) WEP (Wired Equivalent Privacy)

    3) WPA-PSK (Wi-Fi Protected Access Pre-Shared Key)

    4) WPA-802.1x

     

    I had

    2) WEP (Wired Equivalent Privacy)

     

    !! THIS WAS THE PROBLEM !!

     

    According to APPLE:

    WEP is being used less frequently as it appears to be not as SECURE as it's contemporaries (namely WPA etc). As a result LION struggles to communicate with the router using this security. BUT the good news is it CAN be easily changed!

     

    For a home setup Option 3:

    3) WPA-PSK (Wi-Fi Protected Access Pre-Shared Key)

    Seems to be the best option. Option 4 is a for a bigger setup (I wasn't listening too much, but apparently it's more suited to businesses using their own servers/networks etc?!).

     

    Next things we did was:

    SELECT OPTION 3:

    3) WPA-PSK (Wi-Fi Protected Access Pre-Shared Key)

     

    After selecting it asked me to enter a new password, so I did.

     

    Then I selected APPLY (or SAVE depending on your router). It took a minute to load...

     

    Then I went on to my new iMac (LION) clicked on

    SYSTEM PREF > NETWORK > ADVANCED and REMOVED (pressing the negative / '-' symbol) the network I've been struggling to get on for the last two days.

     

    Then ADDED (pressing the positive / '+' symbol) a 'new' network giving it the same title obviously as the one I had just deleted. It'll ask what SECURITY you want of the options, but just leave it as 'None' (as your WiFi will work it out itself). After this press ADD, then OK in the next window. Lastly press 'APPLY'.

     

    After this -  go up to your WiFi putton on your top bar, click it, then select the new network you've just created (which will of course have the same name as your old one) then when asked for a password put in your NEW ONE as you created on your ROUTER...

     

    ...Alas IT SHOULD WORK!

     

    It did for me, and the chap on the phone was so very useful and said this will be in the info they'll be putting on the discussion boards ASAP. I'm sorry if ym explanation has been a ittle convoluted as I'm not a techy person, but wanted to share this after sharing the struggle with so many.

     

    Good luck!

  • dieswaytoofast Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2011 9:54 AM (in response to lucciluccilucci)

    Doesnt work for me.

    Also, it wont work for the 'wifi goes off and wont come back on again' issue...

  • Keokimon Calculating status...
    Currently Being Moderated
    Aug 23, 2011 9:05 AM (in response to lucciluccilucci)

    Thanks! Worked for me to switch the security settings on my Netgear to from the setting "WPA-PSK [TKIP]" to the setting  "WPA-PSK [TKIP] + WPA2-PSK [AES]". So far so good. Hope the fix works throughout the day

  • VVesa Calculating status...
    Currently Being Moderated
    Aug 24, 2011 8:23 AM (in response to Ethanace)

    I also suffered from this problem, until now!!

     

    It seems that when upgrading to Lion, System.keychain and Login.keychains get somehow mixed up. All you need to do is to delete all Airport network passwords from both the System.keychain and Login.keychain.

     

    The steps to do:

     

    • Turn off Wi-FI
    • Open up Terminal and type

               sudo open /Library/Keychains/System.keychain

               This will open up the Keychain Access utility, with which you can delete all Airport network passwords.

    • After deleting the passwords, close the Keychain Access
    • Reboot
    • Log in and turn Wi-Fi on
    • Enjoy

     

    This fixed my problems, from which I suffered since upgrading from Snow Leopard to Lion. At least my Wi-Fi works now after rebooting and waking the computer from sleep.

1 2 3 4 ... 18 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.