6 Replies Latest reply: Jan 22, 2012 7:37 PM by Warwick Teale
Michael Sanders Level 1 Level 1 (0 points)

I've got three computers running Compressor 4 (two are running Lion but this didn't work before Lion so I'm taking that out of the equation.)

 

2 are Macbook Pro's (17" i7 unibody and 15" Core Duo), the other is a Core Duo Mac Mini.

 

When I try to encode a file using just the 17" and Mac Mini the share monitor just sits there waiting.  As far as I can tell everything is set right.  The 17" has the previous version of compressor and qmaster on it - albeit with sharing turned off.  Could that be the problem?

 

Any ideas welcome?

  • 1. Re: Has any one got a compressor 4 cluster to work with more than one computer?
    Bryson Jones Level 1 Level 1 (5 points)

    I'm seeing the exact same thing, basically. I'll bump this and I'm trying to get some Pro Apps guys involved.

     

    My client has 2 mini's running 10.6.8 and an xserve running Server 10.6.8 with Compressor 4.

     

    When we try to create a cluster, we can, but we then lose connection to it in the Qadministrator and it never shows up as an option to send a job to.

     

    The same thing happens when we use the Mini's alone.

     

    I've got three machines, that are matching, and we wipe and reclone them to get rid of settings and start over but after three times we're going back to Compressor 3.

     

    I ask as well, has anyone got a cluster running successfully with Compressor 4?

  • 2. Re: Has any one got a compressor 4 cluster to work with more than one computer?
    Chad West Level 1 Level 1 (5 points)

    I'm also trying to get compressor 4 to play nice with multiple machines, and although I have created a quickcluster being careful to make sure "Require theses services to only be used in managed clusters" is unchecked on the QuickCluster controller and the second machine is set as "services only".

     

    I've tried submitting the batch to the cluster and as "This computer Plus" and neither option seems to get my second computer involved.

     

    Any ideas??

  • 3. Re: Has any one got a compressor 4 cluster to work with more than one computer?
    Michael Sanders Level 1 Level 1 (0 points)

    The root of the problem could be this:

     

    Go to the following directory: /users/shared/library.

    In there is a directory called application support.

    Select it and get info on it.

    If its the pane is locked at the bottom, unlock it

    Set the permissions on everyone to Read and Write.

     

    You need to do it on all computers you want the use.

     

    There's a possiblity Adobe Air could be the culprit.

  • 4. Re: Has any one got a compressor 4 cluster to work with more than one computer?
    Chad West Level 1 Level 1 (5 points)

    Hi Michael,

     

    That didn't work for me.  Compressor is at least using all the cores on 1 computer, but it will not use the other computer.  I have tried trashing preferneces, restarting background processes and I tried changing the preferences as suggested, but to no avail. 

     

    It's interesting though, when I go to the "Administer Clusters" in the Apple Qmaster menu in compressor I can see that my Macbook has two instances shared-  but why is it not getting used??

  • 5. Re: Has any one got a compressor 4 cluster to work with more than one computer?
    Bryson Jones Level 1 Level 1 (5 points)

    Chad, are you seeing them greyed out? That's what we're getting. Once they've been added, there's no deleting and re-adding.

     

    Not ready for prime-time?

  • 6. Re: Has any one got a compressor 4 cluster to work with more than one computer?
    Warwick Teale Level 3 Level 3 (575 points)

    hi guys.. saw this while looking for resolution for another issue. I can confirm that I have another compressor cluster (macpro 4,1 w/ 16Vcores and an i7MAC MINI 8 vcores) and at times tested with a 3rd (a macbook air i7 (4 vcores) for a compressor transcode cluster and also Motion at times..A coupla things...

     

    1. make sure you have the Apple Compressor V4 Users Guide and the Apple Qmaster V4 Users guides around / on hand (pdfs). D/L from apple.
    2. check out the detail in ths procedure in this thread. https://discussions.apple.com/message/17356372#17356372%2317356372
    3. make sure you are using CLUSTERS for submision form FCPX and not computer plus. The later works but has enormous overheads as it will always copy source and destinations to the sahred cluster storage regardless of the compressor "copy / never copy" preferences. Any ideas there on that?
    4. good detail in QMAster manual . Frankly I have found that Quickclusters used to work ok under V3.5 .. but now I have administer a managed cluster using Apple Qadministrator.app

     

    post your results for others.

     

    warwick

    Hong Kong