Skip navigation

SMB Share

17724 Views 48 Replies Latest reply: Jan 25, 2012 12:24 AM by PumaTPG RSS Branched to a new discussion.
  • pvcooper Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 17, 2011 11:29 AM (in response to anderssonjohan)

    According to Apple the Netbiosd and the smbfs_mount shipped wilh Lion have no problems. I just hope that the .1 or patch release (whatever .2,.3,...) have address all the "no-problems" we are experienceing including the horrible open speed of a share on a windows or Samba/Linux machine.  Why didn't Lion come for free with a $29 initial 60 day 2 call support pack. Then GPL3 and Samba would have been addressed and all of the "no-problem" customers would have been saved thousands of hours tracking down bugs and only to be told that the issues do not exist when factual support is presented. The predominance of the folks who don't use microsoft networking would have been no burden.

     

    For serving up files off of apple machines (from an apple machine) I had to enable the Apple File Protocol or afp://aple-machine/share. For my linux Samba machines I set the security to plain old Wotkgroup and use smb://linux-samba-machine. My NAS has AFP has never been very reliable. It does not help a Windows machine connecting to the new netbiosd on the Apple Lion Machine. I believe there is a down grade in Lan Manager LM security on a windows machine that works in that case. It is posted previously or in another thread. I'm not sure whether a corporate policy will allow this downgrade in security but for many it will help.

  • CGraffix Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 17, 2011 2:19 PM (in response to pvcooper)

    SMB in 10.7.1 is still broke

     

    I have installed 10.7.1 and the problems still remain.  I did some testing with my sofware accessing data using 3 different methods and 2 different accounts, standards and admin.  From windows I can access data on 10.6.6, as well as an external drive with no problems.

     

    With Lion the problems remain,  irratic loggin request,  some times a can see data other times I can't.  CAD software always fails to access config files from  Lion but always works with snow leopard.

  • Kristopher Howard Calculating status...
    Currently Being Moderated
    Aug 17, 2011 3:19 PM (in response to CGraffix)

    You're not alone.  I have been having so many issues sharing files to a Windows machine (used for work) I've just given up until the issues are resolved (if ever).

     

    System worked flawlessly in Snow Leopard.

  • jingo_man Calculating status...
    Currently Being Moderated
    Aug 26, 2011 3:08 AM (in response to guruuno)

    i too am having this problem.

     

    under snow leopard, i had a whole bunch of smb shares defined. all accessed without issue (home network, so used "everyone" permissions on mac, then other machines had no issues connecting).

     

    have an xbmc install, with all sources pointed to these locations. it was configured using the "zeroconf" browsing option inside xbmc's new source setup (this is running Ubuntu Lucid 10.04 LTS)

     

    and then lion happened...

     

    same shares.

     

    xbmc can still see the imac as a zeroconf location. but unable to browse and it doesnt prompt for credentials.

     

    i have got over my rage and issues with this, as i needed to migrate this data to a new network-based solution anyway. which i now have in place... however, i would like a vm running windows server 2008 r2 to be able to use smb to access some locations on the mac so files can be shared.

     

    any method used to access this fails to work currently.

    windows explorer > map network drive. it prompts for credentials, but never accepts anything. tried plain "username", also tried "hostname\username", "ipaddress\username", "workgroupofmac\username". nothing works.

    command prompt > "net use" commands with various switches, with the same above username combinations.

     

    is there any difference with windows 7 and windows server 2008 r2?

     

    how are some people managing to get smb shares on os x lion limping into life? and most others cant??

     

    at top of this discussion is a link title "Branched to new discussion", but when i click that link, i am unauthorised. is this thread still even active? should i be able to get to this new discussion? is it a private thing for internal apple people demonstrating they are using the information provided here...?

  • CGraffix Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 26, 2011 9:01 AM (in response to jingo_man)

    On the Lion side try turning off SMB shares then back on again.  Then try to map your network drive or browse the networks from the windows side.   I must toggle SMB shares every time I reboot the Lion "server".

  • pvcooper Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 26, 2011 2:47 PM (in response to abross86)

    This couldnt be more accurate as I stated in put Samba Back Thread. The older version of Samba under a previous release of the GPL not v3 would be far better.

  • philldo_ca Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 3, 2011 3:55 PM (in response to guruuno)

    Some of you may be having the same problem we did, posted on this forum:

     

    http://www.mac-forums.com/forums/os-x-operating-system/246156-mapped-network-dri ve-issue-lion.html#post1320789

  • bvdecicco Calculating status...
    Currently Being Moderated
    Nov 16, 2011 8:35 AM (in response to Governa)

    I wonder how muCommander is communicating to the servers. I'm able to connect to SMB shares with mu that I cannot with the Finder. What's the difference? This is maddening!

  • Hibernian56 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Nov 28, 2011 1:09 PM (in response to guruuno)

    Well you know that the Apple holes have known about this since at least 10.5 and have of course ignored the issue, because they know better than everyone else and we should be using AFP anyway.

     

    Its our fault for not having a cool 100% mac environment.

     

    I'm once more googling for a proper fix to this as today my SMB shares decided to mount but not interact so I have wasted a whole day trying to fix this and failed and every person in th eoffice on their cool iMacs had a nice day browsing the internet because they couldn't access any drawings.

     

    Thank you Apple for being sooooo cool.

     

    As I said, complete Apple Holes...

  • ChiefExecutiveHacker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 7, 2011 2:19 PM (in response to JRansomed)

    Hi,

    JRansomed wrote:

     

    […]

     

    As best as I can tell, when we try to map a SMB or CIFS share from the GUI, it appears to send the username and password of the logged in user.  It appears to completely ignore any username you add to the url.

     

    I can confirm your findings. I am head of IT in a medium size enterprise. I am using a this year's MacBook Pro myself that runs 10.7.2. In the log files of our Windows 2008 R2 file server I can see the Mac logging in as user "xyz" although I typped "smb://domain;abc@server.example/home/abc" Thus, the Finder just happily ignores whatever username I provide.

     

    However, this is not the general case. Some other file shares that are at "server.example/groups/IT" can be reached without any problems. Using muCommander - as someone else suggested - works too. Furthermore, the good old terminal works also.

     

    Definitely the Finder or the dialogue to enter the credentials necessary for accessing a server is broken.

     

    But there is also a good story about 10.7. With 10.6 I sometimes had system crashes when unmounting an SMB share. With Lion that hasn't happened so far. If the connection to a server is broken, it might take long until the share is unmounted. But at least the system doesn't crash anymore …

  • ChiefExecutiveHacker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 7, 2011 2:33 PM (in response to ChiefExecutiveHacker)

    One thing more …

     

    It must be a problem of the Finder. In terminal, I typed

     

         mount_smbfs "//domain;abc@server.example/home/abc/" /Users/CEH/servershare/

     

    That worked. Then, I created an Alias of the fileshare and unmounted it. When I double click the Alias, again it starts using "xyz" as username instead of "abc."

     

    Using vi (or less) I see that the Alias file contains the right command (abc@server etc.). But no matter what I try, the Finder won't use "abc" and continues to use my local Mac username (xyz) to connect to the server :-(

  • Hibernian56 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 9, 2011 4:37 AM (in response to ChiefExecutiveHacker)

    Could you use an Apple Script instead of an Alias?

     

    It would be so much easier if Apple just got the finger out!!

  • ChiefExecutiveHacker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 10, 2011 9:44 AM (in response to Hibernian56)

    Hi,

     

    Thanks for your message.

    Hibernian56 wrote:

     

    Could you use an Apple Script instead of an Alias?

     

    Yes, that would be possible. But "Terminal.app" and I are good friends anyway ;-) So, I don't mind to type the necessary mount commands or to have them in a bash script.

     

     

    Hibernian56 wrote:


    It would be so much easier if Apple just got the finger out!!

     

    What astonishes me is the fact that the Finder sends my Mac's local login name instead of the username that I provide in the "Connect to Server" dialogue. The Finder happily ignores whatever I provide as a username. That's the real core of the problem. The rest (mounting, SMB file access etc.) works. It's just the Finder that doesn't care about a user's input.

     

    Best regards!

  • ChiefExecutiveHacker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 11, 2011 8:23 AM (in response to ChiefExecutiveHacker)

    Hi,

     

    the fault must be on Mac OS's side. I am working in a "heavy Windows" company. Most of the Macs belong to the marketing department. However, there are a few colleagues that use their private Mac too. One of this guys observes the exactely same problem like me. I never touched his machine, haven't even seen it. All I know is that he runs 10.7.2 like me …

     

    So this machine also cannot access the Windows fileserver through the Finder. Whenever he tries to connect to

     

         smb://domain;bcd@server.example/home/bcd/

     

    it fails. It works only from the command line. Like mine, his Mac username (blabla) is different from his Windows username (bcd). But the Finder insists on using the Mac username (blabla) even when the Windows username is provided to the Finder.

     

    I hope that Apple resolves this issue soon.

     

    Best regards

  • Alex Narvey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 28, 2011 5:51 PM (in response to guruuno)

    I have had success by modifying the SMB server prefs. Why Apple took this out of the GUI in Server app I don't know. But the plist files tell all.

     

    This is working for two different setups so far.

    1) Lion Server SMB sharing where the server is an Open Directory Replica of a Lion Server Open Directory Master

    2) Lion Server SMB sharing where this Lion server is merely bound to a Snow Leopard Server's Open Directory Master

     

    The smb server prefs file is located at:

    /Library/Preferences/SystemConfiguration/com.apple.smb.server

     

    I opened it up in TextWrangler (with Command Line Tools installed) and added the following (which were not already there):

     

    <key>AllowKerberosAuth</key>

              <true/>

    <key>AllowNTLM2Auth</key>

              <true/>

    <key>KerberosRealm</key>

    <string>USETHEEXACTSAMESTRINGASTHELOCALKERBEROSREALM</string>

    <key>Workgroup</key>

              <string>Workgroup</string>

     

    You can do it in command line if you like using methods similar to what is stated in Apple Tech Note: HT5038

    http://support.apple.com/kb/HT5038

     

    sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.smb.server AllowKerberosAuth -bool YES

     

    sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.smb.server AllowNTLM2Auth -bool YES

     

    sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.smb.server KerberosRealm -string USETHEEXACTSAMESTRINGASTHELOCALKERBEROSREALM

     

    sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.smb.server Workgroup -string Workgroup

     

    When you have completed the changes just stop the FileSharing in Server app and then start it up again.

     

    Presto. Windows XP and Windows 7 can log in:

     

    \\ServerName\ShareName

     

    name:  UserName  or  ODMASTERNAME\UserName (With Lion 10.7.2 you should only need the UserName

    password: password

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.