5 Replies Latest reply: Aug 10, 2012 4:27 PM by PhilClark
morganfromwinnipeg Level 1 Level 1 (0 points)

Situation:  My iMac purchased about a month ago is unable to boot up.  It has a white screen for about 2 min, the Mac OS CD in, and eventually gives the err "No bootable device -- insert boot diska nd prress a key". Unfortunately, the computer is unresponsive at this point.

 

History:  Here's how things got this way.  I have 1x 256 Gb SSD and 1x 1 Tb HD, with the Mac OS and my files installed on the former drive, nothing on the latter.  I ran the latest version of Bootcamp and ensured Mac OS Lion was up to date. Bootcamp told me I had to format HD first, using Disk Utility. I ran Disk Utility and formatted it for MS-DOS. Returning to Bootcamp is was happy with this and I clicked on things until it told me to insert the Win Install disk for Windows 7. I did so and upon recognising this Bootcamp reboot the computer and the Windows Install app ran. It identified there was a HD it could not install to and a SSD it could. This is wrong, and looking at the partitions it thought were there I knew it was right out to lunch. I cancelled out of it and told it to reboot. Upon rebooting I used the keyboard to eject the Win OS install disk. The iMac then started this cycle of not finding a bootable drive. Unconcerned, as I had not ever touched the SSD where everything was running from, nor installed or partially installed another OS on the other HD, I put in the Mac OS CD and rebooted.  Still I got this err sequence and have been unable to eject this CD. I feel my iMac is bricked and am looking for suggestions on how to proceed. I have tried booting up by holding the Option button to no avail. Advice?

 

Note:  In reading http://manuals.info.apple.com/en_US/boot_camp_install-setup_10.7.pdf I notice there is a similar error message with proposed solution, unfortunately I cannot follow the manual's suggestion, as follows. The manual says when the err msg "No boot disk attached", I should start my computer with the Mac OS and run Bootcamp. While a similar error it is not the same, and, I would love to do what it's telling me to do but I cannot get that far, so please avoid linking me to this doc/solution. Answers that end with "and then there will be cake" will be appreciated


iMac, Mac OS X (10.7.1)
  • 1. Re: "No bootable device", unable to eject Mac OS CD
    ScuseMe Level 2 Level 2 (215 points)

    To eject the CD, try holding the left mouse button down while booting your iMac. I had a similar situation not too long ago when installing Win7 x64 to my new Boot Camp partition. I was really getting nervous since I couldn't figure out how to eject the Win CD (so I could boot my SL disk). Grabbing a wired mouse and holding down the left mouse button while booting did the trick.

     

    Check here for more bootup key combinations - http://support.apple.com/kb/ht1533

  • 2. Re: "No bootable device", unable to eject Mac OS CD
    morganfromwinnipeg Level 1 Level 1 (0 points)

    Thank you ScuseMe, holding down the left-mouse button ejected the disk. Ironically, I will now reinsert it and hold down the "c" key to try and boot off the CD, as per the link you provided and report back.

     

    Message was edited by: morganfromwinnipeg changed "not" to "now"

  • 3. Re: "No bootable device", unable to eject Mac OS CD
    morganfromwinnipeg Level 1 Level 1 (0 points)

    ScuseMe, everything seems to be back to normal. Here's what I did.

     

    I followed your link to the shortcut keys that can be used during startup, pressing "C" during bootup to force it to read off the CD.  Looks like my personal hypothesis that Bootcamp changed the target boot drive to the unwriten disk, bypassing the Mac OS disc and the CD to boot up on was correct. Simply going to Utilities after booting up in the make-shift Lion OS environment and telling the computer to reboot using the Mac OS SSD has brought me back to square one at least, solving the problem of being stuck in a loop of reboots.

  • 4. Re: "No bootable device", unable to eject Mac OS CD
    ScuseMe Level 2 Level 2 (215 points)

    That's great!

     

    My old PC's DVD trays had a little hole where you could insert a paperclip and manually open the caddy. The first time I got a DVD stuck in my iMac, I instinctively ran to the desk and grabbed a paperclip

  • 5. Re: "No bootable device", unable to eject Mac OS CD
    PhilClark Level 1 Level 1 (0 points)

    Does anyone know how to get a paperclip out of a superdrive on an iMac. One of the "geniuses" where I work thought it would be a good idea to try using a paperclip taped to a stick to get an memory card out of the CD slot when the operator accidentally inserted it into the CD slot instead of the card slot. He THEN found the technique that worked (folded card stock cut into an L shape). But the Paperclip is still stuck somewhere inside the superdrive.

     

    Any suggestions? Or is this a take it in for service situation?