1 2 3 Previous Next 63 Replies Latest reply: May 27, 2014 8:35 AM by Kindleman
brendanmitchell Level 1 Level 1 (5 points)

Anyone else had this problem... after installing Lion today I cannot get audio out of the headphone socket, when I insert headphones (I've tried two pairs, both of which I know are working fine) the audio just continues to play via the built in speakers. Also, in the system prefs the headphone socket doesn't appear in the list as an output option, only Internal Speakers? It's as though the system doesn't recognise the headphone socket

 

any ideas greatly received

 

System

MacBook Pro 2.8 Ghz Intel Core 2 Duo, running 10.7 (Lion)


MacBook Pro, Mac OS X (10.7)
  • 1. Re: Audio issue (headphone output no working)
    LT300000 Level 1 Level 1 (0 points)

    I have the same problem.  I upgraded to Lion last night and tried to use my headphone today but it no longer works.  I also tried two different headphones which were both working fine previously, and got the same problem.  Also, as you mentioned, System Preferences/Sound/Output does not show Headphones as an option, only Internal Speakers.

    This appears to be a bug with Lion.

    Could someone from Apple look into this?

  • 2. Re: Audio issue (headphone output no working)
    uram Level 1 Level 1 (0 points)

    I'm having the same problem after a Lion upgrade.  No sound output from the audio port - it looks like the port is simply not recognizing when a plug is inserted.

     

    System

    2011 Macbook Pro 13" 2.3GHz i5, 10.7

  • 3. Re: Audio issue (headphone output no working)
    hohonuuli Level 1 Level 1 (0 points)

    I have the opposite problem. After upgrading to Lion, only my headphones work. My MacBook Pro's internal speakers don't work; the internal speakers also don't show up in System Preferences/Sound/Output. It might be noteworthy that I had my headphones plugged in when I ran the Lion upgrade. Any Apple Engineers have a fix for this?

  • 4. Re: Audio issue (headphone output no working)
    spudies2001 Level 1 Level 1 (0 points)

    I have the same problem, I am really getting iritated with this new Lion software. Why cant they figure out these bug before selling the product. Very irritting Does anyone know how to fix?

  • 5. Re: Audio issue (headphone output no working)
    LT300000 Level 1 Level 1 (0 points)

    Screen Shot 2011-07-25 at 10.47.32 AM.png

     

    Hello everyone,

    I think I have found a solution to this problem.  Go to Applications/Utilities/Audio MIDI Setup/Built-In Output/Output and in Format change from the default 2ch-24bit integer to any other format (say, 2ch-32bit float). This should activate the headphone jack.  I moved the format back to the original 2ch-24 integer setting and the headphones continued working.  So it seems that (for some reason) the original default setting does not recognize a headphone being inserted, but after performing this "resetting" it seems to come to its senses and behave properly from then on.

    Hope this works for you guys.

    Cheers,

    LT300000

  • 6. Re: Audio issue (headphone output no working)
    thisisjakea Level 1 Level 1 (0 points)

    Nope, doesn't work.  My problem is that NO AUDIO DEVICES ARE FOUND ON SYSTEM.  I tried to change the midi output, but nothing is there, because my computer is not recognizing any audio output.  this is a 2010 i7 imac and the audio worked great until a day ago. 

  • 7. Re: Audio issue (headphone output no working)
    A Jungemann Level 1 Level 1 (10 points)

    Weird! My issue was this: my speakers worked fine but when I plugged in my head phones, one ear was normal volume and the other was VERY quiet. I thought my jack was bad but when I followed the advice above, I found that the right channel was turned down really low. I am assuming the lion update scrambled something... luckily any of my issues have been resolved easily by reading on this forum.

  • 8. Re: Audio issue (headphone output no working)
    Richard Birkenhead Level 1 Level 1 (25 points)

    Same issue here.  Since upgrading to Lion, I have not been able to use headphones.  The audio does not switch over from the built-in speakers. A fix for this would be tremendously appreciated.

     

    MacBook Pro

    2.3 GHz Core i7

    4 GB memory

    running OS 10.7

  • 9. Re: Audio issue (headphone output no working)
    MYTMOUS_WP Level 1 Level 1 (0 points)

    MacBook 2010 Edition 4GB

     

    Upgraded to LION earlier, had this problem.

     

    Sorted

     

    Many Thanks

     

    Solution:

    Applications/Utilities/Audio MIDI Setup/Built-In Output/Output and in Format change from the default 2ch-24bit integer to any other format (say, 2ch-32bit float).

  • 10. Re: Audio issue (headphone output no working)
    Thruhiker74 Level 1 Level 1 (10 points)

    Just to keep the ball rolling.  Same problem with the external audio here on my iMac.  Internal speakers work but analog audio jack no longer appears to be recognized.  Tried all the "fixes" above with no luck--system>pref>audio, Audio Midi Setup (which by the way, I don't even have an option for 32bit float), safe mode reboot, epram reboot, repair permissions.  Heck, I even did the system restore reboot and ran disk repair and permissions repair from there, Linux command line interaction with audio files.  I've also re-installed the OS 3 times out of desperation.  Nothing helps.

    I've now been fooled into installing Lion OS onto two machines.  Both have had issues--different issues.  Very rough release Apple.  Shame shame.

    If anyone out there knows what is really going on with this, do us all a favor and patch it in an update for Apple.

  • 11. Re: Audio issue (headphone output no working)
    fourztar Level 1 Level 1 (0 points)

    I`m having the same problem on my 2009 MBP.  I have tried a couple of regular headphones and none of them will be recognized.  However, there is no problem when i use the iphone headphones or iBeats.  It seems like the mbp will only recognize headphones with a microphone.  I noticed that these headsets have three of those black circles on the jack-plug, and normal headsets only have two.

     

    Edit: Tried with an optical cable also, worked without a problem.

  • 12. Re: Audio issue (headphone output no working)
    Lukas777 Level 1 Level 1 (5 points)

    I have had the same problem on my Aluminium MB (Late 2008). Neither the jack or the internal speakers would work. After I restarted the internal speakers were working but the jack was still not. I read this post and then trued another restart and now both are working fine again. Hope that helps.

  • 13. Re: Audio issue (headphone output no working)
    mikehammon Level 1 Level 1 (0 points)

    I solved (sort of) this issue for me today. It seems that if you have an ordinary stereo plug (the one with two dividers in contrast to three on the iphone headphones) you can only choose between external input OR external output.

     

    So to get the external output working, you have to go to "System Settings" -> "Sound" and then at the bottom, set "Use audio port for" to Sound Output.

     

    That did it for me at least...

  • 14. Re: Audio issue (headphone output no working)
    smokinjoev Level 1 Level 1 (0 points)

    Same problem with disappearing audio.   Upgraded a late 2009 Mini MB464LL.   After Lion, all my sound is gone.  This is my HTPC, so its a critical issue.   Hope a solution appears soon

1 2 3 Previous Next