Skip navigation

can't edit events on ical

12454 Views 20 Replies Latest reply: Nov 14, 2012 10:03 AM by kwh_tyro RSS
  • editortom Calculating status...
    Currently Being Moderated
    Jan 8, 2011 2:56 PM (in response to loebtmc)
    Jan 7th, 2011: Same problem here. MacPro OS 10.5.8 (ie NOT snow leopard, as is the case for some of the other posters on this thread). Out of the blue, lost the ability to edit events in iCal. None of the typical fixes (permissions, preferences, etc) work. This is a bummer. Where is Apple tech support? Love all the new gadgets they're making, but if the existing ones aren't supported, what good are they?
    MacPro, Mac OS X (10.5.8)
  • shmeck Level 1 Level 1 (20 points)
    Currently Being Moderated
    Mar 1, 2011 8:36 PM (in response to editortom)
    Same issue: suddenly I can't edit events -- edit window doesn't appear unless I hit F10. When I click it after hitting F10, it just vanishes behind iCal. This is a major productivity jam for me, as I use iCal like crazy to schedule.
    MacBookPro, Mac OS X (10.5.8)
  • David Patridge Calculating status...
    Currently Being Moderated
    Apr 15, 2011 10:37 AM (in response to shmeck)
    All of my trouble went away after I opened Font Book, selected ALL of my fonts, selected "Resolve Duplicates" under the Edit menu. Voila.
  • asmystiq Calculating status...
    Currently Being Moderated
    Aug 30, 2011 11:56 PM (in response to loebtmc)

    Having a similar problem and doing the Font Book trick did not do it. Once the calendar event is created, I cannot change the start or end dates/times. Can add a note and change the title. Any help on this? Thanks.

  • Colin Mann Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 2:58 AM (in response to loebtmc)

    Having the same problems on my MacPro. I can open my events editing window and edit everything in the event except the title of the event. I have also done everything suggested on this link, to no avail. Even tried trashing all my calendars and creating a new one. Does the same. Yet the same calendar is running on my Macbook with no problem. Could this be an issue unrelated to iCal. Maybe a permissions issue?

  • kwh_tyro Calculating status...
    Currently Being Moderated
    Nov 14, 2012 10:03 AM (in response to David Patridge)

    mine too! the font book tricked worked, but i had to quit ical and open it back up before the problem went away.  (my edit box was also vanishing behind ical when it had been working fine for years).  so try the fontbook trick, quit ical and open it back up. 

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.