Skip navigation

Install Xcode from the App Store = Deleted System

20862 Views 65 Replies Latest reply: Sep 10, 2011 11:08 AM by Paulyboy69 RSS
  • JGH60 Calculating status...
    Currently Being Moderated
    Jul 21, 2011 10:05 PM (in response to tforcade)

    Be warned just installed Lion,  found old xcode did not work with lion so downloaded new Lion version from App Store.  Installed and trashed my system as before


    One bright note was able to do a total restore from Time Machine with new recovery part of Lion,  really a great improvement so no more trips to Genius Bar for that


    Now to find out why.  Thinking of removing all firewire disks (for safety)

    Delete old installation (now useless with Lion)

    Having no apps running

    Stopping iTunes as per some comments on web

    Stopping screen saver


    Any other ideas?

  • sirtimp Calculating status...
    Currently Being Moderated
    Jul 22, 2011 6:36 AM (in response to JGH60)

    Wow, still wiped your system?? Insane.. Nice that you have the Time Machine backup..


    Try this: Make sure you have removed  the old Macintosh HD/Developer folder, AND the old Tools folder, located in /Applications/Installers


    That worked for me with the 4.0.2 installer a few months ago

  • harv47 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 22, 2011 8:07 AM (in response to sirtimp)

    You would think, after the 4.0.2 installer fiasco, that they would have either fixed the problem or at least listed some precautions.

  • JGH60 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 23, 2011 7:07 AM (in response to sirtimp)

    So here goes with my way of doing it,  there are a lot of moving variables here so dificult be sure of the right path


    Removed the files and folders associated with the old xcode installation,  thanks for the heads up on the installers folder


    Now for the wobbly bit,  I cleaned up my applications folder using App zap got rid of apps I had not used or moved on from,  including all the PPC and classic apps that are now dead. I have always believed the app base was part of the problem because I managed an install on a clean Leopard installation,  and the Genius Bar managed it on a reinstall of Leopard when the 3rd apps were not yet recoved.  So this is my feeling no facts to support it.




    Downloaded xcode (Lion)

    Restarted computer

    Copied Xcode Installer to desktop

    Deleted Xcode Installer (inc empty trash) from Applications folder

    Exited all apps and ejected all my firewire disks

    Right click on Xcode Installer, Select Show Package Contents, navigate to Resourses folder and open it, find Xcode.mpkg and double click on it,  follow the instructions and 10 mins later Xcode is up and running


    Hope this helps people

  • ssachs02 Calculating status...

    Same problem here:


    1.  Installed Lion

    2.  Downloaded Xcode 4.1.1 via Apple Store

    3.  Opened Install

    4.  (came back to office to find applications disappearing)


    This is truly outrageous.

  • Paulyboy69 Level 1 Level 1 (0 points)

    Another (almost) XCode victim here. I already posted this on the Inside Mac Games forums so reposting here to add to the discussion.




    Upon Smoke_Tetsu's recommendation I decided to download and install Xcode from the Mac App Store because it's apparently required for Wine to work correctly in Mac OS Lion. I was hoping to create some new functional wrappers for the wrapped games that broke in Lion. So it seemed this would all be as simple as downloading Xcode from the Mac App Store and running the installer because everything “just works” right? Wrong.


    First it took me several tries just to download Xcode successfully. The download kept getting error messages when about halfway complete. When I finally got the installer downloaded I launched it yesterday afternoon without a second thought. Fortunately I didn't wander away from my computer for long. When I came back in about 15 minutes the installation still appeared to have a while to go so I decided to multitask. I went to open another application (I don't remember which) and it wasn't present in the shortcut folder in my dock. So when I opened the application folder in the Finder I noticed all applications from “A” to “L” were gone! I then also noticed the little shortcut applications folder icon in the dock was flashing different icons at a reasonable pace, pausing occasionally. I recognized the icons as those of applications so I opened up the application window in the Finder again and before my very eyes applications were vanishing in alphabetical order! I quickly did a Google search in Safari about the issue and almost immediately discovered that this is a pretty widespread problem. I only read a few messages but what I read in those few messages was enough to scare the crap out of me and make me panic! The Xcode installation for other people had completely wiped their internal hard drives AND all external drives connected to their computers at the time! So I quickly tried to abort the installation (at the time it was about 35 percent complete) but that didn't work so I did a force quit which did work. I then checked my applications folder and it was completely empty! Fearing where else it might have ravaged my hard drive and my three connected external drives I decided to restart and hope for the best. Unfortunately all I got was a blue screen. By this time I was totally freaking out! So I tried restarting again while holding the option key down which did thankfully get me into the emergency menu where I was able to use Disk Utility to check all my drives. They were all there but the internal hard drive was missing about 400 gigabytes out of what used to be about 700 gigabytes! But fortunately the external drives weren't affected, one of which is my Time Machine backup, so I was able to restore from a Time Machine backup that was made right before the installation of Xcode. It took about 5 hours to restore but everything is back to normal. Thank God! But if you check out some of the various threads about this others weren't so lucky unfortunately. I guess I was able to interrupt the process in time.


    I've been using Apple Mac computers for 25 years and I've never encountered anything like this. This is just inexcusable on Apple's part and the fact that people have been reporting this issue since March and Apple has yet to publicly address it is even worse. Apple lost some big-time respect from me over this.


    As for Xcode, if you read through all the threads you might notice that some people have discovered a workaround to get Xcode installed without wreaking havoc on their systems. That's all fine and good but I'm not touching Xcode with a 10 foot pole until Apple publicly addresses this issue and the danger is gone. Utterly ridiculous!


    Here's some links to some of the threads:





1 2 3 4 5 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.